]> git.pld-linux.org Git - packages/perl-POE.git/blame - perl-POE.spec
- up to 1.367
[packages/perl-POE.git] / perl-POE.spec
CommitLineData
3cc62918 1#
2# Conditional build:
d68844b4 3%bcond_without tests # do not perform "make test"
3cc62918 4#
5%include /usr/lib/rpm/macros.perl
601627ed 6%define pdir POE
a61a7cb5 7Summary: POE - multitasking and networking framework for Perl
e98149ff 8Summary(pl.UTF-8): POE - wielozadaniowe i sieciowe środowisko dla Perla
3cc62918 9Name: perl-POE
53291eac 10Version: 1.367
d2de4fdf 11Release: 1
64ed78f8 12Epoch: 2
3cc62918 13# same as perl
a61a7cb5 14License: GPL v1+ or Artistic
3cc62918 15Group: Development/Languages/Perl
944e3949 16Source0: http://www.cpan.org/modules/by-module/POE/%{pdir}-%{version}.tar.gz
53291eac 17# Source0-md5: 9b2e4375152b139e4ab5f7dfb2cc5b15
3cc62918 18URL: http://poe.perl.org/
c24bed54 19BuildRequires: perl-devel >= 1:5.8.0
3cc62918 20BuildRequires: rpm-perlprov >= 4.1-13
f4f8fd68 21BuildRequires: perl-Test-Simple >= 0.54
d68844b4 22%if %{with tests}
3cc62918 23BuildRequires: perl(Filter::Util::Call) >= 1.04
03d3f0b1 24BuildRequires: perl-IO-Compress
3cc62918 25BuildRequires: perl-Curses
26BuildRequires: perl-Event
03d3f0b1 27BuildRequires: perl-IO-Tty >= 1.08
19c3ac1f 28BuildRequires: perl-Socket6 >= 0.14
29BuildRequires: perl-Storable >= 2.12
30BuildRequires: perl-Term-ReadKey >= 2.21
31BuildRequires: perl-Time-HiRes >= 1.59
32BuildRequires: perl-URI >= 1.30
3cc62918 33BuildRequires: perl-libwww
34%endif
0cb05eca 35Conflicts: perl-POE-Filter-XML < 0.29
78fe800a 36Obsoletes: perl-POE-Exceptions
3cc62918 37BuildArch: noarch
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
67b52fc5 40%define _noautoreq perl(Curses) perl(HTTP::Date) perl(HTTP::Request) perl(HTTP::Response) perl(HTTP::Status) perl(URI) perl(Term::Cap) perl(Term::ReadKey) perl(Tk)
3cc62918 41
42%description
43POE is an acronym of "Perl Object Environment". It's a networking
44and multitasking (some say cooperative threading) framework for Perl.
45It has been in active development since 1996, with its first open
46release in 1998. O'Reilly's Perl Conference (now OSCON) named POE
47"Best New Module" in 1999.
48
49POE has been used in mission-critical systems such as internetworked
50financial markets, file systems, commerce and application servers.
51It has been used in projects ranging from a few lines of code to tens
52of thousands.
53
54POE is compatible with perl versions as old as 5.005_03.
55
56POE includes an evolving component framework. Components are high-level,
57modular, reusable pieces of programs. Several components have been
58published on the CPAN, and more are listed on POE's web site.
59
60POE includes components and libraries for making quick work of network
61clients, servers, and peers. A simple stand-alone web application takes
62about 30 lines of code, most of which is your own custom logic.
63
43b3d8a9
JR
64%description -l pl.UTF-8
65POE to skrót od "Perl Object Environment" (co oznacza "środowisko
66obiektowe Perla"). Jest to szkielet obsługi sieci i wielozadaniowości
67(nazywanej przez niektórych "kooperatywnym wątkowaniem") dla Perla.
a61a7cb5 68Jest aktywnie rozwijane od 1996 roku, a pierwsze publiczne wydanie
43b3d8a9
JR
69było w 1998 roku. Na O'Reilly's Perl Conference (teraz OSCON) w 1999
70roku POE zostało nazwane "Najlepszym nowym modułem".
a61a7cb5 71
43b3d8a9
JR
72POE jest używane w systemach mission-critical, takich jak
73międzysieciowe rynki finansowe, systemy plików, serwery aplikacji i
74handlowe. Jest używane w projektach o rozmiarach od kilku linii do
75dziesiątek tysięcy.
a61a7cb5
JB
76
77POE jest kompatybilne z Perlem od wersji 5.005_03.
78
43b3d8a9
JR
79POE zawiera rozwijający się szkielet komponentów. Komponenty to
80wysokopoziomowe, modularne, dające się wielokrotnie wykorzystywać
81kawałki programów. Część komponentów została opublikowana w CPAN,
82więcej można znaleźć na stronie WWW POE.
a61a7cb5 83
43b3d8a9
JR
84POE zawiera komponenty i biblioteki do szybkiego tworzenia klientów,
85serwerów i partnerów sieciowych. Prosta, samodzielna aplikacja WWW
86zajmuje około 30 linii kodu, z których większość to właściwa logika.
3cc62918 87
88%prep
89%setup -q -n %{pdir}-%{version}
2b724f66 90rm -f lib/POE/Filter/HTTPD.pm{~.orig}
3cc62918 91
92%build
93%{__perl} Makefile.PL \
94 INSTALLDIRS=vendor \
95 --default
96%{__make}
97
19c3ac1f 98%{?with_tests:%{__make} test}
3cc62918 99
3cc62918 100%install
101rm -rf $RPM_BUILD_ROOT
2886c094 102install -d $RPM_BUILD_ROOT%{perl_vendorlib}/POE/{Component/CD,Session}
3cc62918 103
104%{__make} install \
105 DESTDIR=$RPM_BUILD_ROOT
39d5068c 106install -d $RPM_BUILD_ROOT%{_examplesdir}
89920b49 107cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
39d5068c 108
3cc62918 109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files
113%defattr(644,root,root,755)
19c3ac1f 114%doc CHANGES HISTORY README TODO
39d5068c 115%{perl_vendorlib}/*.pm
2886c094 116%{perl_vendorlib}/POE
89920b49 117%dir %{_examplesdir}/%{name}-%{version}
118%{_examplesdir}/%{name}-%{version}/README*
119%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.perl
3cc62918 120%{_mandir}/man3/*
This page took 0.093668 seconds and 4 git commands to generate.