]> git.pld-linux.org Git - packages/perl-Math-expr_eval.git/blame - perl-Math-expr_eval.spec
use generic url
[packages/perl-Math-expr_eval.git] / perl-Math-expr_eval.spec
CommitLineData
90bd14af
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
669efb2c 4
35d593d9 5%define pdir Math
6%define pnam expr_eval
669efb2c 7%include /usr/lib/rpm/macros.perl
90bd14af 8Summary: Math::expr_eval - an expression evaluator
98912dfe 9Summary(pl.UTF-8): Math::expr_eval - obliczanie wyrażeń
669efb2c 10%define _ver %(echo %{version} | tr . _)
90bd14af
JB
11Name: perl-Math-expr_eval
12Version: 1.0
7b059979 13Release: 2
90bd14af
JB
14# same as perl
15License: GPL v1+ or Artistic
16Group: Development/Languages/Perl
a2324ba2 17Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}_%{_ver}.zip
90bd14af 18# Source0-md5: f4962039a99c1dddf460291b1cf5feff
669efb2c 19URL: http://search.cpan.org/dist/Math-expr_eval/
d845c1b3 20BuildRequires: perl-devel >= 1:5.8.0
90bd14af 21BuildRequires: rpm-perlprov >= 4.1-13
98288873 22BuildRequires: unzip
90bd14af
JB
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27This module is an expression evaluator. It has three main objectives:
28efficiency, extensibility, user-friendly error messages. It's features
29include: standard data types, arithmetic and boolean operators,
30conditionals, pattern matching, user-defined data types, user-defined
31binary operators and prefix unary operators, over-loaded binary
32operators and prefix unary operators, calls to user-provided perl
33functions, a mode for syntax checking only, optimized re-evaluation of
34expressions, multiple symbol tables.
35
a10e0a0a
JR
36%description -l pl.UTF-8
37Ten moduł służy do obliczania wyrażeń. Ma trzy główne cele: wydajność,
38rozszerzalność i przyjazne dla użytkownika komunikaty błędów. Jego
39możliwości obejmują: standardowe typy danych, operatory arytmetyczne i
40logiczne, warunki, dopasowywanie wzorców, definiowalne typy danych,
90bd14af 41definiowalne operatory dwuargumentowe i prefiksowe jednoargumentowe,
a10e0a0a
JR
42przeciążone operatory dwuargumentowe i prefiksowe jednoargumentowe,
43wywołania dostarczonych funkcji Perla, tryb do sprawdzania składni,
44zoptymalizowane ponowne obliczanie wyrażeń, wiele tablic symboli.
90bd14af
JB
45
46%prep
47%setup -q -c
48
49mv -f Makefile.pl Makefile.PL
50
51%build
52%{__perl} Makefile.PL \
53 INSTALLDIRS=vendor
54
55%{__make}
56
57%{?with_tests:%{__make} test}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%{__make} install \
63 DESTDIR=$RPM_BUILD_ROOT
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc Changes README
71%{perl_vendorlib}/Math/expr_eval.pm
This page took 0.092912 seconds and 4 git commands to generate.