]> git.pld-linux.org Git - packages/perl-List-MoreUtils.git/blame - perl-List-MoreUtils.spec
- release 4 (by relup.sh)
[packages/perl-List-MoreUtils.git] / perl-List-MoreUtils.spec
CommitLineData
681cdd43
AG
1#
2# Conditional build:
c5c48ecd 3%bcond_without tests # do not perform "make test"
681cdd43
AG
4#
5%include /usr/lib/rpm/macros.perl
3deef84b 6%define pdir List
7%define pnam MoreUtils
681cdd43 8Summary: List::MoreUtils - provide the stuff missing in List::Util
c22cb832 9Summary(pl.UTF-8): List::MoreUtils - dostarczenie elementów brakujących w List::Util
681cdd43 10Name: perl-List-MoreUtils
cbed697a 11Version: 0.33
7a7a4848 12Release: 4
681cdd43
AG
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
8d1f8f43 16Source0: http://www.cpan.org/modules/by-module/List/%{pdir}-%{pnam}-%{version}.tar.gz
cbed697a 17# Source0-md5: 8a33c84028cc2ff3e92c92434b326c0f
681cdd43 18URL: http://search.cpan.org/dist/List-MoreUtils/
8d1f8f43
JB
19BuildRequires: perl-ExtUtils-MakeMaker >= 6.52
20BuildRequires: perl-ExtUtils-CBuilder >= 0.27
681cdd43
AG
21BuildRequires: perl-devel >= 1:5.8.0
22BuildRequires: rpm-perlprov >= 4.1-13
8d1f8f43
JB
23%if %{with tests}
24BuildRequires: perl-Test-Simple >= 0.82
25%endif
681cdd43
AG
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29List::MoreUtils provides some trivial but commonly needed
30functionality on lists which is not going to go into List::Util.
31
32All of the below functions are implementable in one line of Perl code.
33Using the functions from this module however should give slightly
34better performance as everything is implemented in C. The pure-Perl
35implementation of these functions only serves as a fallback in case
36the C portions of this module couldn't be compiled on this machine.
37
73092f16
JR
38%description -l pl.UTF-8
39List::MoreUtils dostarcza prostych, ale często potrzebnych funkcji do
40operacji na listach - elementy, które nie zostaną dołączone do
681cdd43
AG
41List::Util.
42
73092f16
JR
43Wszystkie z funkcji są możliwe do implementowania w jednej linijce
44kodu Perla. Używanie funkcji z tego modułu może jednak dać odrobinę
45większą wydajność jako, że całość została napisana w C. Implementacja
46napisana w Perlu służy w sytuacjach wyjątkowych w przypadkach, gdy
47elementy modułu napisane w C nie mogą zostać skompilowane na maszynie.
681cdd43
AG
48
49%prep
50%setup -q -n %{pdir}-%{pnam}-%{version}
51
52%build
53%{__perl} Makefile.PL \
54 INSTALLDIRS=vendor
55
56%{__make} \
40f24203 57 CC="%{__cc}" \
681cdd43
AG
58 OPTIMIZE="%{rpmcflags}"
59
60%{?with_tests:%{__make} test}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65%{__make} install \
66 DESTDIR=$RPM_BUILD_ROOT
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%files
72%defattr(644,root,root,755)
73%doc Changes README
bc681e13 74%dir %{perl_vendorarch}/List
beab3ee4
JB
75%{perl_vendorarch}/List/MoreUtils.pm
76%dir %{perl_vendorarch}/auto/List/MoreUtils
beab3ee4 77%attr(755,root,root) %{perl_vendorarch}/auto/List/MoreUtils/MoreUtils.so
0ceff4ff 78%{_mandir}/man3/List::MoreUtils.3pm*
This page took 0.068648 seconds and 4 git commands to generate.