]> git.pld-linux.org Git - packages/perl-HTTP-Cookies.git/blame - perl-HTTP-Cookies.spec
- up to 6.06
[packages/perl-HTTP-Cookies.git] / perl-HTTP-Cookies.spec
CommitLineData
38cfe823
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir HTTP
6%define pnam Cookies
7%include /usr/lib/rpm/macros.perl
8Summary: HTTP::Cookies - HTTP cookie jars
9Summary(pl.UTF-8): HTTP::Cookies - pojemnik na ciasteczka HTTP
10Name: perl-HTTP-Cookies
56a6678a 11Version: 6.06
38cfe823
JB
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/HTTP/%{pdir}-%{pnam}-%{version}.tar.gz
56a6678a 17# Source0-md5: 1edfc54f36cb7eb192637c553d0eab7f
38cfe823
JB
18URL: http://search.cpan.org/dist/HTTP-Cookies/
19BuildRequires: perl-devel >= 1:5.8.8
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-HTTP-Date >= 6
23BuildRequires: perl-HTTP-Message >= 6
24%endif
3d65d648
JB
25Requires: perl-HTTP-Date >= 6
26Requires: perl-HTTP-Message >= 6
38cfe823
JB
27Conflicts: perl-libwww < 6
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32This class is for objects that represent a "cookie jar" -- that is, a
33database of all the HTTP cookies that a given LWP::UserAgent object
34knows about.
35
36This module implements the old style cookies as well as the new style
37cookies described in RFC 2965.
38
39Instances of the class HTTP::Cookies are able to store a collection
40of Set-Cookie2: and Set-Cookie: headers and are able to use this
41information to initialize Cookie-headers in HTTP::Request objects.
42The state of a HTTP::Cookies object can be saved in and restored from
43files.
44
45%description -l pl.UTF-8
46Klasa HTTP::Cookies jest przeznaczona dla obiektów reprezentujących
47"pojemniki na ciasteczka" - tzn. bazę danych wszystkich ciasteczek
48HTTP, jakie zna dany obiekt LWP::UserAgent.
49
50Ten moduł implementuje ciasteczka starego typu, jak i nowego,
51opisanego w RFC 2965.
52
53Instancje klasy HTTP::Cookies mogą przechowywać zbiór nagłówków
54Set-Cookie2: oraz Set-Cookie: i wykorzystywać te informacje do
55zainicjowania nagłówków Cookie w obiektach HTTP::Request. Stan
56obiektu HTTP::Cookies można zapisać w pliku, a później z niego
57odtworzyć.
58
59%prep
60%setup -q -n %{pdir}-%{pnam}-%{version}
61
62%build
63%{__perl} Makefile.PL \
64 INSTALLDIRS=vendor
65%{__make}
66
67%{?with_tests:%{__make} test}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%{__make} pure_install \
73 DESTDIR=$RPM_BUILD_ROOT
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
79%defattr(644,root,root,755)
3d65d648 80%doc Changes
38cfe823
JB
81%{perl_vendorlib}/HTTP/Cookies.pm
82%{perl_vendorlib}/HTTP/Cookies
83%{_mandir}/man3/HTTP::Cookies*.3pm*
This page took 0.047147 seconds and 4 git commands to generate.