]> git.pld-linux.org Git - packages/perl-HTTP-Cookies.git/blame - perl-HTTP-Cookies.spec
- updated docs and dependencies
[packages/perl-HTTP-Cookies.git] / perl-HTTP-Cookies.spec
CommitLineData
38cfe823
JB
1#
2# Conditional build:
0a96adbe 3%bcond_without tests # unit tests
38cfe823
JB
4#
5%define pdir HTTP
6%define pnam Cookies
38cfe823
JB
7Summary: HTTP::Cookies - HTTP cookie jars
8Summary(pl.UTF-8): HTTP::Cookies - pojemnik na ciasteczka HTTP
9Name: perl-HTTP-Cookies
9f86c16a 10Version: 6.08
38cfe823
JB
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/HTTP/%{pdir}-%{pnam}-%{version}.tar.gz
9f86c16a 16# Source0-md5: 8c663710244e70c85775393a8f5be443
0a96adbe 17URL: https://metacpan.org/release/HTTP-Cookies
38cfe823
JB
18BuildRequires: perl-devel >= 1:5.8.8
19BuildRequires: rpm-perlprov >= 4.1-13
0a96adbe 20BuildRequires: rpmbuild(macros) >= 1.745
38cfe823
JB
21%if %{with tests}
22BuildRequires: perl-HTTP-Date >= 6
23BuildRequires: perl-HTTP-Message >= 6
0a96adbe
JB
24BuildRequires: perl-Test-Simple
25BuildRequires: perl-URI
38cfe823 26%endif
3d65d648
JB
27Requires: perl-HTTP-Date >= 6
28Requires: perl-HTTP-Message >= 6
38cfe823
JB
29Conflicts: perl-libwww < 6
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34This class is for objects that represent a "cookie jar" -- that is, a
35database of all the HTTP cookies that a given LWP::UserAgent object
36knows about.
37
38This module implements the old style cookies as well as the new style
39cookies described in RFC 2965.
40
41Instances of the class HTTP::Cookies are able to store a collection
42of Set-Cookie2: and Set-Cookie: headers and are able to use this
43information to initialize Cookie-headers in HTTP::Request objects.
44The state of a HTTP::Cookies object can be saved in and restored from
45files.
46
47%description -l pl.UTF-8
48Klasa HTTP::Cookies jest przeznaczona dla obiektów reprezentujących
49"pojemniki na ciasteczka" - tzn. bazę danych wszystkich ciasteczek
50HTTP, jakie zna dany obiekt LWP::UserAgent.
51
52Ten moduł implementuje ciasteczka starego typu, jak i nowego,
53opisanego w RFC 2965.
54
55Instancje klasy HTTP::Cookies mogą przechowywać zbiór nagłówków
56Set-Cookie2: oraz Set-Cookie: i wykorzystywać te informacje do
57zainicjowania nagłówków Cookie w obiektach HTTP::Request. Stan
58obiektu HTTP::Cookies można zapisać w pliku, a później z niego
59odtworzyć.
60
61%prep
62%setup -q -n %{pdir}-%{pnam}-%{version}
63
64%build
65%{__perl} Makefile.PL \
66 INSTALLDIRS=vendor
67%{__make}
68
69%{?with_tests:%{__make} test}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74%{__make} pure_install \
75 DESTDIR=$RPM_BUILD_ROOT
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(644,root,root,755)
0a96adbe 82%doc CONTRIBUTORS Changes
38cfe823
JB
83%{perl_vendorlib}/HTTP/Cookies.pm
84%{perl_vendorlib}/HTTP/Cookies
85%{_mandir}/man3/HTTP::Cookies*.3pm*
This page took 0.082475 seconds and 4 git commands to generate.