]> git.pld-linux.org Git - packages/perl-Guard.git/blame - perl-Guard.spec
- updated URL and macros
[packages/perl-Guard.git] / perl-Guard.spec
CommitLineData
82cd5b17 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
82cd5b17 5%define pdir Guard
6Summary: Guard - safe cleanup blocks
7Summary(pl.UTF-8): Guard - bezpieczne czyszczenie bloków
8Name: perl-Guard
48e6a324 9Version: 1.023
234b8afa 10Release: 7
fe39478d
JB
11# same as perl
12License: GPL v1+ or Artistic
82cd5b17 13Group: Development/Languages/Perl
39282b86 14Source0: http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pdir}-%{version}.tar.gz
48e6a324 15# Source0-md5: dbbb944601a31f60ee58954ad4cb65b4
314fc5c6 16URL: https://metacpan.org/dist/Guard
82cd5b17 17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
314fc5c6 19BuildRequires: rpmbuild(macros) >= 1.745
82cd5b17 20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23This module implements so-called "guards". A guard is something
24(usually an object) that "guards" a resource, ensuring that it is
25cleaned up when expected.
26
27Specifically, this module supports two different types of guards:
28guard objects, which execute a given code block when destroyed, and
29scoped guards, which are tied to the scope exit.
30
31%description -l pl.UTF-8
39282b86
JB
32Moduł ten implementuje tzw. "strażników". Strażnik jest czymś (zwykle
33obiektem), co strzeże zasobu, zapewniając jego usunięcie wtedy, kiedy
34jest ono oczekiwane.
35
36W szczegóności moduł ten obsługuje dwa rodzaje strażników:
37- obiekty strażników, wykonujące dany blok kodu w trakcie niszczenia
38- strażników zakresowych, powiązanych z zakończeniem zakresu (scope).
82cd5b17 39
40%prep
41%setup -q -n %{pdir}-%{version}
42
43%build
44%{__perl} Makefile.PL \
45 INSTALLDIRS=vendor
46%{__make} \
47 CC="%{__cc}" \
48 OPTIMIZE="%{rpmcflags}"
49
50%{?with_tests:%{__make} test}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55%{__make} pure_install \
56 DESTDIR=$RPM_BUILD_ROOT
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
fe39478d 63%doc COPYING Changes
82cd5b17 64%{perl_vendorarch}/Guard.pm
39282b86 65%dir %{perl_vendorarch}/auto/Guard
82cd5b17 66%attr(755,root,root) %{perl_vendorarch}/auto/Guard/Guard.so
39282b86 67%{_mandir}/man3/Guard.3pm*
This page took 0.096613 seconds and 4 git commands to generate.