]> git.pld-linux.org Git - packages/perl-Fuse.git/blame - perl-Fuse.spec
- fix Source0 URL
[packages/perl-Fuse.git] / perl-Fuse.spec
CommitLineData
c293b7ff 1#
2# Conditional build:
3%bcond_with tests # do perform "make test"; disabled fusermount restricted
53382ba8 4
0464aba5 5%define pdir Fuse
53382ba8 6%include /usr/lib/rpm/macros.perl
c293b7ff 7Summary: Fuse - write filesystems in Perl using FUSE
c293b7ff 8Name: perl-Fuse
0464aba5 9Version: 0.16.1
c293b7ff 10Release: 1
11# same as perl (REMOVE THIS LINE IF NOT TRUE)
12License: GPL v1+ or Artistic
13Group: Development/Languages/Perl
b64527b2 14Source0: http://www.cpan.org/modules/by-module/%{pdir}/DPATES/%{pdir}-%{version}.tar.gz
0464aba5 15# Source0-md5: 29534329808d8cf42fc78ca26c6fa698
53382ba8 16URL: http://search.cpan.org/dist/Fuse/
c293b7ff 17BuildRequires: libfuse-devel
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
c293b7ff 20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23This lets you implement filesystems in perl, through the FUSE
24(Filesystem in USErspace) kernel/lib interface.
25
26FUSE expects you to implement callbacks for the various functions.
27
28In the following definitions, "errno" can be 0 (for a success),
53382ba8 29- -EINVAL, -ENOENT, -EONFIRE, any integer less than 1 really.
c293b7ff 30
53382ba8
ER
31You can import standard error constants by saying something like "use
32POSIX qw(EDOTDOT ENOANO);".
c293b7ff 33
53382ba8
ER
34Every constant you need (file types, open() flags, error values, etc)
35can be imported either from POSIX or from Fcntl, often both. See their
36respective documentations, for more information.
c293b7ff 37
38%prep
39%setup -q -n %{pdir}-%{version}
40
41%build
42%{__perl} Makefile.PL \
43 INSTALLDIRS=vendor
44%{__make} \
45 CC="%{__cc}" \
46 OPTIMIZE="%{rpmcflags}"
47
48%{?with_tests:%{__make} test}
49
50%install
51rm -rf $RPM_BUILD_ROOT
52
53%{__make} pure_install \
54 DESTDIR=$RPM_BUILD_ROOT
55
56install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%doc AUTHORS Changes README
65%{perl_vendorarch}/Fuse.pm
66%dir %{perl_vendorarch}/auto/Fuse/
c293b7ff 67%attr(755,root,root) %{perl_vendorarch}/auto/Fuse/*.so
b56f1f26 68%{perl_vendorarch}/auto/Fuse/autosplit.ix
c293b7ff 69%{_mandir}/man3/*
70%{_examplesdir}/%{name}-%{version}
This page took 0.095134 seconds and 4 git commands to generate.