]> git.pld-linux.org Git - packages/perl-File-Modified.git/blame - perl-File-Modified.spec
use generic url
[packages/perl-File-Modified.git] / perl-File-Modified.spec
CommitLineData
021f7bae 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
d6053a9d 4
021f7bae 5%define pdir File
6%define pnam Modified
d6053a9d 7%include /usr/lib/rpm/macros.perl
021f7bae 8Summary: File::Modified - checks intelligently if files have changed
fc9b9a6b 9Summary(pl.UTF-8): File::Modified - inteligentne sprawdzanie, czy pliki uległy zmianie
021f7bae 10Name: perl-File-Modified
11Version: 0.07
0c180b89 12Release: 2
021f7bae 13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 271a991b96ccbdaeb7098272c9f97d51
d6053a9d 18URL: http://search.cpan.org/dist/File-Modified/
021f7bae 19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
e4bfe6f4
JB
25The Modified module is intended as a simple method for programs to
26detect whether configuration files (or modules they rely on) have
27changed. There are currently two methods of change detection
28implemented, mtime and MD5. The MD5 method will fall back to use
29timestamps if the Digest::MD5 module cannot be loaded.
021f7bae 30
e4bfe6f4
JB
31There is another module, File::Signature, which has many similar
32features, so if this module doesn't do what you need, maybe
33File::Signature does. There also is quite some overlap between the two
34modules, code wise.
021f7bae 35
79b18930
JR
36%description -l pl.UTF-8
37Moduł Modified ma służyć programom za prostą metodę sprawdzania czy
38pliki konfiguracyjne (lub moduły na których polegają) się zmieniły.
39Aktualnie są zaimplementowane dwie metody sprawdzania zmian: mtime i
40MD5. Metoda MD5 będzie działać jako mtime jeśli moduł Digest::MD5
41będzie niedostępny.
e4bfe6f4 42
79b18930
JR
43Istnieje inny moduł - File::Signature - mający wiele podobnych cech,
44więc jeśli ten moduł nie jest tym co potrzeba, może File::Signature
45jest. Moduły te pokrywają się częściowo także pod względem kodu.
021f7bae 46
47%prep
48%setup -q -n %{pdir}-%{pnam}-%{version}
49
50%build
51%{__perl} Makefile.PL \
52 INSTALLDIRS=vendor
53%{__make}
54
55%{?with_tests:%{__make} test}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59
60%{__make} install \
61 DESTDIR=$RPM_BUILD_ROOT
62
63install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
71%doc Changes README
72%{perl_vendorlib}/File/*.pm
73%{_mandir}/man3/*
74%{_examplesdir}/%{name}-%{version}
This page took 0.052403 seconds and 4 git commands to generate.