]> git.pld-linux.org Git - packages/perl-File-FnMatch.git/blame - perl-File-FnMatch.spec
rebuild with perl 5.32
[packages/perl-File-FnMatch.git] / perl-File-FnMatch.spec
CommitLineData
681172c7
AG
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir File
6%define pnam FnMatch
681172c7
AG
7Summary: File::FnMatch - simple filename and pathname matching
8Name: perl-File-FnMatch
9Version: 0.02
cb4d9971 10Release: 3
681172c7
AG
11License: GPL v1+ or Artistic
12Group: Development/Languages/Perl
13Source0: http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
14# Source0-md5: 22f77c20d0fb5af01a3165e2df2fe34c
15URL: https://metacpan.org/release/File-FnMatch/
16BuildRequires: perl-devel >= 1:5.8.0
17BuildRequires: rpm-perlprov >= 4.1-13
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21File::FnMatch::fnmatch() provides simple, shell-like pattern matching.
22
23Though considerably less powerful than regular expressions, shell
24patterns are nonetheless useful and familiar to a large audience of
25end-users.
26
27Other possibilities include at least FNM_CASEFOLD (compare qr//i),
28FNM_LEADING_DIR to restrict matching to everything before the first
29'/', FNM_FILE_NAME as a synonym for FNM_PATHNAME, and the rather more
30exotic FNM_EXTMATCH. Consult your system documentation for details.
31
32%prep
33%setup -q -n %{pdir}-%{pnam}-%{version}
34
35%build
36%{__perl} Makefile.PL \
37 INSTALLDIRS=vendor
38%{__make} \
39 CC="%{__cc}" \
40 OPTIMIZE="%{rpmcflags}"
41
42%{?with_tests:%{__make} test}
43
44%install
45rm -rf $RPM_BUILD_ROOT
46
47%{__make} pure_install \
48 DESTDIR=$RPM_BUILD_ROOT
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%doc Changes README
56%{perl_vendorarch}/File/*.pm
57%dir %{perl_vendorarch}/auto/File/FnMatch
58%attr(755,root,root) %{perl_vendorarch}/auto/File/FnMatch/*.so
59%{_mandir}/man3/*
This page took 0.158841 seconds and 4 git commands to generate.