]> git.pld-linux.org Git - packages/perl-ExtUtils-InstallPaths.git/blame - perl-ExtUtils-InstallPaths.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-ExtUtils-InstallPaths.git] / perl-ExtUtils-InstallPaths.spec
CommitLineData
b78ac37a
JR
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir ExtUtils
6%define pnam InstallPaths
b78ac37a 7Summary: ExtUtils::InstallPaths - Build.PL install path logic made easy
6df2a9b4 8Summary(pl.UTF-8): ExtUtils::InstallPaths - ułatwienie logiki ścieżek instalacyjnych Build.PL
b78ac37a
JR
9Name: perl-ExtUtils-InstallPaths
10Version: 0.010
11Release: 1
6df2a9b4 12# same as perl 5
b78ac37a
JR
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: f0b00cc6c04653588a6298fa1f16c07f
17URL: http://search.cpan.org/dist/ExtUtils-InstallPaths/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-ExtUtils-Config >= 0.002
22%endif
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27This module tries to make install path resolution as easy as possible.
28
29When you want to install a module, it needs to figure out where to
30install things. The nutshell version of how this works is that default
31installation locations are determined from ExtUtils::Config, and they
32may be individually overridden by using the install_path attribute.
33An install_base attribute lets you specify an alternative installation
34root like /home/foo and prefix does something similar in a rather
35different (and more complicated) way. destdir lets you specify a
36temporary installation directory like /tmp/install in case you want to
37create bundled-up installable packages.
38
6df2a9b4
JB
39%description -l pl.UTF-8
40Ten moduł próbuje ułatwić rozwiązywanie ścieżek instalacyjnych na
41tyle, na ile to możliwe.
42
43Aby zainstalować moduł, musi on określić, gdzie instalować
44poszczególne elementy. W skrócie, domyślne ścieżki instalacyjne są
45określane z ExtUtils::Config i mogą być indywidualnie nadpisywane przy
46użyciu atrybutu install_path. Atrybut install_base pozwala na
47określenie alternatywnego korzenia dzewa instalacji, np. /home/foo, a
48prefix robi coś podobnego w nieco inny (i bardziej skomplikowany)
49sposób. destdir pozwala określić tymczasowy katalog instalacyjny, na
50przykład /tmp/install, aby utworzyć pakiety instalacyjne.
b78ac37a
JR
51
52%prep
53%setup -q -n %{pdir}-%{pnam}-%{version}
54
55%build
56%{__perl} Makefile.PL \
57 INSTALLDIRS=vendor
58%{__make}
59
60%{?with_tests:%{__make} test}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65%{__make} pure_install \
66 DESTDIR=$RPM_BUILD_ROOT
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%files
72%defattr(644,root,root,755)
6df2a9b4 73%doc Changes README
b78ac37a 74%{perl_vendorlib}/ExtUtils/InstallPaths.pm
6df2a9b4 75%{_mandir}/man3/ExtUtils::InstallPaths.3pm*
This page took 0.037829 seconds and 4 git commands to generate.