]> git.pld-linux.org Git - packages/perl-ExtUtils-InstallPaths.git/blame - perl-ExtUtils-InstallPaths.spec
- pl
[packages/perl-ExtUtils-InstallPaths.git] / perl-ExtUtils-InstallPaths.spec
CommitLineData
b78ac37a
JR
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir ExtUtils
6%define pnam InstallPaths
7%include /usr/lib/rpm/macros.perl
8Summary: ExtUtils::InstallPaths - Build.PL install path logic made easy
6df2a9b4 9Summary(pl.UTF-8): ExtUtils::InstallPaths - ułatwienie logiki ścieżek instalacyjnych Build.PL
b78ac37a
JR
10Name: perl-ExtUtils-InstallPaths
11Version: 0.010
12Release: 1
6df2a9b4 13# same as perl 5
b78ac37a
JR
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: f0b00cc6c04653588a6298fa1f16c07f
18URL: http://search.cpan.org/dist/ExtUtils-InstallPaths/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-ExtUtils-Config >= 0.002
23%endif
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28This module tries to make install path resolution as easy as possible.
29
30When you want to install a module, it needs to figure out where to
31install things. The nutshell version of how this works is that default
32installation locations are determined from ExtUtils::Config, and they
33may be individually overridden by using the install_path attribute.
34An install_base attribute lets you specify an alternative installation
35root like /home/foo and prefix does something similar in a rather
36different (and more complicated) way. destdir lets you specify a
37temporary installation directory like /tmp/install in case you want to
38create bundled-up installable packages.
39
6df2a9b4
JB
40%description -l pl.UTF-8
41Ten moduł próbuje ułatwić rozwiązywanie ścieżek instalacyjnych na
42tyle, na ile to możliwe.
43
44Aby zainstalować moduł, musi on określić, gdzie instalować
45poszczególne elementy. W skrócie, domyślne ścieżki instalacyjne są
46określane z ExtUtils::Config i mogą być indywidualnie nadpisywane przy
47użyciu atrybutu install_path. Atrybut install_base pozwala na
48określenie alternatywnego korzenia dzewa instalacji, np. /home/foo, a
49prefix robi coś podobnego w nieco inny (i bardziej skomplikowany)
50sposób. destdir pozwala określić tymczasowy katalog instalacyjny, na
51przykład /tmp/install, aby utworzyć pakiety instalacyjne.
b78ac37a
JR
52
53%prep
54%setup -q -n %{pdir}-%{pnam}-%{version}
55
56%build
57%{__perl} Makefile.PL \
58 INSTALLDIRS=vendor
59%{__make}
60
61%{?with_tests:%{__make} test}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66%{__make} pure_install \
67 DESTDIR=$RPM_BUILD_ROOT
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%files
73%defattr(644,root,root,755)
6df2a9b4 74%doc Changes README
b78ac37a 75%{perl_vendorlib}/ExtUtils/InstallPaths.pm
6df2a9b4 76%{_mandir}/man3/ExtUtils::InstallPaths.3pm*
This page took 0.059247 seconds and 4 git commands to generate.