]> git.pld-linux.org Git - packages/perl-EV.git/blame - perl-EV.spec
- release 5
[packages/perl-EV.git] / perl-EV.spec
CommitLineData
d0b8d537 1#
2# Conditional build:
7b6014f9 3%bcond_without tests # perform "make test"
d0b8d537 4#
5%include /usr/lib/rpm/macros.perl
6%define pdir EV
7Summary: EV - perl interface to libev, a high performance full-featured event loop
8Summary(pl.UTF-8): EV - interfejs perlowy do libev
9Name: perl-EV
7b6014f9 10Version: 3.9
d2e7c37a 11Release: 5
05a68dee 12Epoch: 1
9854614f 13# same as perl, libev: BSD-like
14License: GPL v1+ or Artistic, partially BSD-like
d0b8d537 15Group: Development/Languages/Perl
4247d548 16Source0: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/%{pdir}-%{version}.tar.gz
7b6014f9 17# Source0-md5: b46709463a575485eb40ca3309963ce3
d0b8d537 18URL: http://search.cpan.org/dist/EV/
b34e4adf 19BuildRequires: perl-common-sense
d0b8d537 20BuildRequires: perl-devel >= 1:5.8.0
21BuildRequires: rpm-perlprov >= 4.1-13
d0b8d537 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25This module provides an interface to libev
26(http://software.schmorp.de/pkg/libev.html). While the documentation
27below is comprehensive, one might also consult the documentation of
28libev itself (http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod or
29perldoc EV::libev) for more subtle details on watcher semantics or
30some discussion on the available backends, or how to force a specific
31backend with LIBEV_FLAGS, or just about in any case because it has
32much more detailed information.
33
34This module is very fast and scalable. It is actually so fast that you
35can use it through the AnyEvent module, stay portable to other event
36loops (if you don't rely on any watcher types not available through
37it) and still be faster than with any other event loop currently
38supported in Perl.
39
40This module does not export any symbols.
41
42%description -l pl.UTF-8
43Moduł ten dostarcza intefejs do libev.
44
45%prep
46%setup -q -n %{pdir}-%{version}
47
48%build
49%{__perl} Makefile.PL \
36679d7c 50 INSTALLDIRS=vendor </dev/null
d0b8d537 51%{__make} \
52 CC="%{__cc}" \
53 OPTIMIZE="%{rpmcflags}"
54
55%{?with_tests:%{__make} test}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59
60%{__make} pure_install \
61 DESTDIR=$RPM_BUILD_ROOT
62
9854614f 63install -d libev-doc
64mv -f libev/{Changes,LICENSE,README} libev-doc
65
d0b8d537 66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
9854614f 71%doc Changes README COPYING libev-doc
95074e4c 72%dir %{perl_vendorarch}/EV
d0b8d537 73%{perl_vendorarch}/EV/*.pm
74%{perl_vendorarch}/EV.pm
75%{perl_vendorarch}/EV/EVAPI.h
76%{perl_vendorarch}/EV/ev.h
95074e4c 77%dir %{perl_vendorarch}/auto/EV
d0b8d537 78%{perl_vendorarch}/auto/EV/EV.bs
79%attr(755,root,root) %{perl_vendorarch}/auto/EV/EV.so
d0b8d537 80%{_mandir}/man3/*
This page took 0.100752 seconds and 4 git commands to generate.