]> git.pld-linux.org Git - packages/perl-EV.git/blame - perl-EV.spec
- updated to 3.8
[packages/perl-EV.git] / perl-EV.spec
CommitLineData
d0b8d537 1#
2# Conditional build:
1cf02048 3%bcond_with tests # perform "make test"
d0b8d537 4#
5%include /usr/lib/rpm/macros.perl
6%define pdir EV
7Summary: EV - perl interface to libev, a high performance full-featured event loop
8Summary(pl.UTF-8): EV - interfejs perlowy do libev
9Name: perl-EV
1cf02048 10Version: 3.8
d0b8d537 11Release: 1
12License: unknown
13Group: Development/Languages/Perl
4247d548 14Source0: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/%{pdir}-%{version}.tar.gz
1cf02048 15# Source0-md5: 3ce46dd8b6e65103ab55eba3f84448ad
d0b8d537 16URL: http://search.cpan.org/dist/EV/
17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
d0b8d537 19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22This module provides an interface to libev
23(http://software.schmorp.de/pkg/libev.html). While the documentation
24below is comprehensive, one might also consult the documentation of
25libev itself (http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod or
26perldoc EV::libev) for more subtle details on watcher semantics or
27some discussion on the available backends, or how to force a specific
28backend with LIBEV_FLAGS, or just about in any case because it has
29much more detailed information.
30
31This module is very fast and scalable. It is actually so fast that you
32can use it through the AnyEvent module, stay portable to other event
33loops (if you don't rely on any watcher types not available through
34it) and still be faster than with any other event loop currently
35supported in Perl.
36
37This module does not export any symbols.
38
39%description -l pl.UTF-8
40ModuĊ‚ ten dostarcza intefejs do libev.
41
42%prep
43%setup -q -n %{pdir}-%{version}
44
45%build
46%{__perl} Makefile.PL \
47 INSTALLDIRS=vendor
48%{__make} \
49 CC="%{__cc}" \
50 OPTIMIZE="%{rpmcflags}"
51
52%{?with_tests:%{__make} test}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56
57%{__make} pure_install \
58 DESTDIR=$RPM_BUILD_ROOT
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(644,root,root,755)
65%doc Changes README
66%{perl_vendorarch}/EV/*.pm
67%{perl_vendorarch}/EV.pm
68%{perl_vendorarch}/EV/EVAPI.h
69%{perl_vendorarch}/EV/ev.h
70%{perl_vendorarch}/auto/EV/EV.bs
71%attr(755,root,root) %{perl_vendorarch}/auto/EV/EV.so
72%dir %{perl_vendorarch}/auto/EV/
73%{_mandir}/man3/*
This page took 0.592441 seconds and 4 git commands to generate.