]> git.pld-linux.org Git - packages/perl-Data-Dump-Streamer.git/blame - perl-Data-Dump-Streamer.spec
rebuild with perl 5.32
[packages/perl-Data-Dump-Streamer.git] / perl-Data-Dump-Streamer.spec
CommitLineData
c20703d7
JR
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Data
6%define pnam Dump-Streamer
c20703d7
JR
7Summary: Data::Dump::Streamer - Accurately serialize a data structure as Perl code
8Name: perl-Data-Dump-Streamer
7ffa8fe8 9Version: 2.39
8551c68d 10Release: 7
c20703d7
JR
11License: GPL v1+ or Artistic
12Group: Development/Languages/Perl
13Source0: http://www.cpan.org/modules/by-module/Data/%{pdir}-%{pnam}-%{version}.tar.gz
7ffa8fe8 14# Source0-md5: 5cd6fe67653c8de544fa41930de157b7
c20703d7
JR
15URL: http://search.cpan.org/dist/Data-Dump-Streamer/
16BuildRequires: perl-Module-Build
17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
19%if %{with tests}
20BuildRequires: perl-B-Utils
e8ceffc6 21BuildRequires: perl-PadWalker
c20703d7
JR
22%endif
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Given a list of scalars or reference variables, writes out their
27contents in perl syntax. The references can also be objects. The
28contents of each variable is output using the least number of Perl
29statements as convenient, usually only one. Self-referential
30structures, closures, and objects are output correctly.
31
32The return value can be evaled to get back an identical copy of the
33original reference structure. In some cases this may require the use
34of utility subs that Data::Dump::Streamer will optionally export.
35
36This module is very similar in concept to the core module
37Data::Dumper, with the major differences being that this module is
38designed to output to a stream instead of constructing its output in
39memory (trading speed for memory), and that the traversal over the
40data structure is effectively breadth first versus the depth first
41traversal done by the others.
42
43In fact the data structure is scanned twice, first in breadth first
44mode to perform structural analysis, and then in depth first mode to
45actually produce the output, but obeying the depth relationships of
46the first pass.
47
48%prep
49%setup -q -n %{pdir}-%{pnam}-%{version}
50
51%build
52%{__perl} Build.PL NODDS \
53 destdir=$RPM_BUILD_ROOT \
54 installdirs=vendor
55./Build
56
57%{?with_tests:./Build test}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62./Build install
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc Changes README
70%dir %{perl_vendorarch}/Data/Dump
71%{perl_vendorarch}/Data/Dump/*.pm
72%{perl_vendorarch}/Data/Dump/Streamer
73%dir %{perl_vendorarch}/auto/Data/Dump
74%dir %{perl_vendorarch}/auto/Data/Dump/Streamer
c20703d7
JR
75%attr(755,root,root) %{perl_vendorarch}/auto/Data/Dump/Streamer/Streamer.so
76%{_mandir}/man3/*
This page took 0.177681 seconds and 4 git commands to generate.