]> git.pld-linux.org Git - packages/perl-DBD-SQLite.git/blame - perl-DBD-SQLite.spec
- release 2 (by relup.sh)
[packages/perl-DBD-SQLite.git] / perl-DBD-SQLite.spec
CommitLineData
1d55040c
MK
1#
2# Conditional build:
0c9bdf39
JB
3%bcond_without tests # do not perform "make test"
4%bcond_without system_sqlite3 # don't use system sqlite3
58ad5dcf 5#
1d55040c 6%include /usr/lib/rpm/macros.perl
d50faded 7%define pdir DBD
8%define pnam SQLite
d03cf64a 9Summary: DBD::SQLite - Self Contained RDBMS in a DBI Driver (sqlite 3.x)
6bffd699 10Summary(pl.UTF-8): DBD::SQLite - Kompletny RDBMS zawarty w sterowniku DBI (sqlite 3.x)
1d55040c 11Name: perl-DBD-SQLite
4729dc1a 12Version: 1.48
d3553e73 13Release: 2
3fb5a596 14# same as perl
15License: GPL v1+ or Artistic
1d55040c 16Group: Development/Languages/Perl
ea19bb64 17Source0: http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
4729dc1a 18# Source0-md5: 020c02ca595b2074a767a19af8506d2a
ea19bb64 19URL: http://search.cpan.org/dist/DBD-SQLite/
0c9bdf39 20BuildRequires: perl-DBI >= 1.57
ea19bb64 21BuildRequires: perl-devel >= 1:5.8.0
ffdc7184 22BuildRequires: rpm-perlprov >= 4.1-13
5115f0f6 23BuildRequires: rpmbuild(macros) >= 1.663
0c9bdf39
JB
24%{?with_system_sqlite3:BuildRequires: sqlite3-devel >= 3.6.0}
25%if %{with tests}
26BuildRequires: perl-Encode
27BuildRequires: perl-Test-Simple >= 0.86
4729dc1a
JB
28# needs ENABLE_FTS3_PARENTHESIS
29%{?with_system_sqlite3:BuildRequires: sqlite3 >= 3.8.11.1-2}
0c9bdf39
JB
30%endif
31%{?with_system_sqlite3:Requires: sqlite3 >= 3.6.0}
1d55040c
MK
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
5115f0f6
JB
34# virtual module provided by VirtualTable.pm
35%define _noautoreq_perl DBD::SQLite::VirtualTable::Cursor
36
1d55040c 37%description
ffdc7184
JB
38DBD::SQLite is a DBI driver for SQLite database. SQLite is a public
39domain RDBMS database engine that you can find at
ec681d29 40<http://www.sqlite.org/>.
58ad5dcf 41
d03cf64a 42Rather than ask you to install SQLite first, DBD::SQLite includes the
43entire thing in the distribution. So in order to get a fast
44transaction capable RDBMS working for your perl project you simply
45have to install this module, and nothing else.
58ad5dcf 46
d03cf64a 47To use databases created using older SQLite version (2.x) you should
48use perl-DBD-SQLite2 package.
1d55040c 49
1d6aae89 50%description -l pl.UTF-8
ffdc7184 51DBD::SQLite to sterownik DBI do baz danych SQLite. SQLite to silnik
1d6aae89 52relacyjnych baz danych na licencji public domain. Można go znaleźć pod
ec681d29 53adresem <http://www.sqlite.org/>.
58ad5dcf 54
1d6aae89
JR
55DBD::SQLite zawiera w sobie cały silnik bazy danych. Dzięki temu aby
56otrzymać działający RDBMS dostępny z poziomu Perla nie trzeba
57instalować żadnych innych pakietów.
58ad5dcf 58
1d6aae89
JR
59Aby używać baz danych stworzonych przy pomocy starszej wersji SQLite
60(2.x) należy zainstalować pakiet perl-DBD-SQLite2.
e66d8db8 61
1d55040c
MK
62%prep
63%setup -q -n %{pdir}-%{pnam}-%{version}
64
0c9bdf39
JB
65# honour USE_LOCAL_SQLITE instead of using bundled sqlite3 (see comments inside)
66%{__perl} -pi -e 's/if \( 0 \)/if ( 1 )/' Makefile.PL
67
1d55040c 68%build
1671bc38 69echo y | %{__perl} Makefile.PL \
0c9bdf39 70 %{!?with_system_sqlite3:USE_LOCAL_SQLITE=1} \
ffdc7184
JB
71 INSTALLDIRS=vendor
72
33fb8c26 73%{__make} \
48d065fa 74 CC="%{__cc}" \
b3733e15 75 OPTIMIZE="%{rpmcflags}" \
76 OTHERLDFLAGS="%{rpmcflags} %{rpmldflags}"
ea7f784a 77
33fb8c26 78%{?with_tests:%{__make} test}
1d55040c
MK
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
33fb8c26 83%{__make} install \
84 DESTDIR=$RPM_BUILD_ROOT
1d55040c 85
4729dc1a 86%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/DBD/SQLite/{Cookbook,Fulltext_search}.pod
0c9bdf39
JB
87# "sqlite3 amalgamation" sources
88%{__rm} -r $RPM_BUILD_ROOT%{perl_vendorarch}/auto/share
89
1d55040c
MK
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(644,root,root,755)
95%doc Changes README
ffdc7184 96%{perl_vendorarch}/DBD/SQLite.pm
4729dc1a 97%{perl_vendorarch}/DBD/SQLite
ffdc7184 98%dir %{perl_vendorarch}/auto/DBD/SQLite
ffdc7184 99%attr(755,root,root) %{perl_vendorarch}/auto/DBD/SQLite/SQLite.so
4729dc1a 100%{_mandir}/man3/DBD::SQLite*.3pm*
This page took 0.135115 seconds and 4 git commands to generate.