]> git.pld-linux.org Git - packages/perl-Crypt-Camellia.git/blame - perl-Crypt-Camellia.spec
- release 9 (by relup.sh)
[packages/perl-Crypt-Camellia.git] / perl-Crypt-Camellia.spec
CommitLineData
a96e0d2b
JB
1#
2# Conditional build:
276e357a 3%bcond_without tests # Do not perform "make test"
a96e0d2b
JB
4#
5%include /usr/lib/rpm/macros.perl
d426c5c3 6%define pdir Crypt
7%define pnam Camellia
a96e0d2b 8Summary: Crypt::Camellia - Crypt::CBC-compliant block cipher
8c9a3e64 9Summary(pl.UTF-8): Crypt::Camellia - szyfr blokowy kompatybilny z Crypt::CBC
a96e0d2b 10Name: perl-Crypt-Camellia
03e03887 11Version: 1.0.2
82863068 12Release: 9
a96e0d2b
JB
13License: GPL
14Group: Development/Languages/Perl
86938737 15Source0: http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
03e03887 16# Source0-md5: ba2e8ffa62b22f0cc59c8c867318461a
86938737 17URL: http://search.cpan.org/dist/Crypt-Camellia/
af0b0c97 18BuildRequires: perl-devel >= 1:5.8.0
a96e0d2b
JB
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Camellia is a variable-length key, 128-bit block cipher. It is the
24NESSIE winner for 128-bit block ciphers. The default key length in
25this implementation is 128 bits. This module supports the Crypt::CBC
26interface.
27
4672489e
JR
28%description -l pl.UTF-8
29Camellia to 128-bitowy szyfr blokowy o zmiennej długości klucza. Jest
30zwycięzcą NESSIE dla 128-bitowych szyfrów blokowych. Domyślny rozmiar
31klucza w tej implementacji to 128 bitów. Moduł obsługuje interfejs
a96e0d2b
JB
32Crypt::CBC.
33
34%prep
35%setup -q -n %{pdir}-%{pnam}-%{version}
36
37%build
38%{__perl} Makefile.PL \
39 INSTALLDIRS=vendor
a58cc920 40%{__make} \
1be09aa0 41 CC="%{__cc}" \
a58cc920 42 OPTIMIZE="%{rpmcflags}"
a96e0d2b 43
276e357a 44%{?with_tests:%{__make} test}
a96e0d2b
JB
45
46%install
47rm -rf $RPM_BUILD_ROOT
48
49%{__make} install \
50 DESTDIR=$RPM_BUILD_ROOT
51
52cd examples
53install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54for f in * ; do
55 sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
56 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
57done
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%doc Changes README
65%{perl_vendorarch}/Crypt/Camellia.pm
66%dir %{perl_vendorarch}/auto/Crypt/Camellia
a96e0d2b
JB
67%attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Camellia/Camellia.so
68%{_mandir}/man3/*
69%attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.137044 seconds and 4 git commands to generate.