]> git.pld-linux.org Git - packages/perl-Crypt-Anubis.git/blame - perl-Crypt-Anubis.spec
- rebuild for perl 5.20
[packages/perl-Crypt-Anubis.git] / perl-Crypt-Anubis.spec
CommitLineData
9a032ee9
JB
1#
2# Conditional build:
a0df0387 3%bcond_without tests # Do not perform "make test"
9a032ee9
JB
4#
5%include /usr/lib/rpm/macros.perl
1df86b0a 6%define pdir Crypt
7%define pnam Anubis
9a032ee9 8Summary: Crypt::Anubis - Crypt::CBC-compliant block cipher
e1807643 9Summary(pl.UTF-8): Crypt::Abubis - szyfr blokowy kompatybilny z Crypt::CBC
9a032ee9 10Name: perl-Crypt-Anubis
917998e0 11Version: 1.0.4
2f99720f 12Release: 6
09343677 13License: GPL v2
9a032ee9 14Group: Development/Languages/Perl
09343677 15Source0: http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
917998e0 16# Source0-md5: aa62fb3a199063b5dff8bcbfc632338e
09343677 17URL: http://search.cpan.org/dist/Crypt-Anubis/
1a685527 18BuildRequires: perl-devel >= 1:5.8.0
9a032ee9
JB
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Anubis is a variable-length key, 128-bit block cipher designed by
24Vincent Rijmen and Paulo S. L. M. Barreto. Key length can be 128, 160,
25192, 224, 256, 288, or 320 bits. The default key length used in this
26implementation is 128 bits (16 bytes). This module supports the
27Crypt::CBC interface.
28
dce6c171
JR
29%description -l pl.UTF-8
30Anubis to 128-bitowy szyfr blokowy o zmiennej długości klucza
31opracowany przez Vincenta Rijmena i Paulo S. L. M. Baretto. Klucz może
32mieć długość 128, 160, 192, 224, 256, 228 lub 320 bitów. Domyślna
33długość klucza w tej implementacji to 128 bitów (16 bajtów). Ten moduł
34obsługuje interfejs Crypt::CBC.
9a032ee9
JB
35
36%prep
37%setup -q -n %{pdir}-%{pnam}-%{version}
38
39%build
40%{__perl} Makefile.PL \
41 INSTALLDIRS=vendor
3d05966e 42%{__make} \
2ce39288 43 CC="%{__cc}" \
3d05966e 44 OPTIMIZE="%{rpmcflags}"
9a032ee9 45
a0df0387 46%{?with_tests:%{__make} test}
9a032ee9
JB
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51%{__make} install \
52 DESTDIR=$RPM_BUILD_ROOT
53
54cd examples
55install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56for f in * ; do
57 sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
58 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
59done
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc Changes README
67%{perl_vendorarch}/Crypt/Anubis.pm
68%dir %{perl_vendorarch}/auto/Crypt/Anubis
69%{perl_vendorarch}/auto/Crypt/Anubis/Anubis.bs
70%attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Anubis/Anubis.so
71%{_mandir}/man3/*
72%attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.152808 seconds and 4 git commands to generate.