]> git.pld-linux.org Git - packages/perl-Class-Singleton.git/blame - perl-Class-Singleton.spec
- macros for perl autodeps
[packages/perl-Class-Singleton.git] / perl-Class-Singleton.spec
CommitLineData
166ff2ef 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5a21002e 5%define pdir Class
6%define pnam Singleton
1857a6c9 7Summary: Class::singleton - implementation of a "Singleton" class
2839c57c 8Summary(pl.UTF-8): Class::Singleton - implementacja klasy Singleton
e7ca92ba 9Name: perl-Class-Singleton
f3bad910 10Version: 1.5
e476f64c 11Release: 1
f3bad910
JB
12# same as perl
13License: GPL v1+ or Artistic
b288a097 14Group: Development/Languages/Perl
7ed46172 15Source0: http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
f3bad910 16# Source0-md5: 6a2524f590eda075f4bc929598119241
7a186bf9 17URL: https://metacpan.org/release/Class-Singleton
4d755c88 18BuildRequires: perl-devel >= 1:5.8.0
f3bad910 19BuildRequires: rpm-perlprov >= 4.1-13
7a186bf9 20BuildRequires: rpmbuild(macros) >= 1.745
f3bad910 21Obsoletes: perl-Class-Sigleton
b288a097 22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
9c3c1c1e
JB
26This is the Class::Singleton module. A Singleton describes an object
27class that can have only one instance in any system. An example of
28a Singleton might be a print spooler or system registry. This module
29implements a Singleton class from which other classes can be derived.
30By itself, the Class::Singleton module does very little other than
31manage the instantiation of a single object. In deriving a class from
32Class::Singleton, your module will inherit the Singleton instantiation
33method and can implement whatever specific functionality is required.
b288a097 34
b1124829
JR
35%description -l pl.UTF-8
36To jest moduł Class::Singleton. Singleton opisuje obiekt klasy, który
37ma tylko jedną instancję w systemie - na przykład serwer wydruków. Ten
38moduł implementuje klasę Singleton, z której można dziedziczyć inne
39klasy. Sam moduł Class::Singleton robi niewiele więcej niż samo
40zarządzanie pojedynczą instancją obiektu. Poprzez dziedziczenie z
41klasy z Class:Singleton, moduły odziedziczą istnienie pojedynczej
42instancji w systemie, a dodatkowo mogą mieć zaimplementowaną właściwą
43funkcjonalność.
b288a097 44
45%prep
46%setup -q -n %{pdir}-%{pnam}-%{version}
47
48%build
a86d22b6 49%{__perl} Makefile.PL \
811b0bd9 50 INSTALLDIRS=vendor
b288a097 51%{__make}
52
166ff2ef 53%{?with_tests:%{__make} test}
54
b288a097 55%install
56rm -rf $RPM_BUILD_ROOT
57
166ff2ef 58%{__make} install \
59 DESTDIR=$RPM_BUILD_ROOT
b288a097 60
b288a097 61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
f3bad910
JB
66%doc Changes
67%{perl_vendorlib}/Class/Singleton.pm
68%{_mandir}/man3/Class::Singleton.3pm*
This page took 0.081774 seconds and 4 git commands to generate.