]> git.pld-linux.org Git - packages/perl-Class-Method-Modifiers.git/blame - perl-Class-Method-Modifiers.spec
- updated dependencies
[packages/perl-Class-Method-Modifiers.git] / perl-Class-Method-Modifiers.spec
CommitLineData
e6c8a76b 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Class
7%define pnam Method-Modifiers
8Summary: Class::Method::Modifiers - provides Moose-like method modifiers
e41a0381 9Summary(pl.UTF-8): Class::Method::Modifiers - modyfikatory metod na kształt Moose
e6c8a76b 10Name: perl-Class-Method-Modifiers
05408e3a 11Version: 2.12
e6c8a76b 12Release: 1
86b85f9b 13# same as perl 5
e6c8a76b 14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
05408e3a 17# Source0-md5: f55400c7a8134acf3657f8af89bdd7af
e6c8a76b 18URL: http://search.cpan.org/dist/Class-Method-Modifiers/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
86b85f9b
JB
22BuildRequires: perl-Test-Fatal
23BuildRequires: perl-Test-Requires
24BuildRequires: perl-Test-Simple >= 0.88
e6c8a76b 25%endif
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30In its most basic form, a method modifier is just a method that calls
31$self->SUPER::foo(@_).
32
33Class::Method::Modifiers provides three modifiers: before, around,
34and after. before and after are run just before and after the method
35they modify, but can not really affect that original method. around
36is run in place of the original method, with a hook to easily call
e41a0381 37that original method.
e6c8a76b 38
709d43f9 39%description -l pl.UTF-8
e41a0381
JB
40W najprostszej postaci, modyfikator metody to metoda wywołująca
41$self->SUPER::foo(@_).
42
43Moduł Class::Method::Modifiers dostarcza trzy modyfikatory: before,
44around oraz after. Modyfikatory before oraz after są wywoływane
45bezpośrednio przed i bezpośrednio po modyfikowanej metodzie, ale nie
46mogą wpływać na oryginalną metodę. Modyfikator around jest wywoływany
47zamiast oryginalnej metody z uchwytem do łatwego wywołania tej
48oryginalnej metody.
e6c8a76b 49
50%prep
51%setup -q -n %{pdir}-%{pnam}-%{version}
52
53%build
54%{__perl} Makefile.PL \
55 INSTALLDIRS=vendor
56%{__make}
57
58%{?with_tests:%{__make} test}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%{__make} pure_install \
64 DESTDIR=$RPM_BUILD_ROOT
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
71%doc Changes
e41a0381
JB
72%{perl_vendorlib}/Class/Method/Modifiers.pm
73%{_mandir}/man3/Class::Method::Modifiers.3pm*
This page took 0.055728 seconds and 4 git commands to generate.