]> git.pld-linux.org Git - packages/perl-Class-Load.git/blame - perl-Class-Load.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-Load.git] / perl-Class-Load.spec
CommitLineData
11ae5139
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Class
6%define pnam Load
11ae5139
JB
7Summary: Class::Load - a working (require "Class::Name") and more
8Summary(pl.UTF-8): Class::Load - działające (require "Klasa::Nazwa") i inne
9Name: perl-Class-Load
975135e3 10Version: 0.25
11ae5139
JB
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
79c824dc 15Source0: http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
975135e3 16# Source0-md5: e4c831c08df592ce8dfee0c7cfc12fd7
11ae5139 17URL: http://search.cpan.org/dist/Class-Load/
96ab70a5 18BuildRequires: perl-ExtUtils-MakeMaker >= 6.30
11ae5139
JB
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
fb17f18c 22BuildRequires: perl-Data-OptList
96ab70a5
JB
23BuildRequires: perl-Module-Implementation >= 0.04
24BuildRequires: perl-Module-Runtime >= 0.012
25BuildRequires: perl-Package-Stash >= 0.14
fb17f18c 26BuildRequires: perl-Scalar-List-Utils
11ae5139 27BuildRequires: perl-Test-Fatal
96ab70a5
JB
28BuildRequires: perl-Test-Requires
29BuildRequires: perl-Test-Simple >= 0.88
30BuildRequires: perl-Try-Tiny
21fca0b3 31BuildRequires: perl-version
11ae5139
JB
32%endif
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37require EXPR only accepts Class/Name.pm style module names, not
38Class::Name. How frustrating! For that, we provide load_class
39'Class::Name'.
40
41It's often useful to test whether a module can be loaded, instead of
42throwing an error when it's not available. For that, we provide
43try_load_class 'Class::Name'.
44
45Finally, sometimes we need to know whether a particular class has been
46loaded. Asking %%INC is an option, but that will miss inner packages
47and any class for which the filename does not correspond to the
48package name. For that, we provide is_class_loaded 'Class::Name'.
49
50%description -l pl.UTF-8
51require EXPR przyjmuje tylko nazwy modułów w stylu Klasa/Nazwa.pm, a
52nie Klasa::Nazwa - jest to frustrujące. Dlatego moduł ten udostępnia
53funkcję load_class 'Klasa::Nazwa'.
54
55Często przydaje się sprawdzić, czy moduł może być załadowany, zamiast
56rzucania błędu, kiedy jest niedostępny. Dlatego modułu ten udostępnia
57funkcję try_load_class 'Klasa::Nazwa'.
58
59W końcu - czasem trzeba sprawdzić, czy dana klasa została załadowana.
60Sprawdzanie %%INC jest jakąś opcją, ale pominie pakiety i klasy, dla
61których nazwa pliku nie zgadza się z nazwą pakietu. Dlatego moduł ten
62udostępnia funkcję is_class_loaded 'Klasa::Nazwa'.
63
64%prep
65%setup -q -n %{pdir}-%{pnam}-%{version}
66
67%build
68%{__perl} Makefile.PL \
69 INSTALLDIRS=vendor
70%{__make}
71
72%{?with_tests:%{__make} test}
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77%{__make} pure_install \
78 DESTDIR=$RPM_BUILD_ROOT
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(644,root,root,755)
fb17f18c 85%doc Changes README
11ae5139 86%{perl_vendorlib}/Class/Load.pm
dba777b1 87%{perl_vendorlib}/Class/Load
11ae5139 88%{_mandir}/man3/Class::Load.3pm*
This page took 0.086329 seconds and 4 git commands to generate.