]> git.pld-linux.org Git - packages/perl-CPAN-Meta-Requirements.git/blame - perl-CPAN-Meta-Requirements.spec
- macros for perl autodeps
[packages/perl-CPAN-Meta-Requirements.git] / perl-CPAN-Meta-Requirements.spec
CommitLineData
3dbe1c80
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir CPAN
6%define pnam Meta-Requirements
3dbe1c80
JB
7Summary: CPAN::Meta::Requirements - a set of version requirements for a CPAN dist
8Summary(pl.UTF-8): CPAN::Meta::Requirements - zbiór wymaganych wersji dla dystrybucji CPAN
9Name: perl-CPAN-Meta-Requirements
3cd48416 10Version: 2.140
3dbe1c80 11Release: 1
3cd48416 12# same as perl 5
3dbe1c80
JB
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{pnam}-%{version}.tar.gz
3cd48416 16# Source0-md5: 8febe4f14f356e57fd1e2c342d56a64b
b6e9d143 17URL: https://metacpan.org/release/CPAN-Meta-Requirements
3dbe1c80
JB
18BuildRequires: perl-ExtUtils-MakeMaker >= 6.17
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
b6e9d143 21BuildRequires: rpmbuild(macros) >= 1.745
3dbe1c80
JB
22%if %{with tests}
23BuildRequires: perl-File-Temp
24BuildRequires: perl-Scalar-List-Utils
25BuildRequires: perl-Test-Simple >= 0.88
3cd48416 26BuildRequires: perl-version >= 0.88
3dbe1c80
JB
27%endif
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32A CPAN::Meta::Requirements object models a set of version constraints
33like those specified in the META.yml or META.json files in CPAN
34distributions. It can be built up by adding more and more constraints,
35and it will reduce them to the simplest representation.
36
37Logically impossible constraints will be identified immediately by
38thrown exceptions.
39
40%description -l pl.UTF-8
41Obiekt CPAN::Meta::Requirements modeluje zbiór ograniczeń wersji,
42takich jak te podawane w plikach META.yml lub META.json w
43dystrybucjach CPAN. Mogą być tworzone poprzez dodawanie kolejnych
44ograniczeń, a obiekt zredukuje je do najprostszej reprezentacji.
45
46Ograniczenia logicznie niemożliwe zostaną zidentyfikowane natychmiast
47poprzez rzucenie wyjątku.
48
49%prep
50%setup -q -n %{pdir}-%{pnam}-%{version}
51
52%build
53%{__perl} Makefile.PL \
54 INSTALLDIRS=vendor
55%{__make}
56
57%{?with_tests:%{__make} test}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%{__make} pure_install \
63 DESTDIR=$RPM_BUILD_ROOT
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc Changes README
71%{perl_vendorlib}/CPAN/Meta/Requirements.pm
72%{_mandir}/man3/CPAN::Meta::Requirements.3pm*
This page took 0.117677 seconds and 4 git commands to generate.