]> git.pld-linux.org Git - packages/perl-CGI-Emulate-PSGI.git/blame - perl-CGI-Emulate-PSGI.spec
- up to 0.15
[packages/perl-CGI-Emulate-PSGI.git] / perl-CGI-Emulate-PSGI.spec
CommitLineData
cf49b4dc 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir CGI
6%define pnam Emulate-PSGI
7%include /usr/lib/rpm/macros.perl
8Summary: CGI::Parse::PSGI - Parses CGI output and creates PSGI response out of it
9#Summary(pl.UTF-8):
10Name: perl-CGI-Emulate-PSGI
adb8d075 11Version: 0.15
cf49b4dc 12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/CGI/%{pdir}-%{pnam}-%{version}.tar.gz
adb8d075 17# Source0-md5: 3f0b6ae68d1e84e66ea8eb629e569284
cf49b4dc 18# generic URL, check or change before uncommenting
19#URL: http://search.cpan.org/dist/CGI-Emulate-PSGI/
20BuildRequires: perl-devel >= 1:5.8.0
21BuildRequires: rpm-perlprov >= 4.1-13
22%if %{with tests}
23BuildRequires: perl-HTTP-Message
24%endif
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29 use CGI::Parse::PSGI qw(parse_cgi_output);
30
31 my $output = YourApp->run;
32 my $psgi_res = parse_cgi_output(\$output);
33
34
35
36# %description -l pl.UTF-8
37# TODO
38
39%prep
40%setup -q -n %{pdir}-%{pnam}-%{version}
41
42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45%{__make}
46
47%{?with_tests:%{__make} test}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52%{__make} pure_install \
53 DESTDIR=$RPM_BUILD_ROOT
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
60%doc Changes README
f459fb04 61%dir %{perl_vendorlib}/CGI/Emulate
cf49b4dc 62%{perl_vendorlib}/CGI/Emulate/*.pm
f459fb04
AM
63%dir %{perl_vendorlib}/CGI/Parse
64%{perl_vendorlib}/CGI/Parse/PSGI.pm
cf49b4dc 65%{_mandir}/man3/*
This page took 0.060266 seconds and 4 git commands to generate.