]> git.pld-linux.org Git - packages/perl-CGI-Compile.git/blame - perl-CGI-Compile.spec
use generic url
[packages/perl-CGI-Compile.git] / perl-CGI-Compile.spec
CommitLineData
279bcb8c 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
721761e8 4
279bcb8c 5%define pdir CGI
6%define pnam Compile
7%include /usr/lib/rpm/macros.perl
8Summary: CGI::Compile - Compile .cgi scripts to a code reference like ModPerl::Registry
279bcb8c 9Name: perl-CGI-Compile
3d9b7143 10Version: 0.15
279bcb8c 11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/CGI/%{pdir}-%{pnam}-%{version}.tar.gz
3d9b7143 16# Source0-md5: 2fcf4bc473107130229f4e0a98c756ce
721761e8 17URL: http://search.cpan.org/dist/CGI-Compile/
279bcb8c 18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl(File::pushd)
22BuildRequires: perl(Test::NoWarnings)
23BuildRequires: perl-Test-Requires
24%endif
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29CGI::Compile is an utility to compile CGI scripts into a code
30reference that can run many times on its own namespace, as long as the
31script is ready to run on a persistent environment.
32
3d9b7143 33NOTE: for best results, load CGI::Compile before any modules used by
34your CGIs.
279bcb8c 35
279bcb8c 36%prep
37%setup -q -n %{pdir}-%{pnam}-%{version}
38
39%build
40%{__perl} Makefile.PL \
41 INSTALLDIRS=vendor
42%{__make}
43
44%{?with_tests:%{__make} test}
45
46%install
47rm -rf $RPM_BUILD_ROOT
48
49%{__make} pure_install \
50 DESTDIR=$RPM_BUILD_ROOT
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(644,root,root,755)
57%doc Changes README
58%{perl_vendorlib}/CGI/*.pm
59%{_mandir}/man3/*
This page took 0.091067 seconds and 4 git commands to generate.