]> git.pld-linux.org Git - packages/perl-BSD-Resource.git/blame - perl-BSD-Resource.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-BSD-Resource.git] / perl-BSD-Resource.spec
CommitLineData
d0d1520b
JB
1#
2# Conditional build:
c70cb50c 3%bcond_with tests # do not perform "make test"
4# hgw why it doesn't work on builders... temporary disables.
d0d1520b 5#
49aae85f 6%define pdir BSD
7%define pnam Resource
1812cb70 8Summary: Perl module with BSD process resource limit and priority functions
00e33737
ER
9Summary(cs.UTF-8): Funkce pro BSD limity zdrojů a priority procesů
10Summary(da.UTF-8): BSD-procesresursegrænse- og -prioritetsfunktioner
11Summary(de.UTF-8): Funktionen zum Einstellen von Einschränkungen und Prioritäten der Ressourcen des BSD-Prozesses
12Summary(es.UTF-8): Funciones de prioridad y limite de recusros del proceso BSD
13Summary(fr.UTF-8): Limite de ressource de processus BSD et fonctions prioritaires
14Summary(it.UTF-8): Impostazione dei limiti e delle priorità delle risorse del processo BSD
15Summary(ja.UTF-8): BSDのプロセスリソースの制限と優先度の機能
16Summary(ko.UTF-8): BSD 프로세스 자원 한계와 우선 순위 함수
17Summary(pl.UTF-8): Moduł Perla z funkcjami BSD obsługującymi limity zasobów dla procesów
18Summary(pt.UTF-8): Funções de limitação de recursos e prioridades dos processos do BSD
19Summary(pt_BR.UTF-8): Funções de limitação de recursos e prioridades dos processos do BSD
20Summary(sv.UTF-8): BSD-processresursgräns- och -prioritetsfunktioner
21Summary(tr.UTF-8): BSD süreç özkaynak sınırı ve önceliği işlevleri
22Summary(zh_CN.UTF-8): BSD 进程资源限制和优先级函数
ef2b77e8 23Name: perl-BSD-Resource
948634d4 24Version: 1.2911
0da83f9b 25Release: 2
43d52ae8 26# same as perl
27License: GPL v1+ or Artistic
ef2b77e8 28Group: Development/Languages/Perl
d0caa9f7 29Source0: http://www.cpan.org/modules/by-module/BSD/%{pdir}-%{pnam}-%{version}.tar.gz
948634d4 30# Source0-md5: 3a67959a30fd6e537b9d8a64d60d8692
b80719ff 31URL: http://search.cpan.org/dist/BSD-Resource/
56cf3115 32BuildRequires: perl-devel >= 1:5.8.0
20fab71b 33BuildRequires: rpm-perlprov >= 4.1-13
40118f57 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ef2b77e8 35
36%description
fa4e3091 37This Perl extension implements the BSD process resource limit
38functions (getrusage(), getrlimit(), setrlimit()) and the BSD process
39priority functions. These are available also via core Perl but here we
40do more tricks so that the PRIO_* are available (getpriority(),
048832d6 41setpriority()).
ef2b77e8 42
81725f4e
JR
43%description -l cs.UTF-8
44Modul poskytující rozhraní pro testování a nastavování limitů zdrojů a
1812cb70 45priorit procesu.
46
81725f4e
JR
47%description -l da.UTF-8
48Et modul som leverer en grænseflade til at teste og sætte
49procesbegrænsninger og prioriteter.
1812cb70 50
81725f4e
JR
51%description -l de.UTF-8
52Ein Modul mit einem Interface für das Prüfen und Einstellen von
53Prozesseinschränkgungen und -prioritäten.
1812cb70 54
81725f4e
JR
55%description -l es.UTF-8
56Módulo que proporciona una interfaz para chequear y configurar los
57límites del proceso y las prioridades.
1812cb70 58
81725f4e
JR
59%description -l fr.UTF-8
60Module fournissant une interface pour tester et établir les limites de
61processus et les priorités.
1812cb70 62
81725f4e 63%description -l it.UTF-8
1812cb70 64Modulo che offre un'interfaccia per testare e impostare i limiti e le
81725f4e 65priorità dei processi.
1812cb70 66
81725f4e
JR
67%description -l ja.UTF-8
68プロセスの制限と優先度をテストし設定する為のインターフェイスを提供する
69モジュールです。
1812cb70 70
81725f4e
JR
71%description -l ko.UTF-8
72프로세스 한계와 우선 순위를 설정하고 시험하는데 사용되는 인터페이스를
73제공하는 모듈.
1812cb70 74
81725f4e 75%description -l pl.UTF-8
bf1026f5 76To rozszerzenie Perla jest implementacją funkcji BSD dotyczących
81725f4e
JR
77limitów zasobów dla procesów (getrusage(), getrlimit(), setrlimit())
78oraz funkcji BSD związanych z priorytetami procesów. Są one dostępne
79także z podstawowego Perla, ale ten moduł pozwala na więcej sztuczek,
80bo dostępne są PRIO_* (getpriority(), setpriority()).
ef2b77e8 81
81725f4e
JR
82%description -l pt.UTF-8
83Um módulo que oferece uma interface para testar e definir os limites e
1812cb70 84prioridades dos processos.
85
81725f4e
JR
86%description -l pt_BR.UTF-8
87Um módulo que oferece uma interface para testar e definir os limites e
1812cb70 88prioridades dos processos.
89
81725f4e
JR
90%description -l sv.UTF-8
91En modul som tillhandahåller ett gränssnitt för att testa och sätta
92processbegränsningar och prioriteter.
1812cb70 93
81725f4e
JR
94%description -l zh_CN.UTF-8
95为测试和设置进程限度和优先级而提供的模块。
1812cb70 96
ef2b77e8 97%prep
367f03f5 98%setup -q -n %{pdir}-%{pnam}-%{version}
ef2b77e8 99
100%build
20fab71b 101%{__perl} Makefile.PL \
57dde42e 102 INSTALLDIRS=vendor
d0d1520b 103%{__make} \
e3549952 104 CC="%{__cc}" \
d0d1520b
JB
105 OPTIMIZE="%{rpmcflags}"
106
107%{?with_tests:%{__make} test}
ef2b77e8 108
109%install
110rm -rf $RPM_BUILD_ROOT
ef2b77e8 111
d0d1520b
JB
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
ef2b77e8 114
ef2b77e8 115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files
119%defattr(644,root,root,755)
40549b37 120%doc ChangeLog README
20fab71b 121%{perl_vendorarch}/BSD/Resource.pm
122%dir %{perl_vendorarch}/auto/BSD/Resource
123%{perl_vendorarch}/auto/BSD/Resource/*.al
124%{perl_vendorarch}/auto/BSD/Resource/autosplit.ix
20fab71b 125%attr(755,root,root) %{perl_vendorarch}/auto/BSD/Resource/Resource.so
bf1026f5 126%{_mandir}/man3/BSD::Resource.3pm*
This page took 0.20368 seconds and 4 git commands to generate.