]> git.pld-linux.org Git - packages/perl-Authen-Krb5-Simple.git/blame - perl-Authen-Krb5-Simple.spec
- rebuild with perl 5.30.0
[packages/perl-Authen-Krb5-Simple.git] / perl-Authen-Krb5-Simple.spec
CommitLineData
c8f8c536
JR
1#
2# TODO: pl desc
3#
4# Conditional build:
5%bcond_without tests # do not perform "make test"
6#
7%include /usr/lib/rpm/macros.perl
8%define pdir Authen
9%define pnam Krb5-Simple
10Summary: Authen::Krb5::Simple - Basic user authentication using Kerberos 5
11Summary(pl.UTF-8): Authen::Krb5::Simple - Autentykacja przy pomocy Kerberosa 5
12Name: perl-Authen-Krb5-Simple
ce39aa42 13Version: 0.43
f5e20b7f 14Release: 11
c8f8c536
JR
15License: GPL v1+ or Artistic
16Group: Development/Languages/Perl
17Source0: http://www.cpan.org/modules/by-module/Authen/%{pdir}-%{pnam}-%{version}.tar.gz
ce39aa42 18# Source0-md5: 209812d935d778c0a22247b5159bc0f6
c8f8c536
JR
19URL: http://search.cpan.org/dist/Authen-Krb5-Simple/
20BuildRequires: heimdal-devel
21BuildRequires: perl-devel >= 1:5.8.0
22BuildRequires: rpm-perlprov >= 4.1-13
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26The Authen::Krb5::Simple module provides a means to authenticate a
27user/password using Kerberos 5 protocol. The module's authenticate
28function takes a username (or user@kerberos_realm) and a password, and
29authenticates that user using the local Kerberos 5 installation. It
30was initially created to allow perl scripts to perform authentication
31against a Microsoft Active Directory (AD) server configured to accept
32Kerberos client requests.
33
34It is important to note: This module only performs simple
35authentication. It does not get, grant, use, or retain any kerberos
36tickets. It will check user credentials against the Kerberos server
37(as configured on the local system) each time the authenticate method
38is called.
39
40#%description -l pl.UTF-8
41
42%prep
43%setup -q -n %{pdir}-%{pnam}-%{version}
44
45%build
46%{__perl} Makefile.PL \
47 INSTALLDIRS=vendor
48
49%{__make} \
50 CC="%{__cc}"
51 OPTIMIZE="%{rpmcflags}"
52
53%{?with_tests:%{__make} test}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%{__make} pure_install \
59 DESTDIR=$RPM_BUILD_ROOT
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc Changes README
ea399746 67%dir %{perl_vendorarch}/Authen/Krb5
c8f8c536 68%{perl_vendorarch}/Authen/Krb5/Simple.pm
ea399746 69%dir %{perl_vendorarch}/auto/Authen/Krb5
70%dir %{perl_vendorarch}/auto/Authen/Krb5/Simple
c8f8c536
JR
71%attr(755,root,root) %{perl_vendorarch}/auto/Authen/Krb5/Simple/Simple.so
72%{_mandir}/man3/*
This page took 0.063307 seconds and 4 git commands to generate.