]> git.pld-linux.org Git - packages/perl-Astro-FITS-CFITSIO.git/blame - perl-Astro-FITS-CFITSIO.spec
- release 6 (by relup.sh)
[packages/perl-Astro-FITS-CFITSIO.git] / perl-Astro-FITS-CFITSIO.spec
CommitLineData
165f6fdb
JB
1#
2# Conditional build:
3%bcond_without tests # don't perform "make test"
4#
5d406bfa 5%include /usr/lib/rpm/macros.perl
a4368ced 6%define pdir Astro
7%define pnam FITS-CFITSIO
165f6fdb 8Summary: Astro::FITS::CFITSIO - Perl extension for using the cfitsio library
ce045329 9Summary(pl.UTF-8): Astro::FITS::CFITSIO - rozszerzenie Perla do korzystania z biblioteki cfitsio
5d406bfa 10Name: perl-Astro-FITS-CFITSIO
5407c7da 11Version: 1.10
edcf46f0 12Release: 6
165f6fdb 13# same as perl
c30ef801 14License: GPL v1+ or Artistic
5d406bfa 15Group: Development/Languages/Perl
bed3b2a8 16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
5407c7da 17# Source0-md5: 90a933310d986f32c953cb73caf58bf3
744fe34d 18URL: http://search.cpan.org/dist/Astro-FITS-CFITSIO/
b538f8b9 19BuildRequires: cfitsio-devel >= 2.500
7c1c46cf 20BuildRequires: perl-ExtUtils-PkgConfig
edaf7051 21BuildRequires: perl-devel >= 1:5.8.0
165f6fdb 22BuildRequires: rpm-perlprov >= 4.1-13
b538f8b9 23Requires: cfitsio >= 2.500
5d406bfa 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Astro::FITS::CFITSIO is a Perl interface to William Pence's cfitsio
28subroutine library.
744fe34d 29
165f6fdb
JB
30This module attempts to provide a wrapper for nearly every cfitsio
31routine, while retaining as much cfitsio behavior as possible. As
32such, one should be aware that it is still somewhat low-level, in the
33sense that handing an array which is not the correct size to a routine
34like fits_write_img() may cause SIGSEGVs.
5d406bfa 35
165f6fdb
JB
36The goal is to eventually use these routines to build a more Perl-like
37interface to many common tasks such as reading and writing of images
38and ASCII and binary tables.
5d406bfa 39
ffbcbc97 40%description -l pl.UTF-8
b09ff66c 41Astro::FITS::CFITSIO jest perlowym interfejsem do biblioteki cfitsio
42Williama Pence'a.
5d406bfa 43
ffbcbc97
JR
44Ten moduł jest próbą dostarczenia obudowania dla prawie wszystkich
45funkcji cfitsio przy zachowaniu możliwie najbliższym cfitsio. Przez to
46trzeba mieć na uwadze, że dostęp jest nieco niskopoziomowy, w tym
47sensie, że przekazanie tablicy o złym rozmiarze do funkcji typu
48fits_write_img() może powodować SIGSEGV.
5d406bfa 49
165f6fdb 50Celem autora jest ewentualne wykorzystanie tych funkcji to stworzenia
ffbcbc97
JR
51bardziej perlowego interfejsu do wielu ogólnych zadań, takich jak
52odczyt i zapis obrazów oraz tablic binarnych i ASCII.
5d406bfa 53
54%prep
55%setup -q -n %{pdir}-%{pnam}-%{version}
56
57%build
cd09a714 58export CFITSIO=/usr
c10d4ef6 59%{__perl} Makefile.PL \
89df459c 60 INSTALLDIRS=vendor
5d406bfa 61%{__make}
165f6fdb
JB
62
63%{?with_tests:%{__make} test}
5d406bfa 64
65%install
66rm -rf $RPM_BUILD_ROOT
67install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
165f6fdb
JB
69%{__make} install \
70 DESTDIR=$RPM_BUILD_ROOT
5d406bfa 71
72install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(644,root,root,755)
5407c7da 79%doc ChangeLog NOTES README TODO
c10d4ef6 80%{perl_vendorarch}/Astro/FITS
81%dir %{perl_vendorarch}/auto/Astro/FITS
82%dir %{perl_vendorarch}/auto/Astro/FITS/CFITSIO
c10d4ef6 83%{perl_vendorarch}/auto/Astro/FITS/CFITSIO/autosplit.ix
84%attr(755,root,root) %{perl_vendorarch}/auto/Astro/FITS/CFITSIO/CFITSIO.so
7c1c46cf 85%{_mandir}/man3/Astro::FITS::CFITSIO.3pm*
5d406bfa 86%dir %{_examplesdir}/%{name}-%{version}
87%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
88%{_examplesdir}/%{name}-%{version}/INDEX
89%{_examplesdir}/%{name}-%{version}/*.fits.*
This page took 0.128997 seconds and 4 git commands to generate.