]> git.pld-linux.org Git - packages/perl-Algorithm-SVM.git/blame - perl-Algorithm-SVM.spec
perl 5.38.0 rebuild
[packages/perl-Algorithm-SVM.git] / perl-Algorithm-SVM.spec
CommitLineData
a7f06b66 1#
2# Conditional build:
04b1a149 3%bcond_without tests # don't perform "make test"
a7f06b66 4#
629c3e73 5%define pdir Algorithm
6%define pnam SVM
a7f06b66 7Summary: Perl bindings for the libsvm Support Vector Machine library
2c82a38c 8Summary(pl.UTF-8): Dowiązania Perla do biblioteki libsvm (Support Vector Machine)
a7f06b66 9Name: perl-Algorithm-SVM
db3af12b 10Version: 0.13
47a7e872 11Release: 17
e6ce8bb7 12# same as perl
13License: GPL v1+ or Artistic
a7f06b66 14Group: Development/Languages/Perl
93db4d97 15Source0: http://www.cpan.org/modules/by-module/Algorithm/%{pdir}-%{pnam}-%{version}.tar.gz
db3af12b 16# Source0-md5: 276ec1b341e05aa4c0353685f32ea4d5
93db4d97 17URL: http://search.cpan.org/dist/Algorithm-SVM/
be7c534a 18BuildRequires: libstdc++-devel
dc3a178c 19BuildRequires: perl-devel >= 1:5.8.0
a7f06b66 20BuildRequires: rpm-perlprov >= 4.1-13
93db4d97 21BuildRequires: sed >= 4.0
a7f06b66 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Algorithm::SVM implements a Support Vector Machine for Perl. Support
04bf74a0 26Vector Machines provide a method for creating classification functions
a7f06b66 27from a set of labeled training data, from which predictions can be
28made for subsequent data sets.
29
c6497ef8
JR
30%description -l pl.UTF-8
31Moduł Algorithm::SVM jest implementacją Support Vector Machine dla
32Perla. Support Vector Machines udostępniają sposób tworzenia funkcji
33klasyfikujących ze zbioru oznaczonych danych treningowych, z których
34można dokonywać przewidywań co do kolejnych zbiorów danych.
a7f06b66 35
36%prep
37%setup -q -n %{pdir}-%{pnam}-%{version}
38
db3af12b 39%{__sed} -i -e 's/#include <errno.h>/#include <errno.h>\n#include <stdlib.h>\n#include <string.h>/g' bindings.cpp
40
a7f06b66 41%build
42%{__perl} Makefile.PL \
91f511bb 43 CCFLAGS="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
a7f06b66 44 INSTALLDIRS=vendor
45
be7c534a
ER
46# cc1plus: warning: command line option "-Wdeclaration-after-statement" is valid for C/ObjC but not for C++
47%{__sed} -i -e 's/-Wdeclaration-after-statement//' Makefile
48
a7f06b66 49%{__make} \
be7c534a 50 CC="%{__cxx}" \
91f511bb 51 OPTIMIZE="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
a7f06b66 52
04b1a149 53%{?with_tests:%{__make} test}
a7f06b66 54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%{__make} install \
59 DESTDIR=$RPM_BUILD_ROOT
60
be7c534a
ER
61rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
62rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Algorithm/SVM/.packlist
63
a7f06b66 64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc Changes README
70%{perl_vendorarch}/Algorithm/*.pm
71%{perl_vendorarch}/Algorithm/SVM
72%dir %{perl_vendorarch}/auto/Algorithm/SVM
a7908fa0 73%{perl_vendorarch}/auto/Algorithm/SVM/*.ix
a7f06b66 74%attr(755,root,root) %{perl_vendorarch}/auto/Algorithm/SVM/*.so
75%{_mandir}/man3/*
This page took 0.148072 seconds and 5 git commands to generate.