]> git.pld-linux.org Git - packages/perl-Algorithm-SVM.git/blame - perl-Algorithm-SVM.spec
- it's a C++ program
[packages/perl-Algorithm-SVM.git] / perl-Algorithm-SVM.spec
CommitLineData
a7f06b66 1#
2# Conditional build:
04b1a149 3%bcond_without tests # don't perform "make test"
a7f06b66 4#
5%include /usr/lib/rpm/macros.perl
629c3e73 6%define pdir Algorithm
7%define pnam SVM
a7f06b66 8Summary: Perl bindings for the libsvm Support Vector Machine library
2c82a38c 9Summary(pl.UTF-8): Dowiązania Perla do biblioteki libsvm (Support Vector Machine)
a7f06b66 10Name: perl-Algorithm-SVM
173ad841 11Version: 0.11
be7c534a 12Release: 5
e6ce8bb7 13# same as perl
14License: GPL v1+ or Artistic
a7f06b66 15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
173ad841 17# Source0-md5: 95a77fc32f958c745d596940a50b7682
be7c534a 18BuildRequires: libstdc++-devel
dc3a178c 19BuildRequires: perl-devel >= 1:5.8.0
a7f06b66 20BuildRequires: rpm-perlprov >= 4.1-13
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Algorithm::SVM implements a Support Vector Machine for Perl. Support
04bf74a0 25Vector Machines provide a method for creating classification functions
a7f06b66 26from a set of labeled training data, from which predictions can be
27made for subsequent data sets.
28
c6497ef8
JR
29%description -l pl.UTF-8
30Moduł Algorithm::SVM jest implementacją Support Vector Machine dla
31Perla. Support Vector Machines udostępniają sposób tworzenia funkcji
32klasyfikujących ze zbioru oznaczonych danych treningowych, z których
33można dokonywać przewidywań co do kolejnych zbiorów danych.
a7f06b66 34
35%prep
36%setup -q -n %{pdir}-%{pnam}-%{version}
37
38%build
39%{__perl} Makefile.PL \
40 INSTALLDIRS=vendor
41
be7c534a
ER
42# cc1plus: warning: command line option "-Wdeclaration-after-statement" is valid for C/ObjC but not for C++
43%{__sed} -i -e 's/-Wdeclaration-after-statement//' Makefile
44
a7f06b66 45%{__make} \
be7c534a
ER
46 CC="%{__cxx}" \
47 OPTIMIZE="%{rpmcxxflags}"
a7f06b66 48
04b1a149 49%{?with_tests:%{__make} test}
a7f06b66 50
51%install
52rm -rf $RPM_BUILD_ROOT
53
54%{__make} install \
55 DESTDIR=$RPM_BUILD_ROOT
56
be7c534a
ER
57rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
58rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Algorithm/SVM/.packlist
59
a7f06b66 60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(644,root,root,755)
65%doc Changes README
66%{perl_vendorarch}/Algorithm/*.pm
67%{perl_vendorarch}/Algorithm/SVM
68%dir %{perl_vendorarch}/auto/Algorithm/SVM
69%{perl_vendorarch}/auto/Algorithm/SVM/*.bs
a7908fa0 70%{perl_vendorarch}/auto/Algorithm/SVM/*.ix
a7f06b66 71%attr(755,root,root) %{perl_vendorarch}/auto/Algorithm/SVM/*.so
72%{_mandir}/man3/*
This page took 0.069631 seconds and 4 git commands to generate.