]> git.pld-linux.org Git - packages/perl-Algorithm-SVM.git/blame - perl-Algorithm-SVM.spec
- rebuild with perl 5.18.0
[packages/perl-Algorithm-SVM.git] / perl-Algorithm-SVM.spec
CommitLineData
a7f06b66 1#
2# Conditional build:
04b1a149 3%bcond_without tests # don't perform "make test"
a7f06b66 4#
5%include /usr/lib/rpm/macros.perl
629c3e73 6%define pdir Algorithm
7%define pnam SVM
a7f06b66 8Summary: Perl bindings for the libsvm Support Vector Machine library
2c82a38c 9Summary(pl.UTF-8): Dowiązania Perla do biblioteki libsvm (Support Vector Machine)
a7f06b66 10Name: perl-Algorithm-SVM
db3af12b 11Version: 0.13
319f4ba8 12Release: 3
e6ce8bb7 13# same as perl
14License: GPL v1+ or Artistic
a7f06b66 15Group: Development/Languages/Perl
93db4d97 16Source0: http://www.cpan.org/modules/by-module/Algorithm/%{pdir}-%{pnam}-%{version}.tar.gz
db3af12b 17# Source0-md5: 276ec1b341e05aa4c0353685f32ea4d5
93db4d97 18URL: http://search.cpan.org/dist/Algorithm-SVM/
be7c534a 19BuildRequires: libstdc++-devel
dc3a178c 20BuildRequires: perl-devel >= 1:5.8.0
a7f06b66 21BuildRequires: rpm-perlprov >= 4.1-13
93db4d97 22BuildRequires: sed >= 4.0
a7f06b66 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Algorithm::SVM implements a Support Vector Machine for Perl. Support
04bf74a0 27Vector Machines provide a method for creating classification functions
a7f06b66 28from a set of labeled training data, from which predictions can be
29made for subsequent data sets.
30
c6497ef8
JR
31%description -l pl.UTF-8
32Moduł Algorithm::SVM jest implementacją Support Vector Machine dla
33Perla. Support Vector Machines udostępniają sposób tworzenia funkcji
34klasyfikujących ze zbioru oznaczonych danych treningowych, z których
35można dokonywać przewidywań co do kolejnych zbiorów danych.
a7f06b66 36
37%prep
38%setup -q -n %{pdir}-%{pnam}-%{version}
39
db3af12b 40%{__sed} -i -e 's/#include <errno.h>/#include <errno.h>\n#include <stdlib.h>\n#include <string.h>/g' bindings.cpp
41
a7f06b66 42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45
be7c534a
ER
46# cc1plus: warning: command line option "-Wdeclaration-after-statement" is valid for C/ObjC but not for C++
47%{__sed} -i -e 's/-Wdeclaration-after-statement//' Makefile
48
a7f06b66 49%{__make} \
be7c534a
ER
50 CC="%{__cxx}" \
51 OPTIMIZE="%{rpmcxxflags}"
a7f06b66 52
04b1a149 53%{?with_tests:%{__make} test}
a7f06b66 54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%{__make} install \
59 DESTDIR=$RPM_BUILD_ROOT
60
be7c534a
ER
61rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
62rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Algorithm/SVM/.packlist
63
a7f06b66 64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc Changes README
70%{perl_vendorarch}/Algorithm/*.pm
71%{perl_vendorarch}/Algorithm/SVM
72%dir %{perl_vendorarch}/auto/Algorithm/SVM
73%{perl_vendorarch}/auto/Algorithm/SVM/*.bs
a7908fa0 74%{perl_vendorarch}/auto/Algorithm/SVM/*.ix
a7f06b66 75%attr(755,root,root) %{perl_vendorarch}/auto/Algorithm/SVM/*.so
76%{_mandir}/man3/*
This page took 0.090439 seconds and 4 git commands to generate.