]> git.pld-linux.org Git - packages/parallel.git/blame - parallel.spec
- pl
[packages/parallel.git] / parallel.spec
CommitLineData
0a10c022 1Summary: Shell tool for executing jobs in parallel
46350488 2Summary(pl.UTF-8): Narzędzie powłoki do równoległego uruchamiania zadań
0a10c022 3Name: parallel
deb09689 4Version: 20201022
0a10c022
AM
5Release: 1
6License: GPL v3+
8027a409 7Group: Applications/System
d31db2e3 8Source0: https://ftp.gnu.org/gnu/parallel/%{name}-%{version}.tar.bz2
deb09689 9# Source0-md5: 03899475967ff4ca529e3f998fbc4932
d31db2e3 10URL: https://www.gnu.org/software/parallel/
0a10c022
AM
11BuildRequires: perl-tools-pod
12BuildRequires: rpm-perlprov
13BuildArch: noarch
8027a409 14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0a10c022
AM
15
16%description
17GNU Parallel is a shell tool for executing jobs in parallel using one
18or more machines. A job is typically a single command or a small
19script that has to be run for each of the lines in the input. The
20typical input is a list of files, a list of hosts, a list of users, or
21a list of tables.
22
23If you use xargs today you will find GNU Parallel very easy to use. If
24you write loops in shell, you will find GNU Parallel may be able to
25replace most of the loops and make them run faster by running jobs in
26parallel. If you use ppss or pexec you will find GNU Parallel will
27often make the command easier to read.
28
29GNU Parallel also makes sure output from the commands is the same
30output as you would get had you run the commands sequentially. This
31makes it possible to use output from GNU Parallel as input for other
32programs.
33
34GNU Parallel is command-line-compatible with moreutils' parallel, but
35offers additional features.
36
46350488
JB
37%description -l pl.UTF-8
38GNU Parallel to narzędzie powłoki do równoległego uruchamiania zadań
39przy użyciu jednej lub większej liczby maszyn. Zadanie to zwykle
40pojedyncze polecenie lub mały skrypt, który ma być uruchomiony dla
41każdego wiersza z wejścia. Zwykle wejściem jest lista plików, lista
42hostów, lista użytkowników lub lista tabel.
43
44Korzystający dotychczas z xargs uznają GNU Parallel za bardzo łatwe w
45użyciu. Piszący pętle w języku powłoki zauważą, że GNU Parallel może
46zastąpić większość pętli i przyspieszyć je poprzez uruchamianie zadań
47równolegle. Użytkownicy programów ppss lub pexec zwykle uznają, że
48GNU Parallel czyni polecenia bardziej czytelnymi.
49
50GNU Parallel zapewnia dodatkowo, że wyjście poleceń jest takie samo,
51jak przy sekwencyjnym uruchamianiu poleceń. Pozwala to wykorzystywać
52wyjście z GNU Parallel jako wejście dla innych programów.
53
54GNU Parallel jest zgodny co do wiersza poleceń z narzędziem parallel z
55moreutils, ale oferuje dodatkowe możliwości.
56
a0459bde 57%package -n env_parallel
46350488
JB
58Summary: env_parallel shell function
59Summary(pl.UTF-8): Funkca powłoki env_parallel
a0459bde
ER
60Group: Applications/System
61Requires: %{name} = %{version}-%{release}
62
63%description -n env_parallel
64env_parallel is a shell function that exports the current environment
46350488
JB
65to GNU Parallel.
66
67%description -n env_parallel -l pl.UTF-8
68env_parallel to funkcja powłoki eksportująca bieżące środowisko do
69GNU Parallel.
a0459bde 70
0a10c022 71%prep
0a10c022
AM
72%setup -q
73
16e7217c
ER
74%{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' src/{parallel,sem}
75%{__sed} -i -e '1{\@^#!@d}' src/env_parallel.*
76%{__sed} -i -e '1s,^#!/usr/bin/env ,#!/bin/,' src/env_* src/parset
77
0a10c022
AM
78%build
79%configure
80%{__make}
81
82%install
0a10c022 83rm -rf $RPM_BUILD_ROOT
8027a409 84install -d $RPM_BUILD_ROOT%{_sysconfdir}/parallel
0a10c022
AM
85%{__make} install \
86 DESTDIR=$RPM_BUILD_ROOT
87
8027a409 88mv $RPM_BUILD_ROOT%{_mandir}/man1/{sql,parallel-sql}.1
d31db2e3 89touch $RPM_BUILD_ROOT%{_sysconfdir}/parallel/config
8027a409 90rm -rv $RPM_BUILD_ROOT%{_docdir}/parallel
0a10c022
AM
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files
96%defattr(644,root,root,755)
8027a409
ER
97%doc README NEWS
98%doc src/parallel.html src/sem.html src/sql.html src/niceload.html
99%doc src/*.texi
100%dir %{_sysconfdir}/parallel
101%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/parallel/config
b347d81b 102%attr(755,root,root) %{_bindir}/niceload
0a10c022 103%attr(755,root,root) %{_bindir}/parallel
b347d81b
AM
104%attr(755,root,root) %{_bindir}/parcat
105%attr(755,root,root) %{_bindir}/parset
deb09689 106%attr(755,root,root) %{_bindir}/parsort
0a10c022
AM
107%attr(755,root,root) %{_bindir}/sem
108%attr(755,root,root) %{_bindir}/sql
8027a409
ER
109%{_mandir}/man1/niceload.1*
110%{_mandir}/man1/parallel.1*
8027a409 111%{_mandir}/man1/parallel-sql.1*
b347d81b
AM
112%{_mandir}/man1/parcat.1*
113%{_mandir}/man1/parset.1*
deb09689 114%{_mandir}/man1/parsort.1*
b347d81b
AM
115%{_mandir}/man1/sem.1*
116%{_mandir}/man7/parallel_alternatives.7*
117%{_mandir}/man7/parallel_book.7*
3ae6fa45
ER
118%{_mandir}/man7/parallel_design.7*
119%{_mandir}/man7/parallel_tutorial.7*
a0459bde
ER
120
121%files -n env_parallel
122%defattr(644,root,root,755)
123%attr(755,root,root) %{_bindir}/env_parallel
124%attr(755,root,root) %{_bindir}/env_parallel.ash
125%attr(755,root,root) %{_bindir}/env_parallel.bash
126%attr(755,root,root) %{_bindir}/env_parallel.csh
127%attr(755,root,root) %{_bindir}/env_parallel.dash
128%attr(755,root,root) %{_bindir}/env_parallel.fish
129%attr(755,root,root) %{_bindir}/env_parallel.ksh
130%attr(755,root,root) %{_bindir}/env_parallel.mksh
131%attr(755,root,root) %{_bindir}/env_parallel.pdksh
132%attr(755,root,root) %{_bindir}/env_parallel.sh
133%attr(755,root,root) %{_bindir}/env_parallel.tcsh
134%attr(755,root,root) %{_bindir}/env_parallel.zsh
135%{_mandir}/man1/env_parallel.1*
This page took 0.07854 seconds and 4 git commands to generate.