]> git.pld-linux.org Git - packages/owncloudclient.git/blame - owncloudclient.spec
cleanups; add -libs and -devel
[packages/owncloudclient.git] / owncloudclient.spec
CommitLineData
b72e02cb 1Summary: The ownCloud client
69b59edf 2Name: owncloudclient
b72e02cb 3Version: 2.1.1
2b137c43 4Release: 0.9
42696897 5License: GPL v2+
8766d745 6Group: X11/Applications
69b59edf 7Source0: https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
dab60e18 8# Source0-md5: 63a971158201a8dffe96a02c54b86819
42696897 9URL: https://www.owncloud.com/
2b137c43 10BuildRequires: QtKeychain-devel
b72e02cb 11BuildRequires: cmake >= 2.8.11
b72e02cb
PG
12BuildRequires: desktop-file-utils
13BuildRequires: openssl-devel
b72e02cb 14BuildRequires: python-Sphinx
d5924c14 15BuildRequires: sphinx-pdg
42696897 16BuildRequires: tar >= 1:1.22
d5924c14 17BuildRequires: texlive-latex-ams
42696897
ER
18BuildRequires: xz
19Requires: %{name}-libs = %{version}-%{release}
63be3806 20Requires: Qt5Gui-platform-xcb
1a8da98e 21Suggests: %{name}-nautilus
b72e02cb 22Suggests: %{name}-nemo
b72e02cb 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1a8da98e
PG
24
25%description
26The ownCloud sync client - github.com/owncloud/client
27
b72e02cb
PG
28ownCloud client enables you to connect to your private ownCloud
29Server. With it you can create folders in your home directory, and
30keep the contents of those folders synced with your ownCloud server.
31Simply copy a file into the directory and the ownCloud Client does the
32rest.
1a8da98e
PG
33
34ownCloud gives your employees anytime, anywhere access to the files
b72e02cb
PG
35they need to get the job done, whether through this desktop
36application, our mobile apps, the web interface, or other WebDAV
37clients. With it, your employees can easily view and share documents
38and information critical to the business, in a secure, flexible and
39controlled architecture. You can easily extend ownCloud with plug-ins
40from the community, or that you build yourself to meet the
41requirements of your infrastructure and business.
1a8da98e 42
42696897
ER
43%package libs
44Summary: Shared ownCloud client libraries
45Group: Libraries
46
47%description libs
48Shared ownCloud client libraries.
49
50%package devel
51Summary: Header files for %{name} library
52Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
53Group: Development/Libraries
54Requires: %{name}-libs = %{version}-%{release}
55
56%description devel
57Header files for %{name} library.
58
59%description devel -l pl.UTF-8
60Pliki nagłówkowe biblioteki %{name}.
61
1a8da98e 62%prep
d5924c14 63%setup -q
1a8da98e 64
1a8da98e 65%build
d5924c14
PG
66install -d build
67cd build
68%cmake \
d5924c14
PG
69 -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain \
70 -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqtkeychain.so \
42696897 71 ..
d5924c14 72%{__make}
1a8da98e
PG
73
74# documentation here?
42696897
ER
75if [ -e conf.py ]; then
76 # for old cmake versions we need to move the conf.py.
77 mv conf.py doc/
1a8da98e
PG
78fi
79
b72e02cb 80%{__make} doc
1a8da98e
PG
81
82%install
b72e02cb 83rm -rf $RPM_BUILD_ROOT
931f5ef6 84%{__make} -C build install \
b72e02cb 85 DESTDIR=$RPM_BUILD_ROOT
1a8da98e 86
42696897
ER
87mv $RPM_BUILD_ROOT%{_docdir}/html ${RPM_BUILD_ROOT}%{_docdir}/%{name}
88mv $RPM_BUILD_ROOT%{_docdir}/latex ${RPM_BUILD_ROOT}%{_docdir}/%{name}
89rm $RPM_BUILD_ROOT%{_docdir}/%{name}/unthemed/.buildinfo
90
91%clean
92rm -rf $RPM_BUILD_ROOT
1a8da98e 93
1a8da98e 94%post
42696897 95%update_icon_cache_post hicolor
1a8da98e
PG
96
97%postun
98if [ $1 -eq 0 ] ; then
42696897 99 %update_icon_cache_post hicolor
1a8da98e 100fi
42696897
ER
101
102%post libs -p /sbin/ldconfig
103%postun libs -p /sbin/ldconfig
1a8da98e
PG
104
105%files
b72e02cb 106%defattr(644,root,root,755)
931f5ef6
PG
107%doc README.md COPYING
108%doc %{_docdir}/%{name}
42696897 109%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
b72e02cb
PG
110%attr(755,root,root) %{_bindir}/owncloud
111%attr(755,root,root) %{_bindir}/owncloudcmd
b72e02cb 112%{_desktopdir}/owncloud.desktop
931f5ef6 113%{_iconsdir}/*/*/apps/*.png
c1b38b2d 114%{_datadir}/owncloud
42696897 115#%{_libdir}/owncloud/libocsync.so.*
fff4970d 116%dir %{_libdir}/owncloud
42696897
ER
117%{_mandir}/man1/owncloud*
118
119# subpackages
1a8da98e 120%{_datadir}/nautilus-python/extensions/syncstate.py*
1a8da98e 121%{_datadir}/nemo-python/extensions/syncstate.py*
1a8da98e 122
42696897
ER
123%files libs
124%defattr(644,root,root,755)
125%attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
126%ghost %{_libdir}/libowncloudsync.so.0
127%attr(755,root,root) %{_libdir}/owncloud/libocsync.so.*.*.*
128%ghost %{_libdir}/owncloud/libocsync.so.0
fff4970d 129
42696897
ER
130%files devel
131%defattr(644,root,root,755)
132%{_includedir}/owncloudsync
133%{_libdir}/libowncloudsync.so
134%{_libdir}/owncloud/libocsync.so
This page took 0.168615 seconds and 4 git commands to generate.