]> git.pld-linux.org Git - packages/owncloudclient.git/blame - owncloudclient.spec
add doc and gui bconds
[packages/owncloudclient.git] / owncloudclient.spec
CommitLineData
8a768bde
ER
1#
2# Conditional build:
4bbe24d5
ER
3%bcond_without nautilus # build Nautilus extension
4%bcond_without doc # build docs
5%bcond_without gui # build only libraries
6
7%if %{without gui}
8%undefine with_nautilus
9%undefine with_doc
10%endif
8a768bde 11
b72e02cb 12Summary: The ownCloud client
69b59edf 13Name: owncloudclient
b72e02cb 14Version: 2.1.1
2b137c43 15Release: 0.9
42696897 16License: GPL v2+
8766d745 17Group: X11/Applications
69b59edf 18Source0: https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
dab60e18 19# Source0-md5: 63a971158201a8dffe96a02c54b86819
42696897 20URL: https://www.owncloud.com/
60de00dd
ER
21BuildRequires: QtCore-devel
22BuildRequires: QtDBus-devel
23BuildRequires: QtGui-devel
2b137c43 24BuildRequires: QtKeychain-devel
60de00dd
ER
25BuildRequires: QtNetwork-devel
26BuildRequires: QtSql-devel
27BuildRequires: QtWebKit-devel
28BuildRequires: QtXmlPatterns-devel
b72e02cb 29BuildRequires: cmake >= 2.8.11
b72e02cb 30BuildRequires: desktop-file-utils
60de00dd 31BuildRequires: libstdc++-devel
b72e02cb 32BuildRequires: openssl-devel
60de00dd 33BuildRequires: pkgconfig
b72e02cb 34BuildRequires: python-Sphinx
d5924c14 35BuildRequires: sphinx-pdg
e40771e0 36BuildRequires: sqlite3-devel
42696897 37BuildRequires: tar >= 1:1.22
d5924c14 38BuildRequires: texlive-latex-ams
42696897
ER
39BuildRequires: xz
40Requires: %{name}-libs = %{version}-%{release}
63be3806 41Requires: Qt5Gui-platform-xcb
1a8da98e 42Suggests: %{name}-nautilus
b72e02cb 43Suggests: %{name}-nemo
b72e02cb 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1a8da98e
PG
45
46%description
47The ownCloud sync client - github.com/owncloud/client
48
b72e02cb
PG
49ownCloud client enables you to connect to your private ownCloud
50Server. With it you can create folders in your home directory, and
51keep the contents of those folders synced with your ownCloud server.
52Simply copy a file into the directory and the ownCloud Client does the
53rest.
1a8da98e
PG
54
55ownCloud gives your employees anytime, anywhere access to the files
b72e02cb
PG
56they need to get the job done, whether through this desktop
57application, our mobile apps, the web interface, or other WebDAV
58clients. With it, your employees can easily view and share documents
59and information critical to the business, in a secure, flexible and
60controlled architecture. You can easily extend ownCloud with plug-ins
61from the community, or that you build yourself to meet the
62requirements of your infrastructure and business.
1a8da98e 63
42696897
ER
64%package libs
65Summary: Shared ownCloud client libraries
66Group: Libraries
67
68%description libs
69Shared ownCloud client libraries.
70
71%package devel
72Summary: Header files for %{name} library
73Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
74Group: Development/Libraries
75Requires: %{name}-libs = %{version}-%{release}
76
77%description devel
78Header files for %{name} library.
79
80%description devel -l pl.UTF-8
81Pliki nagłówkowe biblioteki %{name}.
82
8a768bde 83%package nautilus
36a3a84c 84Summary: Nautilus overlay icons
8a768bde
ER
85Group: Applications
86Requires: %{name} = %{version}-%{release}
87Requires: nautilus-python
88
89%description nautilus
36a3a84c
ER
90This package provides overlay icons to visualize the sync state in the
91Nautilus file manager.
8a768bde 92
1a8da98e 93%prep
d5924c14 94%setup -q
1a8da98e 95
1a8da98e 96%build
d5924c14
PG
97install -d build
98cd build
99%cmake \
d5924c14
PG
100 -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain \
101 -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqtkeychain.so \
4bbe24d5 102 %{!?with_gui:-DBUILD_LIBRARIES_ONLY=ON} \
42696897 103 ..
d5924c14 104%{__make}
1a8da98e 105
4bbe24d5 106%if %{with doc}
1a8da98e 107# documentation here?
42696897
ER
108if [ -e conf.py ]; then
109 # for old cmake versions we need to move the conf.py.
110 mv conf.py doc/
1a8da98e 111fi
b72e02cb 112%{__make} doc
4bbe24d5 113%endif
1a8da98e
PG
114
115%install
b72e02cb 116rm -rf $RPM_BUILD_ROOT
931f5ef6 117%{__make} -C build install \
b72e02cb 118 DESTDIR=$RPM_BUILD_ROOT
1a8da98e 119
4bbe24d5 120%if %{with nautilus}
8a768bde
ER
121# nemo not in pld
122%{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate.py*
4bbe24d5 123%endif
8a768bde 124
4bbe24d5 125%if %{with doc}
42696897
ER
126mv $RPM_BUILD_ROOT%{_docdir}/html ${RPM_BUILD_ROOT}%{_docdir}/%{name}
127mv $RPM_BUILD_ROOT%{_docdir}/latex ${RPM_BUILD_ROOT}%{_docdir}/%{name}
128rm $RPM_BUILD_ROOT%{_docdir}/%{name}/unthemed/.buildinfo
4bbe24d5 129%endif
42696897
ER
130
131%clean
132rm -rf $RPM_BUILD_ROOT
1a8da98e 133
1a8da98e 134%post
42696897 135%update_icon_cache_post hicolor
1a8da98e
PG
136
137%postun
138if [ $1 -eq 0 ] ; then
42696897 139 %update_icon_cache_post hicolor
1a8da98e 140fi
42696897
ER
141
142%post libs -p /sbin/ldconfig
143%postun libs -p /sbin/ldconfig
1a8da98e 144
4bbe24d5 145%if %{with gui}
1a8da98e 146%files
b72e02cb 147%defattr(644,root,root,755)
931f5ef6
PG
148%doc README.md COPYING
149%doc %{_docdir}/%{name}
42696897 150%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
b72e02cb
PG
151%attr(755,root,root) %{_bindir}/owncloud
152%attr(755,root,root) %{_bindir}/owncloudcmd
b72e02cb 153%{_desktopdir}/owncloud.desktop
931f5ef6 154%{_iconsdir}/*/*/apps/*.png
c1b38b2d 155%{_datadir}/owncloud
4bbe24d5 156%{_libdir}/owncloud/libocsync.so.*
fff4970d 157%dir %{_libdir}/owncloud
42696897 158%{_mandir}/man1/owncloud*
4bbe24d5 159%endif
42696897 160
42696897
ER
161%files libs
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
164%ghost %{_libdir}/libowncloudsync.so.0
165%attr(755,root,root) %{_libdir}/owncloud/libocsync.so.*.*.*
166%ghost %{_libdir}/owncloud/libocsync.so.0
fff4970d 167
42696897
ER
168%files devel
169%defattr(644,root,root,755)
170%{_includedir}/owncloudsync
171%{_libdir}/libowncloudsync.so
172%{_libdir}/owncloud/libocsync.so
8a768bde
ER
173
174%if %{with nautilus}
175%files nautilus
176%defattr(644,root,root,755)
177%{_datadir}/nautilus-python/extensions/syncstate.py*
178%endif
This page took 0.260318 seconds and 4 git commands to generate.