]> git.pld-linux.org Git - packages/owncloud.git/blame - owncloud.spec
Up to 4.5.2 (Several critical security fixes including oC-SA-2012-003, oC-SA-2012...
[packages/owncloud.git] / owncloud.spec
CommitLineData
e770a8b9
AF
1#TODO:
2# - make package for libs from 3rdparty dir:
3# - aws-sdk http://aws.amazon.com/sdkforphp
4# - dropbox-php http://www.dropbox-php.com/
5# - jquery-minicolors https://github.com/claviska/jquery-miniColors/
6# - phpMyID http://siege.org/projects/phpMyID
7# - php-pear-OS_Guess
8# - phpass http://www.openwall.com/phpass/
9# - php-cloudfiles https://github.com/rackspace/php-cloudfiles
10# - simpletest http://simpletest.org/en/download.html
11# - smb4php http://www.phpclasses.org/smb4php
12# - jquery-timepicker http://fgelinas.com/code/timepicker
13# - sabredav - https://code.google.com/p/sabredav/
89b77f4a
AF
14Summary: Private file sync and share server
15Name: owncloud
f1d5190a 16Version: 4.5.2
56b22c21 17Release: 1
89b77f4a
AF
18License: AGPL v3, MIT
19Group: Applications/WWW
20Source0: http://owncloud.org/releases/%{name}-%{version}.tar.bz2
f1d5190a 21# Source0-md5: a23cd7567a35d7c0d3b5e50566ca3853
89b77f4a 22Source1: config.php
83880b0e
AF
23Source2: apache.conf
24Source3: lighttpd.conf
89b77f4a
AF
25Patch0: system-pear.patch
26URL: http://owncloud.org
27BuildRequires: rpmbuild(macros) >= 1.268
e770a8b9
AF
28Requires: getid3
29Requires: php(core) >= 5.3
89b77f4a
AF
30Requires: php(gd)
31Requires: php(mbstring)
32Requires: php(pdo)
33Requires: php(pdo-sqlite)
34Requires: php(posix)
35Requires: php(sqlite3)
36Requires: php(xml)
37Requires: php(zip)
e770a8b9 38Requires: php(zlib)
89b77f4a
AF
39#Requires: php-When
40Requires: php-pear-Archive_Tar
41Requires: php-pear-Console_Getopt
42Requires: php-pear-Crypt_Blowfish
43Requires: php-pear-MDB2
44Requires: php-pear-MDB2_Driver_mysql
45Requires: php-pear-MDB2_Driver_pgsql
46Requires: php-pear-MDB2_Driver_sqlite
47Requires: php-pear-MDB2_Schema
48Requires: php-pear-PEAR-core
49Requires: php-pear-XML_Parser
50Requires: php-phpmailer >= 5.2
51#Requires: php-sabredav-Sabre_CalDAV
52#Requires: php-sabredav-Sabre_CardDAV
53Requires: webapps
54Requires: webserver(access)
55Requires: webserver(alias)
56Requires: webserver(php)
57Requires: webserver(rewrite)
58Suggests: php(mysql)
59Suggests: php(pdo-mysql)
60Suggests: php(pdo-pgsql)
61Suggests: php(pgsql)
62BuildArch: noarch
63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65%define _appdir %{_datadir}/%{name}
66%define _webapps /etc/webapps
67%define _webapp %{name}
68%define _sysconfdir %{_webapps}/%{_webapp}
69
70%description
71ownCloud Server provides you a private file sync and share cloud. Host
72this server to easily sync business or private documents across all
73your devices, and share those documents with other users of your
74ownCloud server on their devices.
75
76%prep
77%setup -q -n %{name}
78%patch0 -p1
79
89b77f4a 80# remove bundled 3rdparty libs
e770a8b9 81%{__rm} -r 3rdparty/{class.phpmailer.php,class.smtp.php,getid3,Archive,Console,Crypt_Blowfish,MDB2,MDB2.php,XML}
89b77f4a
AF
82# PEAR-core
83%{__rm} -r 3rdparty/{PEAR.php,PEAR5.php,System.php,PEAR}
84
85%install
86rm -rf $RPM_BUILD_ROOT
87install -d $RPM_BUILD_ROOT{%{_sysconfdir}/config,%{_appdir}}
88
89cp -pdR *.php db_structure.xml 3rdparty apps core files l10n lib ocs search settings themes $RPM_BUILD_ROOT/%{_appdir}
90ln -s %{_sysconfdir}/config $RPM_BUILD_ROOT%{_appdir}/config
91cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/config/config.php
92
83880b0e
AF
93cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
94cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
95cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
89b77f4a
AF
96
97install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
98
99%triggerin -- apache1 < 1.3.37-3, apache1-base
100%webapp_register apache %{_webapp}
101
102%triggerun -- apache1 < 1.3.37-3, apache1-base
103%webapp_unregister apache %{_webapp}
104
105%triggerin -- apache < 2.2.0, apache-base
106%webapp_register httpd %{_webapp}
107
108%triggerun -- apache < 2.2.0, apache-base
109%webapp_unregister httpd %{_webapp}
110
111%triggerin -- lighttpd
112%webapp_register lighttpd %{_webapp}
113
114%triggerun -- lighttpd
115%webapp_unregister lighttpd %{_webapp}
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(644,root,root,755)
122%doc AUTHORS COPYING-AGPL COPYING-README README
123%dir %attr(750,root,http) %{_sysconfdir}
124%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
125%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
126%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
127%dir %attr(750,http,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
128%attr(640,http,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config/*.php
129%{_appdir}
130%dir %attr(750,http,http) %{_localstatedir}/lib/%{name}
This page took 0.131692 seconds and 4 git commands to generate.