]> git.pld-linux.org Git - packages/oprofile.git/blame - oprofile.spec
- updated to 1.1.0
[packages/oprofile.git] / oprofile.spec
CommitLineData
29410737
JR
1# TODO:
2# Warning: The user account 'oprofile:oprofile' does not exist on the system.
3# To profile JITed code, this special user account must exist.
4# Please ask your system administrator to add the following user and group:
5# user name : 'oprofile'
6# group name: 'oprofile'
7# The 'oprofile' group must be the default group for the 'oprofile' user.
79dff00f 8#
5e4697ab 9Summary: System-wide profiler
9973c25f 10Summary(pl.UTF-8): Ogólnosystemowy profiler
1d3bcbbf 11Name: oprofile
b110efa4
JB
12Version: 1.1.0
13Release: 1
79dff00f 14License: GPL v2 (oprofile), LGPL v2.1+ (libopagent)
1d3bcbbf 15Group: Applications/System
79dff00f 16Source0: http://downloads.sourceforge.net/oprofile/%{name}-%{version}.tar.gz
b110efa4 17# Source0-md5: 248c4c069f9476f427fa7195563f9867
1d3bcbbf 18URL: http://oprofile.sourceforge.net/
ac799760 19# not used directly, but build fails without it
b110efa4 20BuildRequires: autoconf >= 2.50
1e7599a4 21BuildRequires: binutils-devel
79dff00f 22BuildRequires: libstdc++-devel
b110efa4 23BuildRequires: linux-libc-headers >= 7:2.6.31
1d3bcbbf 24BuildRequires: popt-devel
5dc93ca5 25BuildRequires: rpmbuild(macros) >= 1.217
b110efa4
JB
26Requires: uname(release) >= 2.6.31
27Conflicts: kernel < 2.6.31
0c43d782 28ExclusiveArch: alpha arm %{ix86} ia64 mips ppc ppc64 %{x8664} x32
1d3bcbbf
AM
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
0c50e257
AM
31%define oprofile_arch %(echo "%{_target_base_arch}" | sed -e 's#x86_64#x86-64#')
32
1d3bcbbf
AM
33%description
34It consists of a kernel driver and a daemon for collecting sample
35data, and several post-profiling tools for turning data into
36information.
37
38OProfile leverages the hardware performance counters of the CPU to
39enable profiling of a wide variety of interesting statistics, which
40can also be used for basic time-spent profiling. All code is profiled:
41hardware and software interrupt handlers, kernel modules, the kernel,
42shared libraries, and applications.
43
dc16cb39
JR
44%description -l pl.UTF-8
45Pakiet składa się ze sterownika dla jądra oraz demona zbierającego
46próbki danych, a także kilku narzędzi do postprocesingu,
47przekształcających dane na informacje.
13838d6f 48
dc16cb39
JR
49OProfile utrzymuje liczniki wydajności sprzętu dla CPU, aby umożliwić
50profilowanie wielorakich interesujących statystyk, których można
51używać także do podstawowego profilowania czasu wykonywania.
52Profilowany jest cały kod: procedury obsługi przerwań sprzętowych i
53programowych, moduły jądra, jądro, biblioteki współdzielone oraz
b25c0097 54aplikacje.
13838d6f 55
79dff00f
JB
56%package devel
57Summary: Header file for libopagent library
58Summary(pl.UTF-8): Plik nagłówkowy biblioteki libopagent
59License: LGPL v2.1+
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62
63%description devel
64Header file for libopagent library.
65
66%description devel -l pl.UTF-8
67Plik nagłówkowy biblioteki libopagent.
68
69%package static
70Summary: Static libopagent library
71Summary(pl.UTF-8): Statyczna biblioteka libopagent
72License: LGPL v2.1+
73Group: Development/Libraries
74Requires: %{name}-devel = %{version}-%{release}
75
76%description static
77Static libopagent library.
78
79%description static -l pl.UTF-8
80Statyczna biblioteka libopagent.
81
1d3bcbbf
AM
82%prep
83%setup -q
84
85%build
29410737 86%configure
8a7f24f8 87
29410737 88%{__make}
1d3bcbbf
AM
89
90%install
91rm -rf $RPM_BUILD_ROOT
6c2c6c7f 92install -d $RPM_BUILD_ROOT%{_var}/lib/oprofile
1d3bcbbf
AM
93
94%{__make} install \
95 DESTDIR=$RPM_BUILD_ROOT
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
6c2c6c7f 100%preun
4f7144ed
ER
101if [ "$1" = 0 ]; then
102 %{_bindir}/opcontrol --shutdown 2>/dev/null 1>&2
103 rm -rf %{_var}/lib/oprofile/*
104fi
6c2c6c7f 105
1d3bcbbf
AM
106%files
107%defattr(644,root,root,755)
29410737
JR
108%doc ChangeLog* README TODO doc/*.html doc/*.png doc/*.xsd
109%attr(755,root,root) %{_bindir}/ocount
79dff00f
JB
110%attr(755,root,root) %{_bindir}/opannotate
111%attr(755,root,root) %{_bindir}/oparchive
29410737
JR
112%attr(755,root,root) %{_bindir}/op-check-perfevents
113%attr(755,root,root) %{_bindir}/operf
79dff00f
JB
114%attr(755,root,root) %{_bindir}/opgprof
115%attr(755,root,root) %{_bindir}/ophelp
116%attr(755,root,root) %{_bindir}/opimport
117%attr(755,root,root) %{_bindir}/opjitconv
118%attr(755,root,root) %{_bindir}/opreport
82b4ed37 119%dir %{_libdir}/oprofile
79dff00f
JB
120%attr(755,root,root) %{_libdir}/oprofile/libopagent.so.*.*.*
121%attr(755,root,root) %{_libdir}/oprofile/libopagent.so.1
b60332ef 122%{_datadir}/%{name}
6c2c6c7f 123%dir %{_var}/lib/oprofile
29410737 124%{_mandir}/man1/ocount.1*
79dff00f
JB
125%{_mandir}/man1/opannotate.1*
126%{_mandir}/man1/oparchive.1*
29410737
JR
127%{_mandir}/man1/op-check-perfevents.1*
128%{_mandir}/man1/operf.1*
79dff00f
JB
129%{_mandir}/man1/opgprof.1*
130%{_mandir}/man1/ophelp.1*
131%{_mandir}/man1/opimport.1*
132%{_mandir}/man1/opreport.1*
133%{_mandir}/man1/oprofile.1*
134
135%files devel
136%defattr(644,root,root,755)
137%attr(755,root,root) %{_libdir}/oprofile/libopagent.so
138%{_libdir}/oprofile/libopagent.la
139%{_includedir}/opagent.h
140
141%files static
142%defattr(644,root,root,755)
143%{_libdir}/oprofile/libopagent.a
This page took 0.113614 seconds and 4 git commands to generate.