]> git.pld-linux.org Git - packages/openwsman.git/blame - openwsman.spec
rebuild with perl 5.32
[packages/openwsman.git] / openwsman.spec
CommitLineData
5db175a1 1# TODO:
5db175a1 2# - daemon init script
ce0d47d3 3# - where should arch-dependent .jar be packaged?
6961ea6a 4# - add -module to plugins build?
a06ea685
ER
5#
6# Conditional build:
fd5cd5a5
JB
7%bcond_without cim # CIM plugin (sblim-sfcc based)
8%bcond_without java # Java bindings
9%bcond_without perl # Perl bindings
d73560d5
JB
10%bcond_without python # Python bindings (any)
11%bcond_without python2 # Python 2.x bindings
12%bcond_without python3 # Python 3.x bindings
fd5cd5a5 13%bcond_without ruby # Ruby bindings
a06ea685 14
d73560d5
JB
15%if %{without python}
16%undefine with_python2
17%undefine with_python3
18%endif
5db175a1 19Summary: Implementation of the Web Services Management specification (WS-Management)
15f3efed 20Summary(pl.UTF-8): Implementacja specyfikacji Web Services Management (WS-Management)
5db175a1 21Name: openwsman
284335a8 22Version: 2.6.11
a0f7a2a1 23Release: 3
5db175a1
AM
24License: BSD
25Group: Libraries
284335a8 26#Source0Download: https://github.com/Openwsman/openwsman/releases
6961ea6a 27Source0: https://github.com/Openwsman/openwsman/archive/v%{version}/%{name}-%{version}.tar.gz
284335a8 28# Source0-md5: 33a58eb6b13ffe0a51b33553f6cd5728
747b7da9
MK
29Patch0: rdoc-rubygems.patch
30Patch1: %{name}-python.patch
6961ea6a 31URL: https://github.com/Openwsman
d73560d5 32BuildRequires: cmake >= 2.6
396be572 33BuildRequires: curl-devel >= 7.12.0
fd5cd5a5
JB
34%if %{with ruby}
35%if %(locale -a | grep -q '^en_US$'; echo $?)
36BuildRequires: glibc-localedb-all
37%endif
38%endif
ce0d47d3 39BuildRequires: jdk
993872f2 40BuildRequires: libstdc++-devel
396be572 41BuildRequires: libxml2-devel >= 2.0
5db175a1 42BuildRequires: openssl-devel
993872f2 43BuildRequires: pam-devel
fd5cd5a5 44%{?with_perl:BuildRequires: perl-devel}
993872f2 45BuildRequires: pkgconfig
d73560d5
JB
46%{?with_python2:BuildRequires: python-devel >= 2}
47%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
685db724 48BuildRequires: rpmbuild(macros) >= 1.606
fd5cd5a5
JB
49%{?with_ruby:BuildRequires: ruby-devel >= 1.9}
50%{?with_cim:BuildRequires: sblim-sfcc-devel}
15f3efed 51BuildRequires: sed >= 4.0
138a0c32
JB
52BuildRequires: swig >= 2.0.5
53%{?with_perl:BuildRequires: swig-perl >= 2.0.5}
54%{?with_python:BuildRequires: swig-python >= 2.0.5}
55%{?with_ruby:BuildRequires: swig-ruby >= 2.0.5}
685db724 56Requires: %{name}-libs = %{version}-%{release}
5db175a1
AM
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
396be572 59# plugins use symbols from libraries, client libs have circular dependencies with libwsman
a8b066fd 60%define skip_post_check_so .*%{_libdir}/openwsman/.* libwsman_client.so.* libwsman_curl_client_transport.so.* libwsman_server.so.1.0.0 libwsman_clientpp.so.1.0.0 libwsman.so.1.0.0
396be572 61
5db175a1
AM
62%description
63Openwsman is a project intended to provide an open-source
64implementation of the Web Services Management specification
65(WS-Management) and to expose system management information on the
66Linux operating system using the WS-Management protocol. WS-Management
67is based on a suite of web services specifications and usage
68requirements that exposes a set of operations focused on and covers
69all system management aspects.
70
15f3efed
JB
71%description -l pl.UTF-8
72Openwsman to projekt, którego celem jest zapewnienie mającej otwarte
73źródła implementacji specyfikacji Web Services Management
74(WS-Management) i udostępnienie informacji związanych z zarządzaniem
75systemem pod Linuksem poprzez protokół WS-Management. WS-Management
76jest oparty na zbiorze specyfikacji i wymaganiach usług WWW,
77udostępniających zbiór operacji pokrywających wszystkie aspekty
78zarządzania systemem.
79
685db724
JB
80%package libs
81Summary: Shared openwsman libraries
82Summary(pl.UTF-8): Biblioteki współdzielone openwsman
83Group: Libraries
84Conflicts: openwsman < 2.2.6
85
86%description libs
87Shared openwsman libraries.
88
89%description libs -l pl.UTF-8
90Biblioteki współdzielone openwsman.
91
5db175a1 92%package devel
15f3efed
JB
93Summary: Header files for openwsman
94Summary(pl.UTF-8): Pliki nagłówkowe openwsman
5db175a1 95Group: Development/Libraries
685db724 96Requires: %{name}-libs = %{version}-%{release}
396be572 97Obsoletes: openwsman-static
5db175a1
AM
98
99%description devel
15f3efed
JB
100Header files for openwsman.
101
102%description devel -l pl.UTF-8
103Pliki nagłówkowe openwsman.
5db175a1 104
ce0d47d3
JB
105%package -n java-openwsman
106Summary: Java bindings for openwsman libraries
107Summary(pl.UTF-8): Wiązania Javy do bibliotek openwsman
108Group: Libraries/Java
109Requires: %{name}-libs = %{version}-%{release}
110Requires: jre
111
112%description -n java-openwsman
113Java bindings for openwsman libraries.
114
115%description -n java-openwsman -l pl.UTF-8
116Wiązania Javy do bibliotek openwsman.
117
685db724
JB
118%package -n perl-openwsman
119Summary: Perl bindings for openwsman libraries
120Summary(pl.UTF-8): Wiązania Perla do bibliotek openwsman
121Group: Development/Languages/Perl
122Requires: %{name}-libs = %{version}-%{release}
123
124%description -n perl-openwsman
125Perl bindings for openwsman libraries.
126
127%description -n perl-openwsman -l pl.UTF-8
128Wiązania Perla do bibliotek openwsman.
129
130%package -n python-openwsman
d73560d5
JB
131Summary: Python 2 bindings for openwsman libraries
132Summary(pl.UTF-8): Wiązania Pythona 2 do bibliotek openwsman
ce0d47d3 133Group: Libraries/Python
685db724 134Requires: %{name}-libs = %{version}-%{release}
6961ea6a 135Requires: python-libs
685db724
JB
136
137%description -n python-openwsman
d73560d5 138Python 2 bindings for openwsman libraries.
685db724
JB
139
140%description -n python-openwsman -l pl.UTF-8
d73560d5
JB
141Wiązania Pythona 2 do bibliotek openwsman.
142
143%package -n python3-openwsman
144Summary: Python 3 bindings for openwsman libraries
145Summary(pl.UTF-8): Wiązania Pythona 3 do bibliotek openwsman
146Group: Libraries/Python
147Requires: %{name}-libs = %{version}-%{release}
148Requires: python3-libs >= 1:3.2
149
150%description -n python3-openwsman
151Python 3 bindings for openwsman libraries.
152
153%description -n python3-openwsman -l pl.UTF-8
154Wiązania Pythona 3 do bibliotek openwsman.
685db724 155
ce0d47d3
JB
156%package -n ruby-openwsman
157Summary: Ruby bindings for openwsman libraries
158Summary(pl.UTF-8): Wiązania języka Ruby do bibliotek openwsman
159Group: Development/Languages
160Requires: %{name}-libs = %{version}-%{release}
161Requires: ruby
162
163%description -n ruby-openwsman
164Ruby bindings for openwsman libraries.
165
166%description -n ruby-openwsman -l pl.UTF-8
167Wiązania języka Ruby do bibliotek openwsman.
168
5db175a1
AM
169%prep
170%setup -q
396be572
JB
171%undos src/cpp/CMakeLists.txt
172%patch0 -p1
ce0d47d3 173%patch1 -p1
ce0d47d3 174
5db175a1 175%build
396be572
JB
176install -d build
177cd build
178%cmake .. \
a06ea685
ER
179%if %{with java}
180 -DJAVA_INCLUDE_PATH=%{java_home}/include \
181%else
d73560d5 182 -DBUILD_JAVA=OFF \
a06ea685 183%endif
d73560d5
JB
184 %{!?with_cim:-DBUILD_LIBCIM=OFF} \
185 %{!?with_perl:-DBUILD_PERL=OFF} \
186 %{!?with_python2:-DBUILD_PYTHON=OFF} \
187 -DBUILD_PYTHON3=OFF \
188 -DBUILD_RUBY=%{!?with_ruby:OFF}%{?with_ruby:ON} \
d59a0e35 189 -DPACKAGE_ARCHITECTURE=%{_target_cpu} \
d73560d5 190 %{?with_python2:-DPYTHON_EXECUTABLE=%{__python}} \
93eab964 191 -DRUBY_HAS_VENDOR_RUBY:BOOL=ON
5db175a1 192
fd5cd5a5
JB
193# ruby .gemspec contains non-ascii characters, build fails with C locale
194%{?with_ruby:LC_ALL=en_US} \
9f80c555 195%{__make} -j1
6961ea6a 196
d73560d5
JB
197cd ..
198
199%if %{with python3}
200install -d build-python3
201cd build-python3
202%cmake .. \
203 -DBUILD_JAVA=OFF \
204 %{!?with_cim:-DBUILD_LIBCIM=ON} \
205 -DBUILD_PERL=OFF \
206 -DBUILD_PYTHON=OFF \
207 -DBUILD_PYTHON3=ON \
208 -DBUILD_RUBY=OFF \
209 -DPACKAGE_ARCHITECTURE=%{_target_cpu} \
210 -DPYTHON_EXECUTABLE=%{__python3}
211
212%{__make} -j1
213%endif
214
5db175a1
AM
215%install
216rm -rf $RPM_BUILD_ROOT
396be572 217install -d $RPM_BUILD_ROOT/var/lib/openwsman/subscriptions
5db175a1 218
d73560d5
JB
219%if %{with python3}
220%{__make} -C build-python3 install \
221 DESTDIR=$RPM_BUILD_ROOT
222
223%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
224%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
225%endif
226
396be572 227%{__make} -C build install \
5db175a1
AM
228 DESTDIR=$RPM_BUILD_ROOT
229
d73560d5 230%if %{with python2}
685db724
JB
231%py_comp $RPM_BUILD_ROOT%{py_sitedir}
232%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
233%py_postclean
d73560d5 234%endif
685db724 235
5db175a1
AM
236%clean
237rm -rf $RPM_BUILD_ROOT
238
685db724
JB
239%post libs -p /sbin/ldconfig
240%postun libs -p /sbin/ldconfig
5db175a1
AM
241
242%files
243%defattr(644,root,root,755)
6961ea6a 244%doc AUTHORS ChangeLog README.md TODO
5db175a1 245%attr(755,root,root) %{_sbindir}/openwsmand
5db175a1
AM
246%dir %{_libdir}/openwsman
247%dir %{_libdir}/openwsman/authenticators
396be572 248%attr(755,root,root) %{_libdir}/openwsman/authenticators/libwsman_*.so*
5db175a1 249%dir %{_libdir}/openwsman/plugins
396be572 250%attr(755,root,root) %{_libdir}/openwsman/plugins/libwsman_*.so*
6961ea6a 251%attr(755,root,root) %{_libdir}/openwsman/plugins/libredirect.so*
396be572
JB
252%dir %{_sysconfdir}/openwsman
253%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openwsman/openwsman.conf
93eab964 254%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openwsman/openwsman_client.conf
396be572
JB
255%attr(754,root,root) %{_sysconfdir}/openwsman/owsmangencert.sh
256%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openwsman/ssleay.cnf
257%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/openwsman
6961ea6a 258%dir /var/lib/openwsman
83b69cfd 259%dir /var/lib/openwsman/subscriptions
5db175a1 260
685db724
JB
261%files libs
262%defattr(644,root,root,755)
263%attr(755,root,root) %{_libdir}/libwsman.so.*.*.*
264%attr(755,root,root) %ghost %{_libdir}/libwsman.so.1
265%attr(755,root,root) %{_libdir}/libwsman_client.so.*.*.*
138a0c32 266%attr(755,root,root) %ghost %{_libdir}/libwsman_client.so.4
685db724
JB
267%attr(755,root,root) %{_libdir}/libwsman_clientpp.so.*.*.*
268%attr(755,root,root) %ghost %{_libdir}/libwsman_clientpp.so.1
269%attr(755,root,root) %{_libdir}/libwsman_curl_client_transport.so.*.*.*
270%attr(755,root,root) %ghost %{_libdir}/libwsman_curl_client_transport.so.1
271%attr(755,root,root) %{_libdir}/libwsman_server.so.*.*.*
272%attr(755,root,root) %ghost %{_libdir}/libwsman_server.so.1
273
5db175a1
AM
274%files devel
275%defattr(644,root,root,755)
396be572
JB
276%attr(755,root,root) %{_libdir}/libwsman.so
277%attr(755,root,root) %{_libdir}/libwsman_client.so
278%attr(755,root,root) %{_libdir}/libwsman_clientpp.so
279%attr(755,root,root) %{_libdir}/libwsman_curl_client_transport.so
280%attr(755,root,root) %{_libdir}/libwsman_server.so
5db175a1 281%{_includedir}/openwsman
396be572
JB
282%{_pkgconfigdir}/openwsman.pc
283%{_pkgconfigdir}/openwsman++.pc
284%{_pkgconfigdir}/openwsman-server.pc
685db724 285
a06ea685 286%if %{with java}
ce0d47d3
JB
287%files -n java-openwsman
288%defattr(644,root,root,755)
289%{_javadir}/openwsman-%{_target_cpu}-%{version}.jar
a06ea685 290%endif
ce0d47d3 291
685db724
JB
292%files -n perl-openwsman
293%defattr(644,root,root,755)
685db724 294%{perl_vendorlib}/openwsman.pm
6961ea6a 295%attr(755,root,root) %{perl_vendorarch}/openwsman.so
685db724 296
d73560d5 297%if %{with python2}
685db724
JB
298%files -n python-openwsman
299%defattr(644,root,root,755)
685db724 300%{py_sitedir}/pywsman.py[co]
6961ea6a 301%attr(755,root,root) %{py_sitedir}/_pywsman.so
d73560d5
JB
302%endif
303
304%if %{with python3}
305%files -n python3-openwsman
306%defattr(644,root,root,755)
307%{py3_sitedir}/pywsman.py
308%{py3_sitedir}/__pycache__/pywsman.cpython-*.py[co]
309%attr(755,root,root) %{py3_sitedir}/_pywsman.so
310%endif
ce0d47d3 311
d59a0e35 312%if %{with ruby}
ce0d47d3
JB
313%files -n ruby-openwsman
314%defattr(644,root,root,755)
b97ca65a 315%attr(755,root,root) %{_bindir}/winrs
8b81a7dd 316%{ruby_vendorlibdir}/openwsmanplugin.rb
6961ea6a 317%{ruby_vendorlibdir}/openwsman.rb
8b81a7dd 318%{ruby_vendorlibdir}/openwsman
6961ea6a 319%attr(755,root,root) %{ruby_vendorarchdir}/_openwsman.so
d59a0e35 320%endif
This page took 0.614029 seconds and 4 git commands to generate.