]> git.pld-linux.org Git - packages/openvpn.git/blame - openvpn.spec
- partial check-files cleanup, verbose man,include files
[packages/openvpn.git] / openvpn.spec
CommitLineData
3a40fd75
JK
1
2# Conditional build:
3%bcond_without pkcs11 # build without PKCS#11 support
4
1e54a8c4 5Summary: VPN Daemon
f284e4d9 6Summary(pl.UTF-8): Serwer VPN
1e54a8c4 7Name: openvpn
0603da41 8Version: 2.3.1
d073bea7 9Release: 1
1e54a8c4
AM
10License: GPL
11Group: Networking/Daemons
6a22ca81 12Source0: http://swupdate.openvpn.net/community/releases/%{name}-%{version}.tar.gz
0603da41 13# Source0-md5: 57a3b64597fc37b7842a3fde354d8bbe
1e54a8c4
AM
14Source1: %{name}.init
15Source2: %{name}.sysconfig
d073bea7
AM
16Source3: %{name}.tmpfiles
17Patch0: %{name}-pam.patch
72e50cf3 18URL: http://www.openvpn.net/
a32abac3
JB
19BuildRequires: autoconf
20BuildRequires: automake
c4f969c4 21BuildRequires: libselinux-devel
1e54a8c4 22BuildRequires: lzo-devel
2d7ad149 23BuildRequires: openssl-devel >= 0.9.7d
7367fd64 24BuildRequires: pam-devel
3a40fd75 25%{?with_pkcs11:BuildRequires: pkcs11-helper-devel}
60554416 26BuildRequires: rpmbuild(macros) >= 1.268
a32abac3 27Requires(post,preun): /sbin/chkconfig
dc577c8b 28Requires: /sbin/ip
be1312a6 29Requires: rc-scripts >= 0.4.3.0
1a7a867b 30Conflicts: kernel < 2.4
1e54a8c4
AM
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%define _localstatedir /var
34
35%description
36OpenVPN is a robust and highly configurable VPN (Virtual Private
37Network) daemon which can be used to securely link two or more private
38networks using an encrypted tunnel over the internet.
39
22031f4a 40%description -l pl.UTF-8
1e54a8c4 41OpenVPN jest mocnym i silnie konfigurowalnym serwerem VPN (Wirtualne
22031f4a
JR
42Sieci Prywatne), który może być użyty do bezpiecznego łączenia dwóch
43lub więcej prywatnych sieci używając zaszyfrowanego tunelu poprzez
1e54a8c4
AM
44internet.
45
088b9e85 46%package devel
a1c1b5a0 47Summary: Header files for OpenVPN plugins development
f284e4d9 48Summary(pl.UTF-8): Pliki nagłówkowe do tworzenia wtyczek OpenVPN
088b9e85
ER
49Group: Development/Libraries
50
51%description devel
a1c1b5a0
JB
52This is the package containing the header files for OpenVPN plugins
53development.
54
22031f4a
JR
55%description devel -l pl.UTF-8
56Ten pakiet zawiera pliki nagłówkowe do tworzenia wtyczek OpenVPN.
088b9e85 57
1e54a8c4 58%prep
da7b9d5f 59%setup -q
7c5604b6 60%patch0 -p1
727c4226 61
6b9f12e5
ER
62sed -e 's,/''usr/lib/openvpn,%{_libdir}/%{name},' %{SOURCE3} > contrib/update-resolv-conf
63
1e54a8c4 64%build
d073bea7 65%{__aclocal} -I m4
8abf6e16 66%{__autoheader}
67%{__autoconf}
68%{__automake}
73042e26 69
8abf6e16 70%configure \
3a40fd75 71 %{!?with_pkcs11:--disable-pkcs11} \
6f1eceea 72 --enable-password-save \
43fa42e4 73 --enable-iproute2 \
c4f969c4
AM
74 --enable-selinux \
75 --enable-systemd \
d073bea7
AM
76 IFCONFIG=/sbin/ifconfig \
77 IPROUTE=/sbin/ip \
78 ROUTE=/sbin/route \
79 NETSTAT=/bin/netstat
43fa42e4 80
d073bea7 81%{__make}
088b9e85 82
1e54a8c4
AM
83%install
84rm -rf $RPM_BUILD_ROOT
c13903eb 85install -d $RPM_BUILD_ROOT{%{_sysconfdir}/openvpn,%{_sbindir},%{_mandir}/man8} \
f3908354
JR
86 $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},/var/run/openvpn,%{_includedir}} \
87 $RPM_BUILD_ROOT{%{_libdir}/%{name}/plugins,/usr/lib/tmpfiles.d}
1e54a8c4 88
d073bea7
AM
89%{__make} install \
90 DESTDIR=$RPM_BUILD_ROOT
1e54a8c4 91
55a7ee18
JK
92install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
93install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
d073bea7 94install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
6f1eceea 95
388387bf
JB
96%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
97
1e54a8c4
AM
98%clean
99rm -rf $RPM_BUILD_ROOT
100
55a7ee18
JK
101%post
102/sbin/chkconfig --add openvpn
1a7a867b 103%service openvpn restart "OpenVPN"
55a7ee18
JK
104
105%preun
106if [ "$1" = "0" ]; then
1a7a867b 107 %service openvpn stop
55a7ee18 108 /sbin/chkconfig --del openvpn
a34b9b51 109fi
55a7ee18 110
1e54a8c4
AM
111%files
112%defattr(644,root,root,755)
d073bea7
AM
113%doc AUTHORS README* ChangeLog sample/sample-{config-files,keys,scripts} doc/management-notes.txt
114%doc *.IPv6 src/plugins/*/README.*
f063e411 115%dir %{_sysconfdir}/openvpn
088b9e85 116%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
1a7a867b 117%attr(755,root,root) %{_sbindir}/openvpn
e06b2f01 118%attr(754,root,root) /etc/rc.d/init.d/%{name}
088b9e85
ER
119%dir %{_libdir}/%{name}
120%dir %{_libdir}/%{name}/plugins
121%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
388387bf 122%{_mandir}/man8/openvpn.8*
55a7ee18 123%dir /var/run/openvpn
f3908354 124/usr/lib/tmpfiles.d/%{name}.conf
088b9e85
ER
125
126%files devel
127%defattr(644,root,root,755)
d073bea7 128%doc doc/README.plugins sample/sample-plugins
388387bf 129%{_includedir}/openvpn-plugin.h
This page took 0.064684 seconds and 4 git commands to generate.