]> git.pld-linux.org Git - packages/openfec.git/blame - openfec.spec
- package one more header (of_mem.h)
[packages/openfec.git] / openfec.spec
CommitLineData
9611f776
JB
1Summary: Application-Level Forward Erasure Correction codes
2Summary(pl.UTF-8): Kody korygujące dla usuniętych informacji działające w warstwie aplikacji
3Name: openfec
4Version: 1.4.2
5%define tagver %(echo %{version} | tr . _)
6Release: 1
7License: CeCILL-C
8Group: Libraries
9#Source0Download: http://openfec.org/downloads.html
10Source0: http://openfec.org/files/%{name}_v%{tagver}.tgz
11# Source0-md5: c4f8b0aa3e9352f2e713e3db2885ea1c
12URL: http://openfec.org/
13BuildRequires: cmake >= 2.6
14BuildRequires: rpmbuild(macros) >= 1.605
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18OpenFEC library implements Application-Level Forward Erasure
19Correction codes, or AL-FEC (also called UL-FEC, for Upper-Layers
20FEC). The idea, in one line, is to add redundancy in order to be able
21to recover from erasures. Because of their position in the
22communication stack, these codes are implemented as software codecs,
23and they find many applications in robust transmission and distrituted
24storage systems.
25
26%description -l pl.UTF-8
27Biblioteka OpenFEC implementuje kody korygujące dla usuniętych
28informacji działające w warstwie aplikacji (AL-FEC, UL-FEC -
29Application-Level Forward Erasure Correction, Upper-Layers Forward
30Erasure Correction). Idea to w skrócie dodanie redundancji, aby
31umożliwić odtworzenie usuniętych informacji. Ze względu na położenie w
32stosie komunikacyjnym kody te są zaimplementowane jako programowe
33kodeki, mające zastosowanie w mocnych systemach transmisji i
34przechowywania danych.
35
36%package devel
37Summary: Header files for OpenFEC library
38Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenFEC
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43Header files for OpenFEC library.
44
45%description devel -l pl.UTF-8
46Pliki nagłówkowe biblioteki OpenFEC.
47
48%prep
49%setup -q -n %{name}_v%{version}
50
51%build
52install -d build
53cd build
54%cmake ..
55
56%{__make}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}}
61install -d $RPM_BUILD_ROOT%{_includedir}/openfec/{lib_advanced/ldpc_from_file,lib_common,lib_stable/{2d_parity_matrix,ldpc_staircase,reed-solomon_gf_2_{8,m}}}
62
63install bin/Release/eperftool $RPM_BUILD_ROOT%{_bindir}
64cp -a bin/Release/libopenfec.so* $RPM_BUILD_ROOT%{_libdir}
65
66cp -p src/lib_advanced/ldpc_from_file/{of_codec_profile,of_ldpc_ff_api}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_advanced/ldpc_from_file
86f0b2a7 67cp -p src/lib_common/{of_debug,of_mem,of_openfec_api,of_openfec_profile,of_types}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_common
9611f776
JB
68cp -p src/lib_stable/2d_parity_matrix/{of_2d_parity_api,of_codec_profile}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_stable/2d_parity_matrix
69cp -p src/lib_stable/ldpc_staircase/{of_codec_profile,of_ldpc_staircase_api}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_stable/ldpc_staircase
70cp -p src/lib_stable/reed-solomon_gf_2_8/{of_codec_profile,of_reed-solomon_gf_2_8_api}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_stable/reed-solomon_gf_2_8
71cp -p src/lib_stable/reed-solomon_gf_2_m/{of_codec_profile,of_reed-solomon_gf_2_m_api}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_stable/reed-solomon_gf_2_m
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post -p /sbin/ldconfig
77%postun -p /sbin/ldconfig
78
79%files
80%defattr(644,root,root,755)
81%doc CHANGELOG LICENCE_CeCILL-C_V1-en.txt Licence_CeCILL_V2-en.txt README
82%attr(755,root,root) %{_bindir}/eperftool
83%attr(755,root,root) %{_libdir}/libopenfec.so.*.*.*
84%attr(755,root,root) %ghost %{_libdir}/libopenfec.so.1
85
86%files devel
87%defattr(644,root,root,755)
88%attr(755,root,root) %{_libdir}/libopenfec.so
89%{_includedir}/openfec
This page took 0.097869 seconds and 4 git commands to generate.