]> git.pld-linux.org Git - packages/ois.git/blame - ois.spec
- fix missing c headers for c++ files
[packages/ois.git] / ois.spec
CommitLineData
cef5c171 1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
67f289b6 5%define file_version %(echo %{version} | tr . -)
cef5c171 6Summary: Object Oriented Input System
ed09c689 7Summary(pl.UTF-8): Zorientowany obiektowo system wejścia
cef5c171 8Name: ois
67f289b6 9Version: 1.3
a63b1fe0 10Release: 2
cef5c171 11License: zlib/libpng
12Group: Libraries
67f289b6 13Source0: http://downloads.sourceforge.net/wgois/%{name}_v%{file_version}.tar.gz
14# Source0-md5: 9697fead17eac6025151cd2e1fca1518
a63b1fe0 15Patch0: gcc.patch
67f289b6 16URL: http://ostatic.com/wgois/
d6b2c6d4 17BuildRequires: autoconf >= 2.50
cef5c171 18BuildRequires: automake >= 1.6
cef5c171 19BuildRequires: libstdc++-devel
7efe2b2d 20BuildRequires: libtool >= 2:1.4
cef5c171 21BuildRequires: xorg-lib-libXaw-devel
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
7efe2b2d 25The goal of OIS is shield the application programmer from having to
26rewrite input systems from scratch for each project.
cef5c171 27
ed09c689 28%description -l pl.UTF-8
29Celem projektu OIS jest ochrona twórcy aplikacji przed przepisywaniem
30na nowo systemów wejścia w każdym projekcie.
31
cef5c171 32%package devel
d6b2c6d4
JB
33Summary: Header files for OIS library
34Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OIS
cef5c171 35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: libstdc++-devel
d6b2c6d4 38Requires: xorg-lib-libXaw-devel
cef5c171 39
40%description devel
d6b2c6d4 41Header files for OIS library.
cef5c171 42
e158a79e 43%description devel -l pl.UTF-8
d6b2c6d4 44Pliki nagłówkowe biblioteki OIS.
ed09c689 45
cef5c171 46%package static
d6b2c6d4
JB
47Summary: Static OIS library
48Summary(pl.UTF-8): Statyczna biblioteka OIS
cef5c171 49Group: Development/Libraries
50Requires: %{name}-devel = %{version}-%{release}
51
52%description static
d6b2c6d4 53Static OIS library.
cef5c171 54
e158a79e 55%description static -l pl.UTF-8
d6b2c6d4 56Statyczna biblioteka OIS.
ed09c689 57
cef5c171 58%prep
67f289b6 59%setup -q -n %{name}-v%{file_version}
a63b1fe0 60%patch0 -p1
cef5c171 61
62%build
63%{__libtoolize}
64%{__aclocal}
65%{__autoheader}
66%{__automake}
67%{__autoconf}
68%configure \
69 %{!?with_static_libs:--disable-static}
70%{__make}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75%{__make} install \
76 DESTDIR=$RPM_BUILD_ROOT
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post -p /sbin/ldconfig
82%postun -p /sbin/ldconfig
83
84%files
85%defattr(644,root,root,755)
d6b2c6d4 86%attr(755,root,root) %{_libdir}/libOIS-*.*.*.so
cef5c171 87
88%files devel
89%defattr(644,root,root,755)
90%attr(755,root,root) %{_libdir}/libOIS.so
d6b2c6d4
JB
91%{_libdir}/libOIS.la
92%{_includedir}/OIS
93%{_pkgconfigdir}/OIS.pc
cef5c171 94
95%if %{with static_libs}
96%files static
97%defattr(644,root,root,755)
d6b2c6d4 98%{_libdir}/libOIS.a
cef5c171 99%endif
This page took 0.079106 seconds and 4 git commands to generate.