]> git.pld-linux.org Git - packages/ogdi.git/blame - ogdi.spec
- release 3
[packages/ogdi.git] / ogdi.spec
CommitLineData
fae9fa5b 1# TODO: separate gltpd to -server package, add init script (requires portmap)
42a3233f 2#
32f089d1 3# Conditional build:
4%bcond_without tcl # disable gui and nviz
5%bcond_without odbc # disable unixODBC support
6#
fae9fa5b 7Summary: Open Geographic Datastore Interface
5a2968b5 8Summary(pl.UTF-8): OGDI - otwarty interfejs do danych geograficznych
fae9fa5b 9Name: ogdi
2c460ea2 10Version: 3.1.6
9f44e750 11Release: 3
fae9fa5b
JB
12License: BSD-like
13Group: Applications
d5bc17e1 14Source0: http://dl.sourceforge.net/ogdi/%{name}-%{version}.tar.gz
2c460ea2 15# Source0-md5: 212ad71896aa70528ed139c95bed6511
fae9fa5b 16Source1: http://ogdi.sourceforge.net/ogdi.pdf
c7b9d0a5 17# Source1-md5: 029a8cdcd36bee73df92196ee769040e
2c460ea2 18Patch0: %{name}-pic.patch
fae9fa5b
JB
19URL: http://ogdi.sourceforge.net/
20BuildRequires: autoconf
21BuildRequires: expat-devel
22BuildRequires: proj-devel
4c1f6d28 23%{?with_tcl:BuildRequires: tcl-devel}
32f089d1 24%{?with_odbc:BuildRequires: unixODBC-devel}
fae9fa5b
JB
25BuildRequires: zlib-devel
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29OGDI is the Open Geographic Datastore Interface. OGDI is an
30application programming interface (API) that uses a standardized
31access methods to work in conjunction with GIS software packages (the
32application) and various geospatial data products. OGDI uses a
33client/server architecture to facilitate the dissemination of
34geospatial data products over any TCP/IP network, and a
35driver-oriented approach to facilitate access to several geospatial
36data products/formats.
ef94e4a2 37
d6c47a2e 38%description -l pl.UTF-8
fae9fa5b 39OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
d6c47a2e
JR
40do danych geograficznych. OGDI to API używające ustandaryzowanych
41metod dostępu do pracy z pakietami oprogramowania GIS i różnymi danymi
42geograficznymi. OGDI używa architektury klient-serwer aby udostępniać
43dane po dowolnej sieci TCP/IP oraz podejścia bazującego na
44sterownikach aby zapewnić dostęp do różnych produktów/formatów danych
fae9fa5b
JB
45geograficznych.
46
47%package devel
48Summary: OGDI header files and documentation
5a2968b5 49Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja OGDI
fae9fa5b 50Group: Development/Libraries
c7196e26 51Requires: %{name} = %{version}-%{release}
7136c5dd 52Requires: proj-devel
fae9fa5b
JB
53
54%description devel
55OGDI header files and developer's documentation.
56
d6c47a2e
JR
57%description devel -l pl.UTF-8
58Pliki nagłówkowe i dokumentacja programisty do OGDI.
fae9fa5b
JB
59
60%package odbc
61Summary: ODBC driver for OGDI
5a2968b5 62Summary(pl.UTF-8): Sterownik ODBC do OGDI
fae9fa5b 63Group: Libraries
c7196e26 64Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
65
66%description odbc
67ODBC driver for OGDI.
68
d6c47a2e 69%description odbc -l pl.UTF-8
fae9fa5b
JB
70Sterownik ODBC do OGDI.
71
72%package -n tcl-ogdi
05c5e26d 73Summary: Tcl wrapper for OGDI
5a2968b5 74Summary(pl.UTF-8): Interfejs Tcl do OGDI
fae9fa5b 75Group: Libraries
c7196e26 76Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
77
78%description -n tcl-ogdi
05c5e26d 79Tcl wrapper for OGDI.
fae9fa5b 80
d6c47a2e 81%description -n tcl-ogdi -l pl.UTF-8
05c5e26d 82Interfejs Tcl do OGDI.
fae9fa5b
JB
83
84%prep
85%setup -q
78edefe0 86%patch0 -p1
fae9fa5b
JB
87
88cp -f %{SOURCE1} .
89
90%build
91%{__autoconf}
92TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
93%configure \
94 --with-expat \
95 --with-proj \
96 --with-zlib
97
2c460ea2 98# bash because of pushd/popd used in makefiles
fae9fa5b 99%{__make} \
2c460ea2
JB
100 SHELL=/bin/bash \
101 INST_LIB=%{_libdir} \
fae9fa5b
JB
102 OPTIMIZATION="%{rpmcflags}"
103
32f089d1 104%if %{with tcl}
fae9fa5b
JB
105%{__make} -C ogdi/tcl_interface \
106 OPTIMIZATION="%{rpmcflags}" \
107 TCL_LINKLIB="-ltcl"
32f089d1 108%endif
fae9fa5b
JB
109%{__make} -C contrib/gdal \
110 OPTIMIZATION="%{rpmcflags}"
32f089d1 111%if %{with odbc}
fae9fa5b 112%{__make} -C ogdi/attr_driver/odbc \
2c460ea2 113 OPTIMIZATION="%{rpmcflags} -DDONT_TD_VOID" \
fae9fa5b 114 ODBC_LINKLIB="-lodbc"
32f089d1 115%endif
fae9fa5b
JB
116
117%install
118rm -rf $RPM_BUILD_ROOT
119
120TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
121
122%{__make} install \
2c460ea2 123 SHELL=/bin/bash \
fae9fa5b 124 INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
2c460ea2 125 INST_LIB=$RPM_BUILD_ROOT%{_libdir} \
fae9fa5b
JB
126 INST_BIN=$RPM_BUILD_ROOT%{_bindir}
127
32f089d1 128%if %{with tcl}
fae9fa5b
JB
129%{__make} install -C ogdi/tcl_interface \
130 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 131%endif
fae9fa5b 132%{__make} install -C contrib/gdal \
2c460ea2 133 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 134%if %{with odbc}
fae9fa5b 135%{__make} install -C ogdi/attr_driver/odbc \
2c460ea2 136 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 137%endif
fae9fa5b 138
fae9fa5b
JB
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%post -p /sbin/ldconfig
143%postun -p /sbin/ldconfig
144
145%files
146%defattr(644,root,root,755)
147%doc LICENSE NEWS
148%attr(755,root,root) %{_bindir}/gltpd
149%attr(755,root,root) %{_bindir}/ogdi_*
2c460ea2 150%attr(755,root,root) %{_libdir}/libogdi.so.*.*
fae9fa5b 151%dir %{_libdir}/ogdi
46ab6031 152%attr(755,root,root) %{_libdir}/ogdi/lib[!l]*.so
fae9fa5b
JB
153
154%files devel
155%defattr(644,root,root,755)
156%doc ogdi.pdf
2c460ea2 157%attr(755,root,root) %{_libdir}/libogdi.so
fae9fa5b
JB
158%{_includedir}/*.h
159
32f089d1 160%if %{with odbc}
fae9fa5b
JB
161%files odbc
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
32f089d1 164%endif
fae9fa5b 165
32f089d1 166%if %{with tcl}
fae9fa5b
JB
167%files -n tcl-ogdi
168%defattr(644,root,root,755)
2c460ea2 169%attr(755,root,root) %{_libdir}/ogdi/libecs_tcl.so
32f089d1 170%endif
This page took 0.048922 seconds and 4 git commands to generate.