]> git.pld-linux.org Git - packages/ocsync.git/blame - ocsync.spec
- Up to 0.90.2
[packages/ocsync.git] / ocsync.spec
CommitLineData
95f36765
CM
1# TODO:
2# * Add subpackage and complile time flags for plugin packages:
3# * smb backend
4# * Package documentation
d20c1c67
CM
5Summary: A user level bidirectional client only file synchronizer (owncloud version)
6Name: ocsync
ca526685
CM
7Version: 0.90.2
8Release: 0.1
d20c1c67 9License: GPL v2
236be18c 10Group: Libraries
d20c1c67 11Source0: http://download.owncloud.com/download/%{name}-%{version}.tar.bz2
ca526685 12# Source0-md5: c2a8a19289e4d7e7e8eebf8304ac39bd
d20c1c67 13URL: http://www.csync.org
d20c1c67 14BuildRequires: check
236be18c 15BuildRequires: cmake
d20c1c67 16BuildRequires: doxygen
d20c1c67 17BuildRequires: iniparser-devel
236be18c 18BuildRequires: libstdc++-devel
d20c1c67
CM
19BuildRequires: neon-devel
20BuildRequires: sqlite3-devel
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
236be18c
CM
24ocsync is the ownCloud version of csync. csync is an implementation of
25a file synchronizer which provides the feature of roaming home
26directories for Linux clients.
d20c1c67
CM
27
28%package owncloud
29Summary: Plugin files for using ownCloud backend with libraries %{name}
236be18c 30Group: Libraries
3b7d996a 31Requires: %{name} = %{version}-%{release}
d20c1c67
CM
32
33%description owncloud
236be18c
CM
34ocsync is a csync version which is temporarily maintained by the
35ownCloud community to support the ownCloud client. csync is an
36implementation of a file synchronizer which provides the feature of
37roaming home directories for Linux clients. csync makes use of
38libsmbclient in Samba/Windows environments.
d20c1c67 39
236c7f0b
CM
40%package devel
41Summary: Development header files and libraries for %{name}
236be18c 42Group: Libraries
3b7d996a 43Requires: %{name} = %{version}-%{release}
236c7f0b
CM
44
45%description devel
46Development header files and libraries for %{name}
47
d20c1c67
CM
48%prep
49%setup -q
50
51%build
52if test ! -e "build"; then
53 %{__mkdir} build
54fi
55
56cd build
57
58%cmake \
59 -DCMAKE_C_FLAGS:STRING="%{optflags}" \
60 -DCMAKE_CXX_FLAGS:STRING="%{optflags}" \
61 -DCMAKE_SKIP_RPATH=ON \
62 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
63 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
64 -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
65 -DPREFIX=%{_prefix} \
66 -DSYSCONFDIR=%{_sysconfdir} \
67 $RPM_BUILD_ROOT/%{name}-%{version} \
68 ..
69
70%{__make}
71%{__make} doc
72
73cd ..
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78cd build
79
80%{__make} install \
81 DESTDIR=$RPM_BUILD_ROOT
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
e542f5cc
CM
86%post -p /sbin/ldconfig
87%postun -p /sbin/ldconfig
88
d20c1c67
CM
89%files
90%defattr(644,root,root,755)
91%doc AUTHORS COPYING INSTALL README
92%config(noreplace) %{_sysconfdir}/ocsync/ocsync.conf
93%config(noreplace) %{_sysconfdir}/ocsync/ocsync_exclude.conf
94%attr(755,root,root) %{_bindir}/ocsync
95%dir %{_sysconfdir}/ocsync
95f36765
CM
96%attr(755,root,root) %{_libdir}/libocsync.so.*.*.*
97%ghost %{_libdir}/libocsync.so.0
d20c1c67 98%dir %{_libdir}/ocsync-0
236be18c 99%{_mandir}/man1/ocsync.1*
d20c1c67
CM
100
101%files owncloud
102%defattr(644,root,root,755)
103%{_libdir}/ocsync-0/ocsync_owncloud.so
104%{_libdir}/libhttpbflib.a
236c7f0b
CM
105
106%files devel
107%defattr(644,root,root,755)
108%attr(755,root,root) %{_libdir}/libocsync.so
7666a78b 109%dir %{_includedir}/%{name}
236c7f0b 110%{_includedir}/%{name}/*.h
This page took 0.103035 seconds and 4 git commands to generate.