]> git.pld-linux.org Git - packages/ocaml-splittable_random.git/blame - ocaml-splittable_random.spec
- typo
[packages/ocaml-splittable_random.git] / ocaml-splittable_random.spec
CommitLineData
2f6550da
JB
1#
2# Conditional build:
3%bcond_without ocaml_opt # native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
10Summary: PRNG that can be split into independent streams
11Summary(pl.UTF-8): PRNG pozwalający na dzielenie na niezależne strumienie
12Name: ocaml-splittable_random
13Version: 0.14.0
14Release: 1
15License: MIT
16Group: Libraries
17#Source0Download: https://github.com/janestreet/splittable_random/tags
18Source0: https://github.com/janestreet/splittable_random/archive/v%{version}/splittable_random-%{version}.tar.gz
19# Source0-md5: 5e557d49f4a14230e18d86aef98379a0
20URL: https://github.com/janestreet/splittable_random
21BuildRequires: ocaml >= 1:4.04.2
22BuildRequires: ocaml-base-devel >= 0.14
23BuildRequires: ocaml-base-devel < 0.15
24BuildRequires: ocaml-dune >= 2.0.0
25BuildRequires: ocaml-ppx_assert-devel >= 0.14
26BuildRequires: ocaml-ppx_assert-devel < 0.15
27BuildRequires: ocaml-ppx_bench-devel >= 0.14
28BuildRequires: ocaml-ppx_bench-devel < 0.15
29BuildRequires: ocaml-ppx_inline_test-devel >= 0.14
30BuildRequires: ocaml-ppx_inline_test-devel < 0.15
31BuildRequires: ocaml-ppx_sexp_message-devel >= 0.14
32BuildRequires: ocaml-ppx_sexp_message-devel < 0.15
33BuildRequires: ocaml-ppxlib-devel >= 0.11.0
34%requires_eq ocaml-runtime
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%define debug_package %{nil}
38
39%description
40A splittable pseudo-random number generator (SPRNG) functions like a
41PRNG in that it can be used as a stream of random values; it can also
42be "split" to produce a second, independent stream of random values.
43
44This library implements a splittable pseudo-random number generator
45that sacrifices cryptographic-quality randomness in favour of
46performance.
47
48This package contains files needed to run bytecode executables using
49splittable_random library.
50
51%description -l pl.UTF-8
52SPRNG (Splittable Pseudo-Random Number Generator) funkcjonuje tak, jak
53generator liczb pseudolosowych, który można używać jako strumień
54wartości losowych; można go także "rozdzielić" aby utworzyć drugi,
55niezależny strumień wartości losowych.
56
57Ta biblioteka implementuje podzielny generator liczb pseudolosowych
58poświęcający losowość kryptograficznej jakości na rzecz wydajności.
59
60Pakiet ten zawiera binaria potrzebne do uruchamiania programów
61używających biblioteki splittable_random.
62
63%package devel
64Summary: PRNG that can be split into independent streams - development part
58fcf8ea 65Summary(pl.UTF-8): PRNG pozwalający na dzielenie na niezależne strumienie - część programistyczna
2f6550da
JB
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
68%requires_eq ocaml
69Requires: ocaml-base-devel >= 0.14
70Requires: ocaml-ppx_assert-devel >= 0.14
71Requires: ocaml-ppx_bench-devel >= 0.14
72Requires: ocaml-ppx_inline_test-devel >= 0.14
73Requires: ocaml-ppx_sexp_message-devel >= 0.14
74Requires: ocaml-ppxlib-devel >= 0.11.0
75
76%description devel
77This package contains files needed to develop OCaml programs using
78splittable_random library.
79
80%description devel -l pl.UTF-8
81Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
82używających biblioteki splittable_random.
83
84%prep
85%setup -q -n splittable_random-%{version}
86
87%build
88dune build --verbose
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93dune install --destdir=$RPM_BUILD_ROOT
94
95# sources
96%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/splittable_random/*.ml
97# packaged as %doc
98%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/splittable_random
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%files
104%defattr(644,root,root,755)
105%doc CHANGES.md LICENSE.md README.md
106%dir %{_libdir}/ocaml/splittable_random
107%{_libdir}/ocaml/splittable_random/META
108%{_libdir}/ocaml/splittable_random/*.cma
109%if %{with ocaml_opt}
110%attr(755,root,root) %{_libdir}/ocaml/splittable_random/*.cmxs
111%endif
112
113%files devel
114%defattr(644,root,root,755)
115%{_libdir}/ocaml/splittable_random/*.cmi
116%{_libdir}/ocaml/splittable_random/*.cmt
117%{_libdir}/ocaml/splittable_random/*.cmti
118%{_libdir}/ocaml/splittable_random/*.mli
119%if %{with ocaml_opt}
120%{_libdir}/ocaml/splittable_random/splittable_random.a
121%{_libdir}/ocaml/splittable_random/*.cmx
122%{_libdir}/ocaml/splittable_random/*.cmxa
123%endif
124%{_libdir}/ocaml/splittable_random/dune-package
125%{_libdir}/ocaml/splittable_random/opam
This page took 0.061259 seconds and 4 git commands to generate.