]> git.pld-linux.org Git - packages/ocaml-rresult.git/blame - ocaml-rresult.spec
- typo
[packages/ocaml-rresult.git] / ocaml-rresult.spec
CommitLineData
4c7affa9
JB
1#
2# Conditional build:
3%bcond_without ocaml_opt # native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
10Summary: Result value combinators for OCaml
11Summary(pl.UTF-8): Kombinatory wartości wyników dla OCamla
12Name: ocaml-rresult
13Version: 0.7.0
14Release: 1
15License: ISC
16Group: Libraries
17Source0: https://erratique.ch/software/rresult/releases/rresult-%{version}.tbz
18# Source0-md5: 7f6139c00926e09f6d1aa7efdcf2e703
19URL: https://erratique.ch/software/rresult
20BuildRequires: ocaml >= 1:4.08.0
21BuildRequires: ocaml-findlib
22BuildRequires: ocaml-ocamlbuild
23BuildRequires: ocaml-topkg >= 1.0.3
24%requires_eq ocaml-runtime
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define debug_package %{nil}
28
29%description
30Rresult is an OCaml module for handling computation results and errors
31in an explicit and declarative manner, without resorting to
32exceptions. It defines combinators to operate on the "result" type
33available from OCaml 4.03 in the standard library.
34
35OCaml 4.08 provides the Stdlib.Result module which you should prefer
36to Rresult.
37
38This package contains files needed to run bytecode executables using
39rresult library.
40
41%description -l pl.UTF-8
42Rresult to moduł OCamla do obsługi wyników obliczeń i błędów w sposób
43jawny i deklaratywny, bez uciekania się do wyjątków. Definiuje
44kombinatory operujące na typie "result" dostępnym w bibliotece
45standardowej OCamla od wersji 4.03.
46
47OCaml 4.08 udostępnia moduł Stdlib.Result, który powinien być
48preferowany względem Rresult.
49
50Pakiet ten zawiera binaria potrzebne do uruchamiania programów
51używających biblioteki rresult.
52
53%package devel
54Summary: Result value combinators for OCaml - development part
b4d8a428 55Summary(pl.UTF-8): Kombinatory wartości wyników dla OCamla - część programistyczna
4c7affa9
JB
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58%requires_eq ocaml
59
60%description devel
61This package contains files needed to develop OCaml programs using
62rresult library.
63
64%description devel -l pl.UTF-8
65Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
66używających biblioteki rresult.
67
68%prep
69%setup -q -n rresult-%{version}
70
71%build
72ocaml pkg/pkg.ml build
73
74%install
75rm -rf $RPM_BUILD_ROOT
76install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/rresult
77
78cp -p _build/pkg/META _build/opam $RPM_BUILD_ROOT%{_libdir}/ocaml/rresult
79cp -p _build/src/*.{cma,cmi,cmt,cmti,mli} $RPM_BUILD_ROOT%{_libdir}/ocaml/rresult
80%if %{with ocaml_opt}
81cp -p _build/src/*.{a,cmxs,cmx,cmxa} $RPM_BUILD_ROOT%{_libdir}/ocaml/rresult
82%endif
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files
88%defattr(644,root,root,755)
89%doc CHANGES.md LICENSE.md README.md
90%dir %{_libdir}/ocaml/rresult
91%{_libdir}/ocaml/rresult/META
92%{_libdir}/ocaml/rresult/*.cma
93%if %{with ocaml_opt}
94%attr(755,root,root) %{_libdir}/ocaml/rresult/*.cmxs
95%endif
96
97%files devel
98%defattr(644,root,root,755)
99%{_libdir}/ocaml/rresult/*.cmi
100%{_libdir}/ocaml/rresult/*.cmt
101%{_libdir}/ocaml/rresult/*.cmti
102%{_libdir}/ocaml/rresult/*.mli
103%if %{with ocaml_opt}
104%{_libdir}/ocaml/rresult/rresult.a
105%{_libdir}/ocaml/rresult/rresult_top.a
106%{_libdir}/ocaml/rresult/*.cmx
107%{_libdir}/ocaml/rresult/*.cmxa
108%endif
109%{_libdir}/ocaml/rresult/opam
This page took 0.083639 seconds and 4 git commands to generate.