]> git.pld-linux.org Git - packages/ocaml-react.git/blame - ocaml-react.spec
- typo
[packages/ocaml-react.git] / ocaml-react.spec
CommitLineData
74f5a091
JB
1#
2# Conditional build:
3%bcond_without ocaml_opt # native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
10Summary: React - declarative events and signals for OCaml
11Summary(pl.UTF-8): React - deklaratywne zdarzenia i sygnały dla OCamla
12Name: ocaml-react
13Version: 1.2.1
14Release: 1
15License: ISC
16Group: Libraries
17Source0: https://erratique.ch/software/react/releases/react-%{version}.tbz
18# Source0-md5: ce1454438ce4e9d2931248d3abba1fcc
19URL: https://erratique.ch/software/react
20BuildRequires: ocaml >= 1:4.01.0
21BuildRequires: ocaml-findlib-devel
22BuildRequires: ocaml-ocamlbuild
23BuildRequires: ocaml-topkg-devel >= 0.9.0
24%requires_eq ocaml-runtime
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define debug_package %{nil}
28
29%description
30React is an OCaml module for functional reactive programming (FRP). It
31provides support to program with time varying values: declarative
32events and signals. React doesn't define any primitive event or
33signal, it lets the client choose the concrete timeline.
34
35This package contains files needed to run bytecode executables using
36OCaml react library.
37
38%description -l pl.UTF-8
39React to moduł OCamla do funkcyjnego programowania reaktywnego (FRP).
40Wspiera programowanie z wartościami zmiennymi w czasie: deklaratywnymi
41zdarzeniami i sygnałami. React nie definiuje żadnego podstawowego
42zdarzenia czy sygnału, pozwala klientowi wybrać konkretną oś czasu.
43
44Pakiet ten zawiera binaria potrzebne do uruchamiania programów
45używających biblioteki OCamla react.
46
47%package devel
48Summary: React - declarative events and signals for OCaml - development part
d7e30f84 49Summary(pl.UTF-8): React - deklaratywne zdarzenia i sygnały dla OCamla - część programistyczna
74f5a091
JB
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52%requires_eq ocaml
53
54%description devel
55This package contains files needed to develop OCaml programs using
56react library.
57
58%description devel -l pl.UTF-8
59Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
60używających biblioteki react.
61
62%prep
63%setup -q -n react-%{version}
64
65%build
66ocaml pkg/pkg.ml build
67
68%install
69rm -rf $RPM_BUILD_ROOT
70install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/react
71
72cp -p _build/pkg/META _build/opam $RPM_BUILD_ROOT%{_libdir}/ocaml/react
73cp -p _build/src/*.{cma,cmi,cmt,cmti,mli} $RPM_BUILD_ROOT%{_libdir}/ocaml/react
74%if %{with ocaml_opt}
75cp -p _build/src/*.{a,cmxs,cmx,cmxa} $RPM_BUILD_ROOT%{_libdir}/ocaml/react
76%endif
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(644,root,root,755)
83%doc CHANGES.md LICENSE.md README.md TODO.md
84%dir %{_libdir}/ocaml/react
85%{_libdir}/ocaml/react/META
86%{_libdir}/ocaml/react/*.cma
87%if %{with ocaml_opt}
88%attr(755,root,root) %{_libdir}/ocaml/react/*.cmxs
89%endif
90
91%files devel
92%defattr(644,root,root,755)
93%{_libdir}/ocaml/react/*.cmi
94%{_libdir}/ocaml/react/*.cmt
95%{_libdir}/ocaml/react/*.cmti
96%{_libdir}/ocaml/react/*.mli
97%if %{with ocaml_opt}
98%{_libdir}/ocaml/react/*.a
99%{_libdir}/ocaml/react/*.cmx
100%{_libdir}/ocaml/react/*.cmxa
101%endif
102%{_libdir}/ocaml/react/opam
This page took 0.110425 seconds and 4 git commands to generate.