]> git.pld-linux.org Git - packages/ocaml-ppx_sexp_conv.git/blame - ocaml-ppx_sexp_conv.spec
- typo
[packages/ocaml-ppx_sexp_conv.git] / ocaml-ppx_sexp_conv.spec
CommitLineData
5f5386f4
JB
1#
2# Conditional build:
3%bcond_without ocaml_opt # native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
10Summary: Deriving plugin to generate S-expression conversion functions
11Summary(pl.UTF-8): Wtyczka wywodząca do generowania funkcji konwersji S-wyrażeń
12Name: ocaml-ppx_sexp_conv
13Version: 0.14.3
14Release: 1
15License: MIT
16Group: Libraries
17#Source0Download: https://github.com/janestreet/ppx_sexp_conv/releases
18Source0: https://github.com/janestreet/ppx_sexp_conv/archive/v%{version}/ppx_sexp_conv-%{version}.tar.gz
19# Source0-md5: 25caf01245e0113e035ccefe275f85d9
20URL: https://github.com/janestreet/ppx_sexp_conv
21BuildRequires: ocaml >= 1:4.04.2
22BuildRequires: ocaml-base-devel >= 0.14
23BuildRequires: ocaml-base-devel < 0.15
24BuildRequires: ocaml-dune-devel >= 2.0.0
25BuildRequires: ocaml-ppxlib-devel >= 0.22.0
26BuildRequires: ocaml-sexplib0-devel >= 0.14
27BuildRequires: ocaml-sexplib0-devel < 0.15
28%requires_eq ocaml-runtime
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define debug_package %{nil}
32
33%description
34ppx_sexp_conv is a PPX syntax extension that generates code for
35converting OCaml types to and from S-expressions, as defined in the
36sexplib library.
37
38This package contains files needed to run bytecode executables using
39ppx_sexp_conv library.
40
41%description -l pl.UTF-8
42ppx_sexp_conv to rozszerzenie składni PPX generujące kod do konwersji
43typów OCamla do i z S-wyrażeń zgodnie z definicją w bibliotece
44sexplib.
45
46Pakiet ten zawiera binaria potrzebne do uruchamiania programów
47używających biblioteki ppx_sexp_conv.
48
49%package devel
50Summary: ppx_sexp_conv binding for OCaml - development part
cb1d7325 51Summary(pl.UTF-8): Wiązania ppx_sexp_conv dla OCamla - część programistyczna
5f5386f4
JB
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54%requires_eq ocaml
55Requires: ocaml-base-devel >= 0.14
56Requires: ocaml-dune-devel >= 2.0.0
57Requires: ocaml-ppxlib-devel >= 0.22.0
58Requires: ocaml-sexplib0-devel >= 0.14
59
60%description devel
61This package contains files needed to develop OCaml programs using
62ppx_sexp_conv library.
63
64%description devel -l pl.UTF-8
65Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
66używających biblioteki ppx_sexp_conv.
67
68%prep
69%setup -q -n ppx_sexp_conv-%{version}
70
71%build
72dune build --verbose
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77dune install --destdir=$RPM_BUILD_ROOT
78
79# sources
80%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_sexp_conv/*.ml
81%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_sexp_conv/*/*.ml
82# packaged as %doc
83%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_sexp_conv
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(644,root,root,755)
90%doc CHANGES.md LICENSE.md README.org
91%dir %{_libdir}/ocaml/ppx_sexp_conv
92%{_libdir}/ocaml/ppx_sexp_conv/META
93%{_libdir}/ocaml/ppx_sexp_conv/*.cma
94%dir %{_libdir}/ocaml/ppx_sexp_conv/expander
95%{_libdir}/ocaml/ppx_sexp_conv/expander/*.cma
96%dir %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib
97%{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cma
98%if %{with ocaml_opt}
99%attr(755,root,root) %{_libdir}/ocaml/ppx_sexp_conv/*.cmxs
100%attr(755,root,root) %{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmxs
101%attr(755,root,root) %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmxs
102%endif
103
104%files devel
105%defattr(644,root,root,755)
106%{_libdir}/ocaml/ppx_sexp_conv/*.cmi
107%{_libdir}/ocaml/ppx_sexp_conv/*.cmt
108%{_libdir}/ocaml/ppx_sexp_conv/*.cmti
109%{_libdir}/ocaml/ppx_sexp_conv/*.mli
110%{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmi
111%{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmt
112%{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmti
113%{_libdir}/ocaml/ppx_sexp_conv/expander/*.mli
114%{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmi
115%{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmt
116%if %{with ocaml_opt}
117%{_libdir}/ocaml/ppx_sexp_conv/ppx_sexp_conv.a
118%{_libdir}/ocaml/ppx_sexp_conv/*.cmx
119%{_libdir}/ocaml/ppx_sexp_conv/*.cmxa
120%{_libdir}/ocaml/ppx_sexp_conv/expander/ppx_sexp_conv_expander.a
121%{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmx
122%{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmxa
123%{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/ppx_sexp_conv_lib.a
124%{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmx
125%{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmxa
126%endif
127%{_libdir}/ocaml/ppx_sexp_conv/dune-package
128%{_libdir}/ocaml/ppx_sexp_conv/opam
This page took 0.090588 seconds and 4 git commands to generate.