]> git.pld-linux.org Git - packages/ocaml-easy-format.git/blame - ocaml-easy-format.spec
- new URLs, updated to 1.3.2; now uses dune
[packages/ocaml-easy-format.git] / ocaml-easy-format.spec
CommitLineData
4d73a89c
ER
1#
2# Conditional build:
1153ea1a 3%bcond_without ocaml_opt # build opt (native code)
4d73a89c 4
cf5c4029 5%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
037fbb73
JB
6%undefine with_ocaml_opt
7%endif
8
dcf67d86 9%define module easy-format
4d73a89c 10Summary: easy(ier) pretty printing for OCaml
1153ea1a 11Summary(pl.UTF-8): Łatwiejsze ładne wypisywanie dla OCamla
dcf67d86 12Name: ocaml-%{module}
cf5c4029
JB
13Version: 1.3.2
14Release: 1
4d73a89c
ER
15License: BSD
16Group: Libraries
cf5c4029
JB
17#Source0Download: https://github.com/ocaml-community/easy-format/releases
18Source0: https://github.com/ocaml-community/easy-format/releases/download/%{version}/%{module}-%{version}.tbz
19# Source0-md5: 8e8e2da60d3566ab1bce5e5784ae75f9
20# https://github.com/ocaml-community/easy-format/commit/c6d5ab5ef62e7a1ec20ae8a22a39b0f06ad710a8.patch
21Patch0: %{name}-compile.patch
22URL: https://github.com/ocaml-community/easy-format
23BuildRequires: ocaml >= 1:4.02.3
24BuildRequires: ocaml-dune >= 1.10
25BuildRequires: ocaml-findlib
4d73a89c
ER
26%requires_eq ocaml-runtime
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
dcf67d86
ER
29%define debug_package %{nil}
30
4d73a89c 31%description
1153ea1a
JB
32easy-format module offers a simplified interface to the Format module
33of the OCaml standard library. Input data must be converted into a
34tree using 3 kinds of nodes: atoms, lists and labelled nodes. Each
35node is bound to its own formatting parameters and a single function
36call produces the formatted output.
4d73a89c
ER
37
38%description -l pl.UTF-8
1153ea1a
JB
39Moduł easy-format oferuje uproszczony interfejs do modułu Format
40biblioteki standardowej OCamla. Dane wejściowe muszą być
41przekonwertowane do drzewa z użyciem trzech rodzajów węzłów: atomów,
42list oraz węzłów z etykietami. Każdy węzeł jest powiązany z
43parametrami formatującymi, a pojedyncze wywołanie funkcji tworzy
44sformatowane wyjście.
4d73a89c
ER
45
46%package devel
47Summary: easy-format binding for OCaml - development part
48Summary(pl.UTF-8): Wiązania easy-format dla OCamla - cześć programistyczna
49Group: Development/Libraries
50%requires_eq ocaml
be589c54 51Requires: %{name} = %{version}-%{release}
4d73a89c
ER
52
53%description devel
1153ea1a
JB
54easy-format module offers a simplified interface to the Format module
55of the OCaml standard library. Input data must be converted into a
56tree using 3 kinds of nodes: atoms, lists and labelled nodes. Each
57node is bound to its own formatting parameters and a single function
58call produces the formatted output.
59
4d73a89c 60This package contains files needed to develop OCaml programs using
1153ea1a 61easy-format library.
4d73a89c
ER
62
63%description devel -l pl.UTF-8
1153ea1a
JB
64Moduł easy-format oferuje uproszczony interfejs do modułu Format
65biblioteki standardowej OCamla. Dane wejściowe muszą być
66przekonwertowane do drzewa z użyciem trzech rodzajów węzłów: atomów,
67list oraz węzłów z etykietami. Każdy węzeł jest powiązany z
68parametrami formatującymi, a pojedyncze wywołanie funkcji tworzy
69sformatowane wyjście.
70
4d73a89c 71Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
1153ea1a 72biblioteki easy-format.
4d73a89c
ER
73
74%prep
dcf67d86 75%setup -q -n %{module}-%{version}
cf5c4029 76%patch0 -p1
4d73a89c
ER
77
78%build
cf5c4029 79dune build @all %{?_smp_mflags} --display=verbose
4d73a89c
ER
80
81%install
82rm -rf $RPM_BUILD_ROOT
1153ea1a 83
cf5c4029
JB
84dune install --destdir=$RPM_BUILD_ROOT
85
86# just sources
87%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/%{module}/easy_format.ml
88# packaged as %doc
89%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/%{module}
4d73a89c 90
4d73a89c
ER
91%clean
92rm -rf $RPM_BUILD_ROOT
93
a91c78de
JR
94%files
95%defattr(644,root,root,755)
cf5c4029 96%doc CHANGES.md LICENSE README.md
a91c78de 97%dir %{_libdir}/ocaml/%{module}
2be8dd26 98%{_libdir}/ocaml/%{module}/META
cf5c4029 99%{_libdir}/ocaml/%{module}/easy_format.cma
278e611d
JB
100%if %{with ocaml_opt}
101%attr(755,root,root) %{_libdir}/ocaml/%{module}/easy_format.cmxs
1153ea1a 102%endif
a91c78de 103
4d73a89c
ER
104%files devel
105%defattr(644,root,root,755)
cf5c4029
JB
106%{_libdir}/ocaml/%{module}/dune-package
107%{_libdir}/ocaml/%{module}/opam
278e611d 108%{_libdir}/ocaml/%{module}/easy_format.cmi
cf5c4029 109%{_libdir}/ocaml/%{module}/easy_format.cmt*
1153ea1a 110# doc?
278e611d 111%{_libdir}/ocaml/%{module}/easy_format.mli
1153ea1a 112%if %{with ocaml_opt}
cf5c4029 113%{_libdir}/ocaml/%{module}/easy_format.a
278e611d 114%{_libdir}/ocaml/%{module}/easy_format.cmx
cf5c4029 115%{_libdir}/ocaml/%{module}/easy_format.cmxa
9b7f6652 116%endif
This page took 0.076655 seconds and 4 git commands to generate.