]> git.pld-linux.org Git - packages/ocaml-cryptokit.git/blame - ocaml-cryptokit.spec
up to 1.9
[packages/ocaml-cryptokit.git] / ocaml-cryptokit.spec
CommitLineData
28697ea6 1%define ocaml_ver 1:3.09.2
cd1b6e93 2Summary: Cryptographic toolkit for OCaml
ed22a1f0 3Summary(pl.UTF-8): Biblioteka kryptograficzna dla OCamla
cd1b6e93 4Name: ocaml-cryptokit
f8d6e8cf
ER
5Version: 1.9
6Release: 1
aefc526d 7License: LGPL w/ linking exceptions
cd1b6e93 8Group: Libraries
f8d6e8cf
ER
9Source0: http://forge.ocamlcore.org/frs/download.php/1229/cryptokit-%{version}.tar.gz
10# Source0-md5: 4432a426c9d260822f4ff2b0750413de
91162c67 11URL: http://pauillac.inria.fr/~xleroy/software.html
0ae33ae3 12BuildRequires: ocaml >= %{ocaml_ver}
cd1b6e93 13BuildRequires: zlib-devel
cd1b6e93
MM
14%requires_eq ocaml-runtime
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18The Cryptokit library for Objective Caml provides a variety of
19cryptographic primitives that can be used to implement cryptographic
20protocols in security-sensitive applications. The primitives provided
21include: symmetric-key cryptography: AES, DES, Triple-DES, ARCfour, in
22ECB, CBC, CFB and OFB modes; public-key cryptography: RSA; hash
23functions and MACs: SHA-1, MD5, and MACs based on AES and DES; random
24number generation; encodings and compression: base 64, hexadecimal,
25Zlib compression.
26
27This package contains files needed to run bytecode executables using
28this library.
29
a77ceedb
JR
30%description -l pl.UTF-8
31Biblioteka Cryptokit dostarcza szeroką gamę funkcji kryptograficznych,
32które mogą być użyte w implementacji protokołów kryptograficznych w
33aplikacjach, dla których ważne jest bezpieczeństwo. Dostarczane
cd1b6e93
MM
34funkcje to: szyfry symetryczne: AES, DES, 3DES, ARCFour w trybach ECB,
35CBC, CFB oraz OFB; szyfr z kluczem publicznym RSA; kryptograficzne
a77ceedb 36funkcje skrótu i MACi: SHA-1, MD5 oraz MACi bazowane na AES oraz DES;
0ae33ae3
ER
37generacje liczb losowych; kodowania i kompresja: base 64, szesnastkowa
38oraz zlib.
cd1b6e93 39
a77ceedb
JR
40Pakiet ten zawiera binaria potrzebne do uruchamiania programów
41używających tej biblioteki.
cd1b6e93
MM
42
43%package devel
44Summary: Cryptographic toolkit for OCaml - development part
ed22a1f0 45Summary(pl.UTF-8): Biblioteka kryptograficzna dla OCamla - cześć programistyczna
cd1b6e93
MM
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48%requires_eq ocaml
49
50%description devel
51The Cryptokit library for Objective Caml provides a variety of
52cryptographic primitives that can be used to implement cryptographic
53protocols in security-sensitive applications. The primitives provided
54include: symmetric-key cryptography: AES, DES, Triple-DES, ARCfour, in
55ECB, CBC, CFB and OFB modes; public-key cryptography: RSA; hash
56functions and MACs: SHA-1, MD5, and MACs based on AES and DES; random
57number generation; encodings and compression: base 64, hexadecimal,
58Zlib compression.
59
60This package contains files needed to develop OCaml programs using
61this library.
62
a77ceedb
JR
63%description devel -l pl.UTF-8
64Biblioteka Cryptokit dostarcza szeroką gamę funkcji kryptograficznych,
65które mogą być użyte w implementacji protokołów kryptograficznych w
66aplikacjach, dla których ważne jest bezpieczeństwo. Dostarczane
cd1b6e93
MM
67funkcje to: szyfry symetryczne: AES, DES, 3DES, ARCFour w trybach ECB,
68CBC, CFB oraz OFB; szyfr z kluczem publicznym RSA; kryptograficzne
a77ceedb 69funkcje skrótu i MACi: SHA-1, MD5 oraz MACi bazowane na AES oraz DES;
0ae33ae3
ER
70generacje liczb losowych; kodowania i kompresja: base 64, szesnastkowa
71oraz zlib.
cd1b6e93 72
a77ceedb 73Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
cd1b6e93
MM
74tej biblioteki.
75
76%prep
77%setup -q -n cryptokit-%{version}
78
79%build
f72889f2
JR
80./configure \
81 --exec-prefix %{_prefix} \
82 --prefix %{_prefix} \
83 --enable-bench
84
85%{__make} all \
91162c67 86 CFLAGS="%{rpmcflags} -fPIC"
cd1b6e93
MM
87
88%install
89rm -rf $RPM_BUILD_ROOT
cd1b6e93 90install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/cryptokit
91162c67 91
f72889f2 92install _build/src/{*.cm[ixa]*,*.a,dll*.so} $RPM_BUILD_ROOT%{_libdir}/ocaml/cryptokit
cd1b6e93
MM
93(cd $RPM_BUILD_ROOT%{_libdir}/ocaml && ln -s cryptokit/dll*.so .)
94
95install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
f72889f2 96cp -r test/*.ml $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
cd1b6e93
MM
97
98install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cryptokit
99cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cryptokit/META <<EOF
f72889f2 100description = "Cryptographic primitives"
cd1b6e93
MM
101requires = "unix num"
102version = "%{version}"
103directory = "+cryptokit"
104archive(byte) = "cryptokit.cma"
105archive(native) = "cryptokit.cmxa"
f72889f2 106exists_if = "cryptokit.cma"
cd1b6e93
MM
107linkopts = ""
108EOF
109
cd1b6e93
MM
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(644,root,root,755)
f72889f2 115%doc AUTHORS.txt Changes LICENSE.txt README.txt
cd1b6e93
MM
116%dir %{_libdir}/ocaml/cryptokit
117%attr(755,root,root) %{_libdir}/ocaml/cryptokit/*.so
118%{_libdir}/ocaml/*.so
119
120%files devel
121%defattr(644,root,root,755)
f72889f2 122%doc _build/src/api-cryptokit.docdir/*
cd1b6e93
MM
123%{_libdir}/ocaml/cryptokit/*.cm[ixa]*
124%{_libdir}/ocaml/cryptokit/*.a
125%{_examplesdir}/%{name}-%{version}
126%{_libdir}/ocaml/site-lib/cryptokit
This page took 0.370985 seconds and 4 git commands to generate.