]> git.pld-linux.org Git - packages/nuget.git/blame - nuget.spec
- use mono autodeps
[packages/nuget.git] / nuget.spec
CommitLineData
d021ce86 1%include /usr/lib/rpm/macros.mono
e23030bb
JB
2Summary: Package manager for .NET/Mono development platform
3Summary(pl.UTF-8): Zarządca pakietów dla platformy programistycznej .NET/Mono
4Name: nuget
5Version: 2.8.7
6Release: 1
7License: Apache v2.0
8Group: Development/Tools
9%define veradd md510+dhx1
10#Source0: http://download.mono-project.com/sources/nuget/%{name}_%{version}+%{veradd}.orig.tar.bz2
11Source0: https://launchpad.net/ubuntu/+archive/primary/+files/%{name}_%{version}+%{veradd}.orig.tar.bz2
12# Source0-md5: 0fe8090470bf35f44f705c94d7150037
13Source1: %{name}-core.pc
14Source2: %{name}.sh
15Patch0: %{name}-fix_xdt_hintpath
16URL: http://nuget.org/
17BuildRequires: mono-devel >= 4.0
d021ce86 18BuildRequires: rpmbuild(monoautodeps)
e23030bb
JB
19BuildRequires: sed >= 4.0
20Requires: dotnet-nuget = %{version}-%{release}
21ExclusiveArch: %{ix86} %{x8664} arm aarch64 ia64 mips ppc ppc64 s390x sparc sparcv9 sparc64
22ExcludeArch: i386
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26NuGet is the package manager for the Microsoft development platform
27including .NET. The NuGet client tools provide the ability to produce
28and consume packages. The NuGet Gallery is the central package
29repository used by all package authors and consumers.
30
31%description -l pl.UTF-8
32NuGet to zarządca pakietów dla platformy programistycznej platformy
33Microsoft, w tym .NET. Narzędzia klienckie NuGet pozwalają produkować
34i konsumować pakiety. NuGet Gallery to centralne repozytorium pakietów
35używane przez wszystkich autorów i konsumentów pakietów.
36
37%package -n dotnet-nuget
38Summary: NuGet package manager library for .NET
39Summary(pl.UTF-8): Biblioteka zarządców pakietów NuGet dla .NET
40Group: Libraries
41Requires: mono >= 4.0
42
43%description -n dotnet-nuget
44NuGet package manager library for .NET.
45
46%description -n dotnet-nuget -l pl.UTF-8
47Biblioteka zarządców pakietów NuGet dla .NET.
48
49%package -n dotnet-nuget-devel
50Summary: Development files for NuGet .NET library
51Summary(pl.UTF-8): Pliki programistyczne biblioteki .NET NuGet
52Group: Development/Libraries
53Requires: dotnet-nuget = %{version}-%{release}
54Obsoletes: nuget-devel
55
56%description -n dotnet-nuget-devel
57Development files for NuGet .NET library.
58
59%description -n dotnet-nuget-devel -l pl.UTF-8
60Pliki programistyczne biblioteki .NET NuGet.
61
62%prep
63%setup -qn %{name}-git
64%{__sed} -i "s/\r//g" src/Core/Core.csproj
65%patch0 -p1
66
67# fix compile with Mono4
68find . -name "*.csproj" -print -exec sed -i 's#ToolsVersion="3.5"#ToolsVersion="4.0"#g; s#<TargetFrameworkVersion>.*</TargetFrameworkVersion>##g; s#<PropertyGroup>#<PropertyGroup><TargetFrameworkVersion>v4.5</TargetFrameworkVersion>#g' {} \;
69
70%build
71xbuild xdt/XmlTransform/Microsoft.Web.XmlTransform.csproj
72xbuild src/Core/Core.csproj /p:Configuration="Mono Release"
73xbuild src/CommandLine/CommandLine.csproj /p:Configuration="Mono Release"
74
75%install
76rm -rf $RPM_BUILD_ROOT
77install -d $RPM_BUILD_ROOT{%{_bindir},%{_pkgconfigdir},%{_prefix}/lib/mono/nuget}
78
79cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pkgconfigdir}/nuget-core.pc
80cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/nuget
81
82cp -p src/CommandLine/bin/Release/NuGet.Core.dll $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
83cp -p xdt/XmlTransform/bin/Debug/Microsoft.Web.XmlTransform.dll $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
84cp -p src/CommandLine/bin/Release/NuGet.exe $RPM_BUILD_ROOT%{_prefix}/lib/mono/nuget
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(644,root,root,755)
91%doc COPYRIGHT.txt CREDITS.txt acknowledgements.md changelog.md
92%attr(755,root,root) %{_bindir}/nuget
93%{_prefix}/lib/mono/nuget/NuGet.exe
94
95%files -n dotnet-nuget
96%defattr(644,root,root,755)
97%dir %{_prefix}/lib/mono/nuget
98%{_prefix}/lib/mono/nuget/Microsoft.Web.XmlTransform.dll
99%{_prefix}/lib/mono/nuget/NuGet.Core.dll
100
101%files -n dotnet-nuget-devel
102%defattr(644,root,root,755)
103%{_pkgconfigdir}/nuget-core.pc
This page took 0.137788 seconds and 4 git commands to generate.