]> git.pld-linux.org Git - packages/nodejs-gyp.git/blame - nodejs-gyp.spec
Down to 0.7.3, since npm declares < 0.8.0
[packages/nodejs-gyp.git] / nodejs-gyp.spec
CommitLineData
964283d8
ER
1Summary: Node.js native addon build tool
2Name: nodejs-gyp
deffbae1 3Version: 0.7.3
5b4d1be1 4Release: 1
964283d8 5License: MIT
06f427e5 6Group: Development/Libraries
964283d8
ER
7URL: https://github.com/TooTallNate/node-gyp
8Source0: http://registry.npmjs.org/node-gyp/-/node-gyp-%{version}.tgz
deffbae1 9# Source0-md5: 6ed1cda95544587a78287975cdb0ce5d
964283d8
ER
10BuildRequires: sed >= 4.0
11Requires: make
12Requires: gcc
13Requires: nodejs
14Requires: nodejs-ansi >= 0.1.0
5b4d1be1
AS
15Requires: nodejs-fstream >= 0.1.13, nodejs-fstream < 0.2.0
16Requires: nodejs-glob >= 3.0.0, nodejs-glob < 4.0.0
17Requires: nodejs-graceful-fs >= 1.0.0, nodejs-graceful-fs < 2.0.0
18Requires: nodejs-minimatch >= 0.2.0, nodejs-minimatch < 0.3.0
19Requires: nodejs-mkdirp >= 0.3.0, nodejs-mkdirp < 0.4.0
20Requires: nodejs-nopt >= 2.0.0, nodejs-nopt < 3.0.0
21Requires: nodejs-request >= 2.9.0, nodejs-request < 2.10.0
22Requires: nodejs-rimraf >= 2.0.0, nodejs-rimraf < 3.0.0
23Requires: nodejs-semver >= 1.0.0, nodejs-semver < 2.0.0
24Requires: nodejs-tar >= 0.1.12, nodejs-tar < 0.2.0
25Requires: nodejs-which >= 1.0.0, nodejs-which < 2.0.0
964283d8
ER
26Requires: python
27Obsoletes: node-node-gyp
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32node-gyp is a cross-platform command-line tool written in Node.js for
33compiling native addon modules for Node.js, which takes away the pain
34of dealing with the various differences in build platforms. It is the
35replacement to the node-waf program which is removed for node v0.8.
36
37%prep
38%setup -qc
39mv package/* .
964283d8
ER
40
41# fix shebangs
42%{__sed} -i -e '1s,^#!.*node,#!/usr/bin/node,' \
43 bin/node-gyp.js
44
964283d8
ER
45%install
46rm -rf $RPM_BUILD_ROOT
47
48install -d $RPM_BUILD_ROOT%{nodejs_libdir}/node-gyp
49cp -pr bin lib legacy package.json $RPM_BUILD_ROOT%{nodejs_libdir}/node-gyp
50
51install -d $RPM_BUILD_ROOT%{_bindir}
7347ff6a 52ln -s %{nodejs_libdir}/node-gyp/bin/node-gyp.js $RPM_BUILD_ROOT%{_bindir}/node-gyp
964283d8
ER
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(644,root,root,755)
59%doc README.md LICENSE
60%attr(755,root,root) %{_bindir}/node-gyp
7347ff6a
ER
61%dir %{nodejs_libdir}/node-gyp
62%{nodejs_libdir}/node-gyp/package.json
63%{nodejs_libdir}/node-gyp/lib
64%dir %{nodejs_libdir}/node-gyp/bin
65%attr(755,root,root) %{nodejs_libdir}/node-gyp/bin/node-gyp.js
66
67# waf based tools
68%{nodejs_libdir}/node-gyp/legacy
This page took 0.07852 seconds and 4 git commands to generate.