]> git.pld-linux.org Git - packages/nodejs-emojione.git/blame - nodejs-emojione.spec
rebuild with python 3.10
[packages/nodejs-emojione.git] / nodejs-emojione.spec
CommitLineData
536e0fd2
JB
1# TODO:
2# - php (lib/php)
3# - swift (lib/swift)
4#
5# Conditional build:
6%bcond_without python2 # CPython 2.x module
7%bcond_without python3 # CPython 3.x module
8#
9Summary: EmojiOne - complete open source emoji set
10Summary(pl.UTF-8): EmojiOne - pełny zbiór piktogramów emoji o otwartych źródłach
11Name: nodejs-emojione
12Version: 2.2.7
6d5fce9e 13Release: 6
536e0fd2
JB
14License: MIT (code), CC-BY v4.0 (artwork)
15Group: Libraries
16#Source0Download: https://github.com/Ranks/emojione/releases
17Source0: https://github.com/Ranks/emojione/archive/v%{version}/emojione-%{version}.tar.gz
18# Source0-md5: 0690ff19597b898a5c37fafb553863f8
19URL: https://github.com/Ranks/emojione
20BuildRequires: rpmbuild(macros) >= 1.714
21%if %{with python2}
22BuildRequires: python-modules >= 1:2.7
23BuildRequires: python-setuptools
24%endif
25%if %{with python3}
26BuildRequires: python3-modules >= 1:3.4
27BuildRequires: python3-setuptools
28%endif
29Requires: nodejs
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Emoji One is a complete set of emojis designed for the web. It
35includes libraries to easily convert unicode characters to shortnames
36(:smile:) and shortnames to our custom emoji images. PNG and SVG
37formats provided for the emoji images.
38
39%description -l pl.UTF-8
40Emoji One to pełny zbiór piktogramów emoji zaprojektowany dla WWW.
41Zawiera biblioteki łatwo konwertujące znaki unikodowe na krótkie nazwy
42(:smile:) i krótkie nazwy na załączone obrazki emoji. Załączone są
43piktogramy w formatach PNG i SVG.
44
45%package -n python-emojipy
46Summary: Python 2 library for working with emoji
47Summary(pl.UTF-8): Biblioteka Pythona 2 do pracy z piktogramami emoji
48Group: Development/Languages/Python
49Requires: python-modules >= 1:2.7
50Requires: python-six
51
52%description -n python-emojipy
53Python 2 library for working with emoji.
54
55%description -n python-emojipy -l pl.UTF-8
56Biblioteka Pythona 2 do pracy z piktogramami emoji.
57
58%package -n python3-emojipy
59Summary: Python 3 library for working with emoji
60Summary(pl.UTF-8): Biblioteka Pythona 3 do pracy z piktogramami emoji
61Group: Development/Languages/Python
62Requires: python3-modules >= 1:3.4
63Requires: python3-six
64
65%description -n python3-emojipy
66Python 3 library for working with emoji.
67
68%description -n python3-emojipy -l pl.UTF-8
69Biblioteka Pythona 3 do pracy z piktogramami emoji.
70
71%prep
72%setup -q -n emojione-%{version}
73
74%build
75cd lib/python
76%if %{with python2}
77%py_build
78%endif
79
80%if %{with python3}
81%py3_build
82%endif
83
84%install
85rm -rf $RPM_BUILD_ROOT
86install -d $RPM_BUILD_ROOT%{nodejs_libdir}/emojione/lib/{js,emojione-awesome}
87
88cp -pr assets $RPM_BUILD_ROOT%{nodejs_libdir}/emojione
89cp -pr lib/meteor $RPM_BUILD_ROOT%{nodejs_libdir}/emojione/lib
90cp -p lib/js/*.js $RPM_BUILD_ROOT%{nodejs_libdir}/emojione/lib/js
91cp -p emoji*.json package.json $RPM_BUILD_ROOT%{nodejs_libdir}/emojione
92
93install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94cp -a demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
95
96cd lib/python
97%if %{with python2}
98%py_install
99
100%py_postclean
101%endif
102
103%if %{with python3}
104%py3_install
105
106# only build time, requires cog module
107%{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/emojipy/create_ruleset.py
108%endif
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(644,root,root,755)
115%doc LICENSE.md README.md
116%{nodejs_libdir}/emojione
117%{_examplesdir}/%{name}-%{version}
118
119%if %{with python2}
120%files -n python-emojipy
121%defattr(644,root,root,755)
122%doc lib/python/README.md
123%{py_sitescriptdir}/emojipy
124%{py_sitescriptdir}/emojipy-0.1-py*.egg-info
125%endif
126
127%if %{with python3}
128%files -n python3-emojipy
129%defattr(644,root,root,755)
130%doc lib/python/README.md
131%{py3_sitescriptdir}/emojipy
132%{py3_sitescriptdir}/emojipy-0.1-py*.egg-info
133%endif
This page took 0.067729 seconds and 4 git commands to generate.