]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
- disable rtsig on x32. There is no sysctl on x32
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
ee4f2132 2# - /etc/sysconfig/nginx file
1c438d78 3# - missing perl build/install requires
7423f6a6 4# - mod_spdy build http://mailman.nginx.org/pipermail/nginx-devel/2012-June/002343.html patch from http://nginx.org/patches/attic/spdy/
1a66daf3 5# http://nginx.org/en/docs/http/ngx_http_spdy_module.html
ee4f2132 6#
362f5ab2 7# Conditional build for nginx:
056acc18 8%bcond_without light # don't build light version
9%bcond_without mail # don't build imap/mail proxy
10%bcond_without perl # don't build with perl module
d0c0492d 11%bcond_without addition # adds module
12%bcond_without dav # WebDAV
13%bcond_without flv # FLV stream
3d4bad81 14%bcond_without ipv6 # build without ipv6 support
d6fc4b09 15%bcond_without sub # ngx_http_sub_module
d0c0492d 16%bcond_without poll # poll
17%bcond_without realip # real ip (behind proxy)
18%bcond_without rtsig # rtsig
19%bcond_without select # select
20%bcond_without status # stats module
21%bcond_without ssl # ssl support
056acc18 22%bcond_with http_browser # header "User-agent" parser
3b14ae78 23%bcond_with rtmp # rtmp support
8cf64677 24%bcond_with threads # thread pool support
e9a11359 25%bcond_without auth_request # auth_request module
fb649fe5 26
8cf64677
WF
27%ifarch x32
28%undefine with_rtsig
29%endif
30
5d0d957d 31%define rtmp_version 1.1.7
8e1389c7 32Summary: High perfomance HTTP and reverse proxy server
185313bb 33Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
3dfa1ca2
AM
34# nginx lines:
35# - stable: production quality with stable API
36# - mainline: production quality but API can change
f9e65082 37Name: nginx
f7602fcf 38Version: 1.7.11
8cf64677 39Release: 2
51ef519b 40License: BSD-like
cbf76340 41Group: Networking/Daemons/HTTP
06e274b9 42Source0: http://nginx.org/download/%{name}-%{version}.tar.gz
f7602fcf 43# Source0-md5: 22912ba71eebd6987be47eeaff79f0f0
06e274b9 44Source1: http://nginx.net/favicon.ico
87404bf2 45# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
06e274b9 46Source2: proxy.conf
226bcc40 47Source3: %{name}.logrotate
48Source4: %{name}.mime
49Source5: %{name}-light.conf
50Source6: %{name}-light.monitrc
0da077af 51Source7: %{name}-light.init
52Source8: %{name}-mail.conf
53Source9: %{name}-mail.monitrc
54Source10: %{name}-mail.init
55Source11: %{name}-perl.conf
56Source12: %{name}-perl.monitrc
57Source13: %{name}-perl.init
58Source14: %{name}-standard.conf
59Source15: %{name}-standard.monitrc
7d80c773 60Source16: %{name}-standard.init
61Source17: %{name}-mime.types.sh
d323480a
JK
62Source18: %{name}-standard.service
63Source19: %{name}-light.service
64Source20: %{name}-perl.service
65Source21: %{name}-mail.service
5d0d957d
ER
66Source101: https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/nginx-rtmp-module-%{rtmp_version}.tar.gz
67# Source101-md5: 8006de2560db3e55bb15d110220076ac
5ca9795d 68Patch0: %{name}-no-Werror.patch
51ef519b 69URL: http://nginx.net/
dfef7372 70BuildRequires: mailcap
f9e65082 71BuildRequires: openssl-devel
f1fc9780 72BuildRequires: pcre-devel
1c438d78 73%{?with_perl:BuildRequires: perl-CGI}
d0c0492d 74%{?with_perl:BuildRequires: perl-devel}
dd2388c2 75%{?with_perl:BuildRequires: python}
1c438d78 76%{?with_perl:BuildRequires: rpm-perlprov}
d323480a 77BuildRequires: rpmbuild(macros) >= 1.644
f9e65082
ER
78BuildRequires: zlib-devel
79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
362f5ab2 81%define _sysconfdir /etc/%{name}
82%define _nginxdir /home/services/%{name}
f9e65082
ER
83
84%description
57f21172 85nginx ("engine x") is a high-performance HTTP server and reverse
86proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
894ff1f7
ER
87Sysoev for Rambler.ru, Russia's second-most visited website, where it
88has been running in production for over two and a half years. Igor has
89released the source code under a BSD-like license. Although still in
57f21172 90beta, nginx is known for its stability, rich feature set, simple
894ff1f7 91configuration, and low resource consumption.
8e1389c7 92
390f5b88 93%description -l pl.UTF-8
57f21172 94nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
95a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
96potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
056acc18 97odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
98opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
99fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1dc54c84 100prostej konfiguracji oraz małej "zasobożerności".
2ee780b1 101
1a973791
JK
102%package common
103Summary: nginx - common files
104Summary(pl.UTF-8): nginx - pliki wspólne
105Group: Networking/Daemons/HTTP
106Requires(postun): /usr/sbin/groupdel
107Requires(postun): /usr/sbin/userdel
108Requires(pre): /bin/id
109Requires(pre): /usr/bin/getgid
110Requires(pre): /usr/sbin/groupadd
111Requires(pre): /usr/sbin/useradd
112Requires: openssl
113Requires: pcre
114Requires: rc-scripts >= 0.2.0
115Requires: systemd-units >= 38
116Requires: zlib
117Provides: group(http)
118Provides: group(nginx)
119Provides: user(nginx)
120Provides: webserver
5ca9795d 121Obsoletes: nginx < 1.4.1-4.1
1a973791 122Conflicts: logrotate < 3.8.0
1a973791
JK
123
124%description common
125Common files for the nginx daemon.
126
127%description common -l pl.UTF-8
57f21172 128Niezbędne pliki dla nginx.
85600569 129
2ee780b1 130%package light
131Summary: High perfomance HTTP and reverse proxy server
7ad53968 132Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 133Group: Networking/Daemons/HTTP
85600569 134Requires(post,preun): /sbin/chkconfig
1a973791
JK
135Requires(post,preun,postun): systemd-units >= 38
136Requires: %{name}-common = %{version}-%{release}
85600569 137Requires: openssl
138Requires: pcre
139Requires: zlib
119e2f19 140Provides: nginx-daemon
2ee780b1 141Provides: webserver
142
143%description light
1a973791
JK
144nginx ("engine x") is a high-performance HTTP server and reverse
145proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
146Sysoev for Rambler.ru, Russia's second-most visited website, where it
147has been running in production for over two and a half years. Igor has
148released the source code under a BSD-like license. Although still in
149beta, nginx is known for its stability, rich feature set, simple
150configuration, and low resource consumption.
151
57f21172 152The smallest, but also the fastest nginx edition. No additional
7ad53968 153modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
2ee780b1 154
155%description light -l pl.UTF-8
1a973791 156nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
157a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
158potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 159odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
160opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
161fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
162prostej konfiguracji oraz małej "zasobożerności".
163
57f21172 164Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
1cf92547 165FLV oraz IMAP, POP3, SMTP proxy.
2ee780b1 166
167%package perl
168Summary: High perfomance HTTP and reverse proxy server
7ad53968 169Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 170Group: Networking/Daemons/HTTP
85600569 171Requires(post,preun): /sbin/chkconfig
1a973791
JK
172Requires(post,preun,postun): systemd-units >= 38
173Requires: %{name}-common = %{version}-%{release}
85600569 174Requires: openssl
1cf92547 175Provides: nginx-daemon
2ee780b1 176Provides: webserver
177
178%description perl
1a973791
JK
179nginx ("engine x") is a high-performance HTTP server and reverse
180proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
181Sysoev for Rambler.ru, Russia's second-most visited website, where it
182has been running in production for over two and a half years. Igor has
183released the source code under a BSD-like license. Although still in
184beta, nginx is known for its stability, rich feature set, simple
185configuration, and low resource consumption.
186
57f21172 187nginx with Perl support. Mail modules not included.
2ee780b1 188
189%description perl -l pl.UTF-8
1a973791 190nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
191a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
192potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 193odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
194opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
195fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
196prostej konfiguracji oraz małej "zasobożerności".
197
57f21172 198nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
2ee780b1 199
200%package mail
57f21172 201Summary: High perfomance IMAP, POP3, SMTP proxy server
202Summary(pl.UTF-8): IMAP, POP3, SMTP proxy o wysokiej wydajności
cbf76340 203Group: Networking/Daemons/HTTP
85600569 204Requires(post,preun): /sbin/chkconfig
1a973791
JK
205Requires(post,preun,postun): systemd-units >= 38
206Requires: %{name}-common = %{version}-%{release}
85600569 207Requires: openssl
208Requires: pcre
209Requires: zlib
1cf92547 210Provides: nginx-daemon
2ee780b1 211
212%description mail
1a973791
JK
213nginx ("engine x") is a high-performance HTTP server and reverse
214proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
215Sysoev for Rambler.ru, Russia's second-most visited website, where it
216has been running in production for over two and a half years. Igor has
217released the source code under a BSD-like license. Although still in
218beta, nginx is known for its stability, rich feature set, simple
219configuration, and low resource consumption.
220
57f21172 221nginx with mail support. Only mail modules included.
2ee780b1 222
223%description mail -l pl.UTF-8
1a973791 224nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
225a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
226potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 227odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
228opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
229fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
230prostej konfiguracji oraz małej "zasobożerności".
231
57f21172 232nginx ze wsparciem tylko dla modułów poczty.
2ee780b1 233
b0fa7cc6 234%package standard
57f21172 235Summary: High perfomance HTTP and reverse proxy server
4ca0234e 236Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 237Group: Networking/Daemons/HTTP
d6fc4b09 238Requires(post,preun): /sbin/chkconfig
1a973791
JK
239Requires(post,preun,postun): systemd-units >= 38
240Requires: %{name}-common = %{version}-%{release}
6de999a5 241Requires: openssl
1a973791 242Provides: nginx
1cf92547 243Provides: nginx-daemon
d6fc4b09 244Conflicts: logrotate < 3.7-4
28a25161 245
b0fa7cc6 246%description standard
1a973791
JK
247nginx ("engine x") is a high-performance HTTP server and reverse
248proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
249Sysoev for Rambler.ru, Russia's second-most visited website, where it
250has been running in production for over two and a half years. Igor has
251released the source code under a BSD-like license. Although still in
252beta, nginx is known for its stability, rich feature set, simple
253configuration, and low resource consumption.
254
57f21172 255This is standard nginx version, without Perl support and IMAP, POP3,
5ca9795d 256SMTP proxy.
fccff804 257
b0fa7cc6 258%description standard -l pl.UTF-8
1a973791 259nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
260a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
261potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 262odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
263opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
264fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
265prostej konfiguracji oraz małej "zasobożerności". ginx ("engine x")
266jest wysokowydajnym serwerem HTTP, odwrotnym proxy a także IMAP/POP3
267proxy. nginx został napisany przez Igora Sysoeva na potrzeby serwisu
268Rambler.ru. Jest to drugi pod względem ilości odwiedzin serwis w Rosji
269i działa od ponad dwóch i pół roku. Igor opublikował źródła na
270licencji BSD. Mimo, że projekt jest ciągle w fazie beta, już zasłynął
271dzięki stabilności, bogactwu dodatków, prostej konfiguracji oraz małej
272"zasobożerności".
1a973791 273
57f21172 274To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
1dc54c84 275IMAP, POP3, SMTP.
85600569 276
dd7459ac 277%package -n monit-rc-nginx
57f21172 278Summary: nginx support for monit
279Summary(pl.UTF-8): Wsparcie nginx dla monit
60b8f836 280Group: Applications/System
281URL: http://nginx.eu/
1a973791 282Requires: %{name}-common = %{version}-%{release}
1cf92547 283Requires: monit
dd7459ac 284
285%description -n monit-rc-nginx
57f21172 286monitrc file for monitoring nginx webserver.
dd7459ac 287
288%description -n monit-rc-nginx -l pl.UTF-8
57f21172 289Plik monitrc do monitorowania serwera WWW nginx.
dd7459ac 290
f9e65082 291%prep
9fc2d63c 292%setup -q %{?with_rtmp:-a101}
717159c4 293%patch0 -p0
f9e65082 294
fb649fe5
ER
295%if %{with rtmp}
296mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
297%endif
298
a8eaad11 299# build mime.types.conf
7d80c773 300#sh %{SOURCE17} /etc/mime.types
a8eaad11 301
f9e65082
ER
302%build
303# NB: not autoconf generated configure
056acc18 304cp -f configure auto/
5d0d957d 305
056acc18 306%if %{with perl}
307./configure \
308 --prefix=%{_prefix} \
4e61eac8 309 --sbin-path=%{_sbindir}/%{name}-perl \
310 --conf-path=%{_sysconfdir}/%{name}-perl.conf \
311 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
312 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
313 --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
314 --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
056acc18 315 --user=nginx \
316 --group=nginx \
317 --with-http_perl_module \
2ee780b1 318 --without-mail_pop3_module \
319 --without-mail_imap_module \
320 --without-mail_smtp_module \
056acc18 321 %{?with_addition:--with-http_addition_module} \
322 %{?with_dav:--with-http_dav_module} \
323 %{?with_flv:--with-http_flv_module} \
3d4bad81 324 %{?with_ipv6:--with-ipv6} \
d6fc4b09 325 %{?with_sub:--with-http_sub_module} \
056acc18 326 %{?with_poll:--with-poll_module} \
327 %{?with_realip:--with-http_realip_module} \
328 %{?with_rtsig:--with-rtsig_module} \
329 %{?with_select:--with-select_module} \
330 %{?with_status:--with-http_stub_status_module} \
331 %{?with_ssl:--with-http_ssl_module} \
332 %{!?with_http_browser:--without-http_browser_module} \
fb649fe5 333 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 334 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 335 %{?with_threads:--with-threads} \
ca3f3f03 336 --with-http_secure_link_module \
4e61eac8 337 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
338 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
339 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
056acc18 340 --with-cc="%{__cc}" \
341 --with-cc-opt="%{rpmcflags}" \
342 --with-ld-opt="%{rpmldflags}"
343%{__make}
4e61eac8 344mv -f objs/nginx contrib/nginx-perl
d6fc4b09 345mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
346mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
056acc18 347%endif
348
349%if %{with mail}
056acc18 350./configure \
351 --prefix=%{_prefix} \
4e61eac8 352 --sbin-path=%{_sbindir}/%{name}-mail \
353 --conf-path=%{_sysconfdir}/%{name}-mail.conf \
354 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
355 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
356 --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
357 --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
056acc18 358 --user=nginx \
359 --group=nginx \
360 --with-imap \
361 --with-mail \
362 --with-mail_ssl_module \
d6fc4b09 363 --without-http \
129a70a2 364 %{?with_ipv6:--with-ipv6} \
056acc18 365 %{?with_poll:--with-poll_module} \
056acc18 366 %{?with_rtsig:--with-rtsig_module} \
367 %{?with_select:--with-select_module} \
4e61eac8 368 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
369 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
370 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
056acc18 371 --with-cc="%{__cc}" \
372 --with-cc-opt="%{rpmcflags}" \
373 --with-ld-opt="%{rpmldflags}" \
374 %{?debug:--with-debug}
375%{__make}
4e61eac8 376mv -f objs/nginx contrib/nginx-mail
056acc18 377%endif
378
379%if %{with light}
056acc18 380./configure \
381 --prefix=%{_prefix} \
4e61eac8 382 --sbin-path=%{_sbindir}/%{name}-light \
383 --conf-path=%{_sysconfdir}/%{name}-light.conf \
384 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
385 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
386 --pid-path=%{_localstatedir}/run/%{name}-light.pid \
387 --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
056acc18 388 --user=nginx \
389 --group=nginx \
129a70a2 390 %{?with_ipv6:--with-ipv6} \
056acc18 391 %{?with_poll:--with-poll_module} \
392 %{?with_realip:--with-http_realip_module} \
393 %{?with_rtsig:--with-rtsig_module} \
394 %{?with_select:--with-select_module} \
395 %{?with_status:--with-http_stub_status_module} \
396 %{?with_ssl:--with-http_ssl_module} \
fb649fe5 397 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 398 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 399 %{?with_threads:--with-threads} \
056acc18 400 --without-http_browser_module \
1a62642d 401 --without-mail_pop3_module \
402 --without-mail_imap_module \
403 --without-mail_smtp_module \
ca3f3f03 404 --with-http_secure_link_module \
4e61eac8 405 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
406 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
407 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
056acc18 408 --with-cc="%{__cc}" \
409 --with-cc-opt="%{rpmcflags}" \
410 --with-ld-opt="%{rpmldflags}" \
411 %{?debug:--with-debug}
412%{__make}
4e61eac8 413mv -f objs/nginx contrib/nginx-light
056acc18 414%endif
415
f9e65082
ER
416./configure \
417 --prefix=%{_prefix} \
226bcc40 418 --sbin-path=%{_sbindir}/%{name}-standard \
f1686a52 419 --conf-path=%{_sysconfdir}/%{name}-standard.conf \
226bcc40 420 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
421 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
422 --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
423 --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
dfef7372
ER
424 --user=nginx \
425 --group=nginx \
d0c0492d 426 %{?with_addition:--with-http_addition_module} \
427 %{?with_dav:--with-http_dav_module} \
428 %{?with_flv:--with-http_flv_module} \
129a70a2 429 %{?with_ipv6:--with-ipv6} \
d6fc4b09 430 %{?with_sub:--with-http_sub_module} \
d0c0492d 431 %{?with_poll:--with-poll_module} \
432 %{?with_realip:--with-http_realip_module} \
362f5ab2 433 %{?with_rtsig:--with-rtsig_module} \
434 %{?with_select:--with-select_module} \
d0c0492d 435 %{?with_status:--with-http_stub_status_module} \
362f5ab2 436 %{?with_ssl:--with-http_ssl_module} \
ee4f2132 437 %{!?with_http_browser:--without-http_browser_module} \
fb649fe5 438 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 439 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 440 %{?with_threads:--with-threads} \
ca3f3f03 441 --with-http_secure_link_module \
226bcc40 442 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
443 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
444 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
f9e65082
ER
445 --with-cc="%{__cc}" \
446 --with-cc-opt="%{rpmcflags}" \
447 --with-ld-opt="%{rpmldflags}" \
448 %{?debug:--with-debug}
f9e65082
ER
449%{__make}
450
056acc18 451
f9e65082
ER
452%install
453rm -rf $RPM_BUILD_ROOT
362f5ab2 454install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
455 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
4e61eac8 456 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
226bcc40 457 $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
458 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
36b3be34 459 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{vhosts,webapps}.d} \
d323480a 460 $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
599f35f0 461 $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
f9e65082 462
5ca9795d
ER
463cp -p conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
464cp -p conf/scgi_params $RPM_BUILD_ROOT%{_sysconfdir}/scgi.params
465cp -p conf/uwsgi_params $RPM_BUILD_ROOT%{_sysconfdir}/uwsgi.params
466cp -p conf/koi-utf $RPM_BUILD_ROOT%{_sysconfdir}/koi-utf
467cp -p conf/koi-win $RPM_BUILD_ROOT%{_sysconfdir}/koi-win
468cp -p conf/win-utf $RPM_BUILD_ROOT%{_sysconfdir}/win-utf
469cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
470cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
471cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
472cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
473cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
474cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
475cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
476cp -p %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
477install -p %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
478cp -p %{SOURCE18} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-standard.service
479install -p objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
599f35f0 480ln -sf %{systemdunitdir}/%{name}-standard.service $RPM_BUILD_ROOT/etc/systemd/system/nginx.service
85600569 481
482%if %{with light}
5ca9795d
ER
483cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
484cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
485cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
486cp -p %{SOURCE19} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-light.service
487install -p contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
85600569 488%endif
489
490%if %{with mail}
5ca9795d
ER
491cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
492cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
493install -p contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
494install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
495cp -p %{SOURCE21} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-mail.service
85600569 496%endif
497
498%if %{with perl}
499install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
5ca9795d
ER
500cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
501cp -p %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
502install -p %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
503cp -p %{SOURCE20} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-perl.service
504cp -p contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
505install -p contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
506install -p contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
85600569 507%endif
f9e65082
ER
508
509rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
510rm -rf $RPM_BUILD_ROOT%{_prefix}/html
511
512%clean
513rm -rf $RPM_BUILD_ROOT
514
1a973791 515%pre common
a37373c3 516%groupadd -r -g 213 %{name}
362f5ab2 517%groupadd -g 51 http
a37373c3 518%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
362f5ab2 519%addusertogroup %{name} http
f1fc9780 520
738166d2 521%post standard
522for a in access.log error.log; do
523 if [ ! -f /var/log/%{name}/nginx-standard_$a ]; then
98376457 524 umask 022
738166d2 525 touch /var/log/%{name}/nginx-standard_$a
1cf92547 526 chown nginx:nginx /var/log/%{name}/nginx-standard_$a
738166d2 527 chmod 644 /var/log/%{name}/nginx-standard_$a
528 fi
529done
3d760264 530/sbin/chkconfig --add %{name}-standard
d323480a 531%systemd_post %{name}-standard.service
3d760264 532%service %{name}-standard restart
a20d2702 533echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-standard.conf" as config.'
599f35f0
JK
534if ! [ -L /etc/systemd/system/nginx.service ] ; then
535 ln -s %{systemdunitdir}/%{name}-standard.service /etc/systemd/system/nginx.service || :
536fi
738166d2 537
538%post light
539for a in access.log error.log; do
540 if [ ! -f /var/log/%{name}/nginx-light_$a ]; then
98376457 541 umask 022
738166d2 542 touch /var/log/%{name}/nginx-light_$a
543 chown nginx:nginx /var/log/%{name}/nginx-light_$a
544 chmod 644 /var/log/%{name}/nginx-light_$a
545 fi
546done
3d760264 547/sbin/chkconfig --add %{name}-light
d323480a 548%systemd_post %{name}-light.service
3d760264 549%service %{name}-light restart
a20d2702 550echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-light.conf" as config'
738166d2 551
552%post perl
553for a in access.log error.log; do
554 if [ ! -f /var/log/%{name}/nginx-perl_$a ]; then
98376457 555 umask 022
738166d2 556 touch /var/log/%{name}/nginx-perl_$a
557 chown nginx:nginx /var/log/%{name}/nginx-perl_$a
558 chmod 644 /var/log/%{name}/nginx-perl_$a
559 fi
560done
3d760264 561/sbin/chkconfig --add %{name}-perl
d323480a 562%systemd_post %{name}-perl.service
3d760264 563%service %{name}-perl restart
a20d2702 564echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-perl.conf" as config'
738166d2 565
566%post mail
362f5ab2 567for a in access.log error.log; do
738166d2 568 if [ ! -f /var/log/%{name}/nginx-mail_$a ]; then
98376457 569 umask 022
738166d2 570 touch /var/log/%{name}/nginx-mail_$a
571 chown nginx:nginx /var/log/%{name}/nginx-mail_$a
572 chmod 644 /var/log/%{name}/nginx-mail_$a
362f5ab2 573 fi
574done
3d760264 575/sbin/chkconfig --add %{name}-mail
d323480a 576%systemd_post %{name}-mail.service
3d760264 577%service %{name}-mail restart
a20d2702 578echo 'NOTE: this nginx daemon is using "/etc/nginx/nginx-mail.conf" as config'
f9e65082 579
b0fa7cc6 580%preun standard
7d80c773 581if [ "$1" = "0" ];then
6eef4074 582 %service %{name}-standard stop
226bcc40 583 /sbin/chkconfig --del %{name}-standard
f9e65082 584fi
d323480a 585%systemd_preun %{name}-standard.service
f9e65082 586
0663f9da 587%preun light
588if [ "$1" = "0" ]; then
6eef4074 589 %service %{name}-light stop
226bcc40 590 /sbin/chkconfig --del %{name}-light
0663f9da 591fi
d323480a 592%systemd_preun %{name}-light.service
0663f9da 593
594%preun perl
595if [ "$1" = "0" ]; then
6eef4074 596 %service %{name}-perl stop
226bcc40 597 /sbin/chkconfig --del %{name}-perl
0663f9da 598fi
d323480a 599%systemd_preun %{name}-perl.service
0663f9da 600
601%preun mail
602if [ "$1" = "0" ]; then
6eef4074 603 %service %{name}-mail stop
226bcc40 604 /sbin/chkconfig --del %{name}-mail
0663f9da 605fi
d323480a 606%systemd_preun %{name}-mail.service
0663f9da 607
1a973791 608%postun common
f1fc9780 609if [ "$1" = "0" ]; then
7d9b86c7
ER
610 %userremove %{name}
611 %groupremove %{name}
f1fc9780 612fi
613
d323480a
JK
614%postun standard
615%systemd_reload
616
617%postun light
618%systemd_reload
619
620%postun perl
621%systemd_reload
622
623%postun mail
624%systemd_reload
625
626%triggerpostun -- %{name}-standard < 1.4.1-4
627%systemd_trigger %{name}-standard.service
628
629%triggerpostun -- %{name}-light < 1.4.1-4
630%systemd_trigger %{name}-light.service
631
632%triggerpostun -- %{name}-perl < 1.4.1-4
633%systemd_trigger %{name}-perl.service
634
635%triggerpostun -- %{name}-mail < 1.4.1-4
636%systemd_trigger %{name}-mail.service
637
1a973791 638%files common
f9e65082 639%defattr(644,root,root,755)
6f8318ed 640%doc CHANGES LICENSE README html/index.html conf/nginx.conf
f9e65082 641%doc %lang(ru) CHANGES.ru
f1fc9780 642%dir %attr(754,root,root) %{_sysconfdir}
164ab75d 643%dir %{_nginxdir}
644%dir %{_nginxdir}/cgi-bin
645%dir %{_nginxdir}/html
646%dir %{_nginxdir}/errors
28a25161 647%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
98376457 648# XXX: duplicates, don't use such glob here
57f21172 649#%attr(640,root,root) %{_sysconfdir}/*[_-]*
98376457 650%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
394dc7b0 651%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.params
0bc43776
JK
652%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi.params
653%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi.params
f1fc9780 654%attr(640,root,root) %{_sysconfdir}/mime.types
57f21172 655%attr(640,root,root) %{_sysconfdir}/koi-utf
656%attr(640,root,root) %{_sysconfdir}/koi-win
657%attr(640,root,root) %{_sysconfdir}/win-utf
36b3be34
JK
658%dir %{_sysconfdir}/webapps.d
659%dir %{_sysconfdir}/vhosts.d
debe6eba
JR
660%attr(750,nginx,logs) %dir /var/log/archive/%{name}
661%attr(750,nginx,logs) /var/log/%{name}
475fecd1 662%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
cd728db7 663%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
599f35f0 664%ghost /etc/systemd/system/nginx.service
28a25161 665
b0fa7cc6 666%files standard
667%defattr(644,root,root,755)
de0bfb9b 668%attr(755,root,root) %{_sbindir}/%{name}-standard
1846cd14 669%attr(770,root,%{name}) /var/cache/%{name}-standard
0da077af 670%attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
4ddbebd7 671%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
d323480a 672%{systemdunitdir}/%{name}-standard.service
b0fa7cc6 673
85600569 674%if %{with mail}
675%files mail
676%defattr(644,root,root,755)
4e61eac8 677%attr(755,root,root) %{_sbindir}/%{name}-mail
1846cd14 678%attr(770,root,%{name}) /var/cache/%{name}-mail
0da077af 679%attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
4ddbebd7 680%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
d323480a 681%{systemdunitdir}/%{name}-mail.service
85600569 682%endif
683
684%if %{with light}
685%files light
686%defattr(644,root,root,755)
4e61eac8 687%attr(755,root,root) %{_sbindir}/%{name}-light
1846cd14 688%attr(770,root,%{name}) /var/cache/%{name}-light
0da077af 689%attr(754,root,root) /etc/rc.d/init.d/%{name}-light
4ddbebd7 690%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
d323480a 691%{systemdunitdir}/%{name}-light.service
85600569 692%endif
693
694%if %{with perl}
695%files perl
696%defattr(644,root,root,755)
4e61eac8 697%attr(755,root,root) %{_sbindir}/%{name}-perl
0da077af 698%attr(754,root,root) /etc/rc.d/init.d/%{name}-perl
f7b57295 699%attr(770,root,%{name}) /var/cache/%{name}-perl
1846cd14 700%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-perl.conf
85600569 701%dir %{perl_vendorarch}/auto/%{name}
702%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
98376457 703%{perl_vendorarch}/%{name}.pm
d323480a 704%{systemdunitdir}/%{name}-perl.service
dd7459ac 705%endif
706
707%files -n monit-rc-nginx
708%defattr(644,root,root,755)
709%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-standard.monitrc
710%if %{with perl}
1846cd14 711%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-perl.monitrc
85600569 712%endif
dd7459ac 713%if %{with light}
714%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-light.monitrc
715%endif
716%if %{with mail}
717%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-mail.monitrc
718%endif
This page took 0.423295 seconds and 4 git commands to generate.